SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 06-20-2018, 10:59 PM   #1
A2Saturn
Member
A2Saturn is on a distinguished road
 
Join Date: Nov 2010
Location: Jeffersonville, Indiana
Posts: 130

1994 SL1
Default instrument panel blower relay issue

Replaced the instrument panel fuse panel in June 2016 (photo attached) due to the blower relay getting hot, and melting the surrounding plastic. I'm experiencing the same issue again, although it's not melted quite as bad...yet. I have to jiggle the relay to get the blower fan to work.
I replaced the blower resistor in 2011, replaced the blower fan about 4 years ago, and put in a new blower switch this week. Car is stock with no mods to the electrical system. What could be causing this? What donor cars can I pick one out of? I'm on the hunt for a new panel. Current installed donor part is same year, engine and tranny. I've searched threads, but not finding much to go on.
Attached Images
File Type: jpg blower relay.jpg (120.6 KB, 5 views)

REWARD EXCELLENCE!

Add to A2Saturn's Reputation
Rate the quality of this post and help A2Saturn reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
A2Saturn is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 06-21-2018, 12:19 AM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 40,635
 

2003 L-Series 3.0L Sedan
Default Re: instrument panel blower relay issue

If the fuse panel melted in the exact same spot, did you examine the terminals underneath the fuse panel and wire(s) connecting to the terminal that burned? It may be a poor mechanical connection between wire, crimped terminal and spade lug(?) on the fuse panel. I'm not sure of actual connections between wires and fuse panels but in general, male and female spade lugs are used. More secure connections would be soldered wires to lug terminals compared to push on terminals.

Poor mechanical connections are one reason for electrical resistance heating up and melting plastic. If the terminals are severely discolored compared to nearby terminals, its a sign of loose mechanical connections contributing to high resistance, preventing good current flow. The easiest fix is if the terminal can be squeezed to make it more difficult to connect the male/female connection. A tighter fitting mechanical connection makes the metal to metal contacts better at conducting electricity with lower resistance to allow more current flow without heating up the connections. The alternative is replacing the burned and ruined terminal, crimping it on bare wires cut back to expose clean copper (not burned discolored wires) and soldering the terminal to wires.

Last edited by fdryer; 06-21-2018 at 12:27 AM..

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Instrument Panel Lights - goofy issue dhoenisch S-Series Tech 6 05-17-2013 12:30 PM
2001 instrument panel lights issue EdGs S-Series Tech 4 09-01-2010 11:16 PM
Blower relay pin #30 by-pass ajs_saturn S-Series Mods 2 11-22-2009 10:27 AM
Instrument Panel Issue, Please Help... inkdguy81 L-Series Tech 5 06-17-2009 12:25 PM
Blower motor or relay or ?? angelaw S-Series Tech 1 04-17-2009 03:14 PM


All times are GMT -5. The time now is 12:39 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.