SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 02-24-2018, 12:15 AM   #1
RangerUSA
New Member
RangerUSA is on a distinguished road
 
Join Date: Nov 2017
Posts: 3
Default Saturn L300 Bogs No Power Under Accel Flickering Electronics

Hello not sure if a thread has already been made on this specific topic but I looked and was not able to find any information on the problems I have been having.

My L300 does not respond to mild and heavy acceleration. Car drives ok with light pedal pressure but then has difficulty getting up to speed. Basically I can get it up to speed by taking my time getting through each gear.

Idle is not smooth all of the time.

Even while the car is in neutral it will not take heavy gas and bogs out. This will not usually turn the car off but can drop into low hundreds of rpms.

Another symptom that goes along with this issue is that all of the electronics surge. Headlights have slight flicker along with all indoor lights, radio, and even instrument cluster.

this is how i got the car but have not been able to solve this issue yet on my own.

I have replaced fuel filter on rear frame rail.
Replaced spark plugs.

Today I cleaned throttle body and a plate that was sticking further into the intake manifold.

Battery is new as well.

Any possible ideas anyone has I am open to trying and is highly appreciated.
Thanks

REWARD EXCELLENCE!

Add to RangerUSA's Reputation
Rate the quality of this post and help RangerUSA reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
RangerUSA is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 02-24-2018, 08:46 AM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 41,067
 

2003 L-Series 3.0L Sedan
Default Re: Saturn L300 Bogs No Power Under Accel Flickering Electronics

1-Mileage?

2-What's fuel pressure? AutoZone loans fuel pressure gauges.

3-L300s have three catalytic converters - one for each side of the V6 and a third downstream. A damaged catcon may be blocking exhaust flow, equivalent to engine constipation. Removing two O2 sensors, one on each exhaust manifold (with a temporary soup can diverter to prevent melting nearby plastic) with sudden renewed power can reveal catcon damage.

4-Main power (battery/battery cables/connections/alternator) and the drive belt system may be contributing to power fluctuations. If the drive belt is tight then have the battery and alternator tested by any auto store selling car batteries as they should be able to provide free battery and alternator tests.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 02-25-2018, 01:40 AM   #3
RangerUSA
New Member
RangerUSA is on a distinguished road
 
Join Date: Nov 2017
Posts: 3
Default Re: Saturn L300 Bogs No Power Under Accel Flickering Electronics

Quote:
Originally Posted by fdryer View Post
1-Mileage?

2-What's fuel pressure? AutoZone loans fuel pressure gauges.

3-L300s have three catalytic converters - one for each side of the V6 and a third downstream. A damaged catcon may be blocking exhaust flow, equivalent to engine constipation. Removing two O2 sensors, one on each exhaust manifold (with a temporary soup can diverter to prevent melting nearby plastic) with sudden renewed power can reveal catcon damage.

4-Main power (battery/battery cables/connections/alternator) and the drive belt system may be contributing to power fluctuations. If the drive belt is tight then have the battery and alternator tested by any auto store selling car batteries as they should be able to provide free battery and alternator tests.
Hey fdryer thanks for the response certainly means a lot.

Mileage 95k

I have not tested fuel pressure that can be one of the next things I try.

I know that there are some busted up flex hoses in the exhaust that mat have caused blockage. I know I can see exhaust blowing out tailpipe and seems to have good flow.

I have not checked belt but will double check this tomorrow. Alternator may be faulty as it is most likely original.

This is how I recieved the car and have driven it a few hundred miles in what I call herky jerky limp mode.

Again thanks for your reply
I will post my findings as soon as I find them...?

REWARD EXCELLENCE!

Add to RangerUSA's Reputation
Rate the quality of this post and help RangerUSA reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
RangerUSA is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 Saturn L200 - Loss of power-bogs out when attempting to accelerate. matousek L-Series Tech 13 09-27-2011 03:51 PM
94 SL2 bogs down, loss of power and lurching. chrisvirgo S-Series Tech 7 07-27-2006 03:04 AM
2004 L300 lights flickering. What to do? hoppy L-Series Tech 19 04-19-2005 05:04 AM
L300 lights flickering. What to do? hoppy L-Series General 21 02-12-2004 06:57 PM
L300 lights flickering. What to do? hoppy S-Series General 0 01-25-2004 06:55 PM


All times are GMT -5. The time now is 01:01 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.