SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 02-13-2018, 06:51 AM   #1
youstolemybeer
Junior Member
youstolemybeer is on a distinguished road
 
Join Date: Feb 2018
Location: St louis
Posts: 24

2001 SW2
Default dreaded p0401

Hey all, 2001 sw2. new egr (old one too gunked up to clean) clean manifold tube,clean exhaust conduit (speedometer cable trick), revs to 4000 with out egr one. New map sensor. still getting the p0401 egr insufficient.
My question. how many exhaust ports feed the egr conduit from the head. just the one or is there a connection between all 4 exhaust ports.
Thanks
Steve

REWARD EXCELLENCE!

Add to youstolemybeer's Reputation
Rate the quality of this post and help youstolemybeer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
youstolemybeer is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 02-13-2018, 10:06 AM   #2
alordofchaos
Super Member
alordofchaos is a splendid one to beholdalordofchaos is a splendid one to beholdalordofchaos is a splendid one to beholdalordofchaos is a splendid one to beholdalordofchaos is a splendid one to beholdalordofchaos is a splendid one to beholdalordofchaos is a splendid one to behold
 
alordofchaos's Avatar
 
Join Date: Jan 2009
Location: Central MI
Posts: 11,539
 

2002 SC2
1998 SL2
Default Re: dreaded p0401

Not sure and my search-fu is weak this morning, but richpin's video probably explains it (I don't think I've watched this one yet)

https://www.youtube.com/watch?v=MTsqvQrl7OA

Also, Dorman sells an EGR gasket with a screen on it. Comes in a pack with a Ford EGR gasket, around $7 or so. Might help protect the new EGR

...
I'm not worthy to grovel in the shadow of Signmaster's wisdom

11/2016 red 2002 5 spd SC2 124k DD
7/2010 Craigslist white 1997 SC2 project
12/2008 eBay silver 1998 SL2 5 spd 102k, now 201k+ miles

REWARD EXCELLENCE!

Add to alordofchaos's Reputation
Rate the quality of this post and help alordofchaos reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
alordofchaos is offline   Reply With Quote
Old 02-13-2018, 01:59 PM   #3
1996SL11.9L
Senior Member
1996SL11.9L has a spectacular aura about1996SL11.9L has a spectacular aura about
 
1996SL11.9L's Avatar
 
Join Date: Sep 2009
Location: Stouchsburg, PA
Posts: 1,785
 

2002 SL1
Default Re: dreaded p0401

It only comes from the side of the #4 cylinder exhaust port.

I'm betting you managed to punch a hole through the carbon but there is still plenty of buildup in there.

The port going into the intake manifold is clean?

REWARD EXCELLENCE!

Add to 1996SL11.9L's Reputation
Rate the quality of this post and help 1996SL11.9L reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
1996SL11.9L is offline   Reply With Quote
Old 02-13-2018, 03:51 PM   #4
youstolemybeer
Junior Member
youstolemybeer is on a distinguished road
 
Join Date: Feb 2018
Location: St louis
Posts: 24

2001 SW2
Default Re: dreaded p0401

the port to the intake is nice and clean, when I ran the speedo cable thru it came out with no carbon on it. Obviously I cant tell about the exhaust side. I think I will bend the tip of the speedometer cable about an inch from the end and run it through the exhaust to see if I can knock more loose.
Thanks for everything so far
Steve

REWARD EXCELLENCE!

Add to youstolemybeer's Reputation
Rate the quality of this post and help youstolemybeer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
youstolemybeer is offline   Reply With Quote
Old 02-13-2018, 08:15 PM   #5
youstolemybeer
Junior Member
youstolemybeer is on a distinguished road
 
Join Date: Feb 2018
Location: St louis
Posts: 24

2001 SW2
Default Re: dreaded p0401

did one better, I pulled the manifold and ran the cable thru it backwards as well. so far the car passed the egr test on the scanner. we shall see.
I was reading that the tps could cause this as well, maybe I should change it?
thanks
Steve

REWARD EXCELLENCE!

Add to youstolemybeer's Reputation
Rate the quality of this post and help youstolemybeer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
youstolemybeer is offline   Reply With Quote
Old 02-14-2018, 02:49 AM   #6
youstolemybeer
Junior Member
youstolemybeer is on a distinguished road
 
Join Date: Feb 2018
Location: St louis
Posts: 24

2001 SW2
Default Re: dreaded p0401

well that wasnt it. wife works nites so she just told me the ses light turned on after a 13 mile highway drive

REWARD EXCELLENCE!

Add to youstolemybeer's Reputation
Rate the quality of this post and help youstolemybeer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
youstolemybeer is offline   Reply With Quote
Old 02-14-2018, 02:57 AM   #7
1996SL11.9L
Senior Member
1996SL11.9L has a spectacular aura about1996SL11.9L has a spectacular aura about
 
1996SL11.9L's Avatar
 
Join Date: Sep 2009
Location: Stouchsburg, PA
Posts: 1,785
 

2002 SL1
Default Re: dreaded p0401

It's either looking for the MAP reading to go high when it opens the egr to check for flow or it's looking for the pre-cat O2 sensor to go rich. (Towards .9v)

Any vacuum or exhaust leaks that could prevent that?

Hook 12v to your egr valve and make sure it's fully opening.

REWARD EXCELLENCE!

Add to 1996SL11.9L's Reputation
Rate the quality of this post and help 1996SL11.9L reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
1996SL11.9L is offline   Reply With Quote
Old 02-14-2018, 08:19 PM   #8
youstolemybeer
Junior Member
youstolemybeer is on a distinguished road
 
Join Date: Feb 2018
Location: St louis
Posts: 24

2001 SW2
Default Re: dreaded p0401

apparently I lied about the intake tube, I did the speedometer cable thing again about 20 times and then hit it with the air compressor. BLACK dust, not a whole lot but enough (took the throttle body off to do this) then started it without the egr on. came right up to 4k rpm. Once the egr was installed I started it and let it warm up. it Idles perfect at 900 according to the tach so I dont believe I have a vacuum leak. In neutral/park it revs without any hesitation. For the heck of it I replaced the o2 sensor and the pcv valve I figure at 106k miles its time for some new stuff just to prevent problems down the road and hopefully fix this problem (I know, wishful thinking)
Any other ideas would be greatly appreciated
Thanks
Steve

REWARD EXCELLENCE!

Add to youstolemybeer's Reputation
Rate the quality of this post and help youstolemybeer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
youstolemybeer is offline   Reply With Quote
Old 02-15-2018, 12:03 AM   #9
1996SL11.9L
Senior Member
1996SL11.9L has a spectacular aura about1996SL11.9L has a spectacular aura about
 
1996SL11.9L's Avatar
 
Join Date: Sep 2009
Location: Stouchsburg, PA
Posts: 1,785
 

2002 SL1
Default Re: dreaded p0401

It should be idling at 700 in park neutral not 900rpm when it's up to temp.

If your TPS is bad isn't showing 0% at idle it will cause a high idle condition.

REWARD EXCELLENCE!

Add to 1996SL11.9L's Reputation
Rate the quality of this post and help 1996SL11.9L reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
1996SL11.9L is offline   Reply With Quote
Old 02-15-2018, 11:10 PM   #10
youstolemybeer
Junior Member
youstolemybeer is on a distinguished road
 
Join Date: Feb 2018
Location: St louis
Posts: 24

2001 SW2
Default Re: dreaded p0401

I replaced the tps, idle is now perfect. when hot its at the line below the 1 in park and inbetween the 2nd and 3rd line below the 1 in drive. I cleaned out the ports again, got more carbon out of both the intake and exhaust. I even replaced the egr connector (Sheese Jesse James used a gun) Still having the code. wth
any ideas?
Steve

REWARD EXCELLENCE!

Add to youstolemybeer's Reputation
Rate the quality of this post and help youstolemybeer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
youstolemybeer is offline   Reply With Quote
Old 02-16-2018, 11:42 AM   #11
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 40,218
 

2003 L-Series 3.0L Sedan
Default Re: dreaded p0401

The service manual describes P0401 as insufficient egr flow. Parameters testing egr valve operation occurs when the vehicle is decelerating (closed throttle) above 35 mph, engine is warm and rpm is in mid range while decelerating. The map sensor should detect a large vacuum when throttle is closed as engine rpm drops to check for egr operation.

With the egr valve removed, the engine should rev immediately to redline limits 4500 rpm(?) and bounce off the electronic rev limiter. This would indicate intake port is clear to allow air flow to have the engine free rev to its programmed limit. A blocked intake port won't allow ingesting air to maximum rev limit. The exhaust port should blow freely with black carbon deposits blowing out as the engine revs high. If all this occurs then you're likely looking at replacing the egr valve. Some here report aftermarket egr valves aren't compatible and have to find an OEM one from junk yards or buy a new OEM one.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 02-16-2018, 02:34 PM   #12
1996SL11.9L
Senior Member
1996SL11.9L has a spectacular aura about1996SL11.9L has a spectacular aura about
 
1996SL11.9L's Avatar
 
Join Date: Sep 2009
Location: Stouchsburg, PA
Posts: 1,785
 

2002 SL1
Default Re: dreaded p0401

I mentioned before to put 12v on it and make sure the pintle is fully open. I don't have the drawing handy for the pinout.

REWARD EXCELLENCE!

Add to 1996SL11.9L's Reputation
Rate the quality of this post and help 1996SL11.9L reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
1996SL11.9L is offline   Reply With Quote
Old 02-16-2018, 08:13 PM   #13
youstolemybeer
Junior Member
youstolemybeer is on a distinguished road
 
Join Date: Feb 2018
Location: St louis
Posts: 24

2001 SW2
Default Re: dreaded p0401

pintle is fully opening at 12 volts. I looked at the egr tube, took it off the head and ran some thick wire rope thru the head till I saw daylight thru the ports. I then took the intake off to make sure the egr tube was clear because I could not get the wire rope thru the tube. Its clear. I then took the exhaust off because the wire rope would not go thru, it does now. guess what. I still have the p0401.

REWARD EXCELLENCE!

Add to youstolemybeer's Reputation
Rate the quality of this post and help youstolemybeer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
youstolemybeer is offline   Reply With Quote
Old 02-19-2018, 06:58 PM   #14
TomM96
Senior Member
TomM96 will become famous soon enoughTomM96 will become famous soon enough
 
Join Date: May 2004
Location: Long Island, NY
Posts: 1,488
Default Re: dreaded p0401

OP-
maybe view:

http://www.saturnfans.com/forums/sho...d.php?t=233806

REWARD EXCELLENCE!

Add to TomM96's Reputation
Rate the quality of this post and help TomM96 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
TomM96 is offline   Reply With Quote
Old 02-20-2018, 08:23 AM   #15
youstolemybeer
Junior Member
youstolemybeer is on a distinguished road
 
Join Date: Feb 2018
Location: St louis
Posts: 24

2001 SW2
Default Re: dreaded p0401

I did all that, Im starting to wonder if the vss is crapping out on me

REWARD EXCELLENCE!

Add to youstolemybeer's Reputation
Rate the quality of this post and help youstolemybeer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
youstolemybeer is offline   Reply With Quote
Old 04-21-2018, 09:32 AM   #16
youstolemybeer
Junior Member
youstolemybeer is on a distinguished road
 
Join Date: Feb 2018
Location: St louis
Posts: 24

2001 SW2
Default Re: dreaded p0401

well Im back at it, been busy for a month so now its time to work.
here is the freeze frame
fuel sys1 CL
fuel sys2 n/a
calc load 13.7%
ect 194
stftB1 14.1%
ltft B1 -16.4%
map 6 inhg
engine rpm 1650
veh speed 41mph
tps 0.0%
air status ---

again its the PO401. please refer to the first posting for all that I have done so far.
Thank you for all

REWARD EXCELLENCE!

Add to youstolemybeer's Reputation
Rate the quality of this post and help youstolemybeer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
youstolemybeer is offline   Reply With Quote
Old 04-21-2018, 12:53 PM   #17
Cheyne
Senior Member
Cheyne will become famous soon enough
 
Join Date: Oct 2008
Posts: 1,253

2000 SL2
Default Re: dreaded p0401

Still pulling vacuum. Did you start to blow out exhaust port after last cleaning? See the carbon blowing out forcefully when first cranked? You may want to try cleaning the original EGR and/or installing the screened gasket mentioned if you're sure the exhaust side is sufficiently clean. Intake is fine if revving to limiter.

REWARD EXCELLENCE!

Add to Cheyne's Reputation
Rate the quality of this post and help Cheyne reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Cheyne is offline   Reply With Quote
Old 04-21-2018, 01:35 PM   #18
youstolemybeer
Junior Member
youstolemybeer is on a distinguished road
 
Join Date: Feb 2018
Location: St louis
Posts: 24

2001 SW2
Default Re: dreaded p0401

started it, and ran compressed air thru the both ports

REWARD EXCELLENCE!

Add to youstolemybeer's Reputation
Rate the quality of this post and help youstolemybeer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
youstolemybeer is offline   Reply With Quote
Old 04-21-2018, 06:18 PM   #19
youstolemybeer
Junior Member
youstolemybeer is on a distinguished road
 
Join Date: Feb 2018
Location: St louis
Posts: 24

2001 SW2
Default Re: dreaded p0401

I have even used a 9volt battery on the pos and ground of the valve to see if it kills the engine. It kills it quit when 9volts is applied to egr valve.

REWARD EXCELLENCE!

Add to youstolemybeer's Reputation
Rate the quality of this post and help youstolemybeer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
youstolemybeer is offline   Reply With Quote
Old 04-22-2018, 07:56 PM   #20
Cheyne
Senior Member
Cheyne will become famous soon enough
 
Join Date: Oct 2008
Posts: 1,253

2000 SL2
Default Re: dreaded p0401

Did you see a big puff of black carbon from the exhaust port when started? Sound like the car was being revved with no exhaust/muffler?

REWARD EXCELLENCE!

Add to Cheyne's Reputation
Rate the quality of this post and help Cheyne reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Cheyne is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Saturn SL P0401 Hackettbr1 S-Series General 17 02-02-2018 11:34 AM
can't rid myself of P0401 blentz S-Series Tech 5 02-01-2016 12:15 PM
Hello P0401. We meet again. Border Walker S-Series Tech 1 05-10-2014 05:49 PM
p0401 alleninpa S-Series General 1 07-27-2006 02:20 AM
p0401 alleninpa S-Series General 3 04-21-2005 05:58 AM


All times are GMT -5. The time now is 06:47 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.