SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Vue > Vue General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 10-14-2017, 03:20 PM   #1
kbar
New Member
kbar is on a distinguished road
 
Join Date: Nov 2015
Posts: 3

2005 VUE 2.2L
Default stumped by code PO171

I have recently put all these items in my 05 Vue 2.2.

New (as in rebuilt) head, new timing chains and guides, crank sensor, MAP sensor, 02 sensors, fuel pump (which came with a new fuel tank pressure sensor), thermostat and coolant temp sensor.

After I replaced the head, fuel pump and crank sensor everything was fine for about 3 weeks. Ran good, had power, no codes, improved idle and gas mileage, as you would expect after all that.

Then I started getting code PO171 system too lean and PO117 low coolant temp. I changed the throttle body temporarily with a used one from a junkyard, and it made no difference, so I took it back. (the assumption was the TPS might have been bad, and my TPS is built-in the fly-by-wire throttle body, so its 200+ bucks to change that.)

I changed the MAP sensor. I changed the temp sensor because I had changed the thermostat only a 8 months ago.

Interestingly, the fan comes on when the low temp code it set, which to me seems stupid and counter-intuitive since that will only make it lower.

I am left with 3 items in my mind to look at.

A) dirty injectors
B) low fuel pressure (even thought pump is new)
C) ECM is whacked out. (my fear) Although I can get a new one for $200 on Ebay, W/ another $150 for programming, but that $150 may not allow for my key fob to unlock that doors, another problem that I am told can ONLY be programmed by the dealer.

Any thoughts on my 3. Am I missing something ?

BTW: It seems the too lean code always comes ones when the engine is below 180, but the system is in closed loop. I check the freeze frame and it generally is at about 175 degrees.

I even blocked part of the radiator to get the temps up a bit.

Puling my hair out over this...

REWARD EXCELLENCE!

Add to kbar's Reputation
Rate the quality of this post and help kbar reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
kbar is offline   Reply With Quote
SaturnFans.com Sponsored Links
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PO171 Code NewTommie Astra Tech 5 07-14-2016 07:19 AM
PO171 code JerryHughes S-Series General 2 02-14-2012 07:43 PM
evap emissions error code...stumped loworange88 S-Series General 3 01-09-2011 02:46 PM
I'm stumped: P0133 Code Testing O2 Sensor rg567 S-Series Tech 13 03-06-2009 07:57 PM
Bought a code reader and now I am stumped Renegade S-Series General 20 06-02-2006 12:42 AM


All times are GMT -5. The time now is 06:28 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.