SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Astra > Astra Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 07-16-2017, 12:01 PM   #1
jarluk
New Member
jarluk is on a distinguished road
 
Join Date: Jul 2017
Posts: 4
Default 2009 Astra Diagnostic Error Codes, diagnostic help needed

I have these 4 error codes, vehicle was stuttering at low rev's and had check engine light on.

P0300
P0301

I have changed spark plugs to help with this but no change in performance

P0313
C1555

What are these codes? What is recommended course of action?

Should I invest in a new iginition coil pack?

REWARD EXCELLENCE!

Add to jarluk's Reputation
Rate the quality of this post and help jarluk reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
jarluk is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 07-16-2017, 12:57 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,219
 

2003 L-Series 3.0L Sedan
Default Re: 2009 Astra Diagnostic Error Codes, diagnostic help needed

P0300 is a general misfire for all four cylinders, P0301 is for misfiring in cylinder #1. If you search past threads within the Astra forums, you may see a repeating failure pattern of coil packs.

Googling for each error code will provide many sites with code definitions.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 09-05-2017, 03:58 PM   #3
DWW
Junior Member
DWW has a spectacular aura aboutDWW has a spectacular aura aboutDWW has a spectacular aura about
 
Join Date: Jan 2017
Posts: 20
Default Re: 2009 Astra Diagnostic Error Codes, diagnostic help needed

My daughter has a 2008 XR that has thrown a number of codes including 300, 301 and 313. I have replaced plugs, coil pack, mass airflow sensor and air filter. Car runs great but the CEL was still on. I recently (this past Saturday) cleared the codes and am waiting to see if the CEL comes back on.

REWARD EXCELLENCE!

Add to DWW's Reputation
Rate the quality of this post and help DWW reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
DWW is offline   Reply With Quote
Old 11-10-2017, 11:46 AM   #4
j.small17
New Member
j.small17 has a spectacular aura aboutj.small17 has a spectacular aura aboutj.small17 has a spectacular aura about
 
Join Date: Nov 2017
Location: Ottawa, On
Posts: 2

2009 Astra XE
Default Re: 2009 Astra Diagnostic Error Codes, diagnostic help needed

My 09 Astra XE is giving me 0301 and 0313 codes. Running very rough, acceleration is weak, and CEL comes and goes as I drive. Based on a few threads I've read on this site (it's been a big help for me, a new Astra driver) I figure it's either the spark plugs or ignition coils.

I replaced the spark plugs first, to see if that helps at all. The gap was bigger than .045, so I tried closing the gap (didn't help) then I put in new plugs (didn't help either).

Now, I have ordered an aftermarket ignition coil pack (Spectra Premium C-828 from eBay, also avail on Amazon.ca). It should be here in about a week. Will update when it's installed. Hopefully it gets everything back to normal!

Edit: forgot to mention some details on my car. Just purchased in July from a used dealer. 54000 km on it (up to 59K now) and drove like it was brand new. It may have been sitting for a while (lug bolts were INCREDIBLY difficult to get off to change to winter tires and the oil drain plug is seized/stuck) before I bought it.

Last edited by j.small17; 11-10-2017 at 11:53 AM..

REWARD EXCELLENCE!

Add to j.small17's Reputation
Rate the quality of this post and help j.small17 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
j.small17 is offline   Reply With Quote
Old 11-10-2017, 07:04 PM   #5
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,219
 

2003 L-Series 3.0L Sedan
Default Re: 2009 Astra Diagnostic Error Codes, diagnostic help needed

P0301 is a misfire in cylinder#1 while P0313 is a misfire detected with low fuel; https://www.engine-codes.com/p0313.html. Astra members here may have better info. Did you run the fuel tank to close to empty?

Whoever did the wheels and oil may have used gorilla techniques using a pneumatic impact wrench set for 3 million ft-lbs.......... Morons do this in laziness instead of learning what t-o-r-q-u-e [tork] means and using finesse if they insist on using pneumatic impact tools.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 11-18-2017, 05:19 PM   #6
j.small17
New Member
j.small17 has a spectacular aura aboutj.small17 has a spectacular aura aboutj.small17 has a spectacular aura about
 
Join Date: Nov 2017
Location: Ottawa, On
Posts: 2

2009 Astra XE
Default Re: 2009 Astra Diagnostic Error Codes, diagnostic help needed

Update: Ignition coil pack arrived yesterday and I installed it today. Car runs smooth and is good as new!

Re: drain plug - it seems like it was just over tightened. Was able to get it off with some TLC from a heat gun and a hammer. The O-ring on it looked dinged up (maybe it was leaking and that was excuse to over tighten) so I replaced it.

Quote:
Originally Posted by j.small17 View Post
My 09 Astra XE is giving me 0301 and 0313 codes. Running very rough, acceleration is weak, and CEL comes and goes as I drive. Based on a few threads I've read on this site (it's been a big help for me, a new Astra driver) I figure it's either the spark plugs or ignition coils.

I replaced the spark plugs first, to see if that helps at all. The gap was bigger than .045, so I tried closing the gap (didn't help) then I put in new plugs (didn't help either).

Now, I have ordered an aftermarket ignition coil pack (Spectra Premium C-828 from eBay, also avail on Amazon.ca). It should be here in about a week. Will update when it's installed. Hopefully it gets everything back to normal!

Edit: forgot to mention some details on my car. Just purchased in July from a used dealer. 54000 km on it (up to 59K now) and drove like it was brand new. It may have been sitting for a while (lug bolts were INCREDIBLY difficult to get off to change to winter tires and the oil drain plug is seized/stuck) before I bought it.

REWARD EXCELLENCE!

Add to j.small17's Reputation
Rate the quality of this post and help j.small17 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
j.small17 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Diagnostic computer codes 301 and 507 prioris S-Series Tech 1 12-20-2012 02:40 PM
OBD2 diagnostic codes....? captaintrips S-Series Tech 13 12-08-2012 04:48 PM
Diagnostic codes?? jdb30 S-Series General 4 09-27-2012 02:21 AM
Diagnostic Codes Kessler Vue Tech 3 02-22-2012 05:44 PM
Can someone help w/ my 92 saturn sl 1 and diagnostic codes?! 92teal_saturn S-Series Tech 6 09-09-2010 12:16 PM


All times are GMT -5. The time now is 09:06 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.