SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Site Information > Community Center > Introductions & Greetings
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 01-02-2016, 10:09 PM   #1
vueawd
New Member
vueawd is on a distinguished road
 
Join Date: Oct 2015
Posts: 7
Default 2007 Vue speedometer and limp

Hello
I just bought a 2007 vue 2.2L 2wd standard
The timing chain jumped and bent the valves (this is how I got it)
We changed the head out and repaired the chain and guide
we first started it and it ran fine but idled a little strange.
It would idle high and not idle down very fast.
I figured it was because we cleaned the throttle body.

the speedometer would jump around just sitting there idling. We called the last owner and they said that was new. (we looked for a missing wire but did not see anything) it had some power test driving it up and down the road.

Let it sit for a week to work on it later started it and it would not start.

The gauges did not work fuel gauge said empty.

I pulled out the ECM relay and then the guages started to work.
Put it back in and started the car. Idled the same then the speedometer started to jump higher now and did not stop jumping around.

Put it in gear then the miss fires started and went into limp mode

We unhooked the battery and hooked it back up after 20 minutes and it would idle fine but still jumping on the speedometer after just a couple minutes started to miss-fire again.

Thanks for any light.
Mark

REWARD EXCELLENCE!

Add to vueawd's Reputation
Rate the quality of this post and help vueawd reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
vueawd is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 01-03-2016, 09:16 AM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,042
 

2003 L-Series 3.0L Sedan
Default Re: 2007 Vue speedometer and limp

If I'm not mistaken, the gauges are driven by the body control module (BCM). The ecm or pcm runs the EFI system that runs the engine. You may have several problems here.

If you have an electric throttle (drive by wire throttle/pedal), you can verify pedal/throttle plate operation; with ignition on, have someone exercise the pedal as you observe the throttle plate - throttle plate movement should be in direct proportion to pedal movement.

Mileage, parts replaced in addition to repairing the engine?

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 01-06-2016, 07:50 PM   #3
vueawd
New Member
vueawd is on a distinguished road
 
Join Date: Oct 2015
Posts: 7
Default Re: 2007 Vue speedometer and limp

it has 170,000 miles
we did a remaned head
new timing chain set
cleaned throttle body
new spark plugs platinum

Since last post we checked the acc pedal sensor to the throttle body plate looks correct
changed plugs again to iridium
put a used know good coil set with ignition control module

idles better and does not go into limp mode
throttle responce is still hesitates still low in HP
In reverse gear throttle is much more responsive (maybe lower gear ratio is reason)

The speedometer is still jumping around over 100 mhp.
the door was shut idling there and the auto lock made it fun...

we found a ground strap off from head to block

My big thing right now is I would like to figure out about the speedometer

Thanks again for the help

REWARD EXCELLENCE!

Add to vueawd's Reputation
Rate the quality of this post and help vueawd reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
vueawd is offline   Reply With Quote
Old 01-06-2016, 09:32 PM   #4
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,042
 

2003 L-Series 3.0L Sedan
Default Re: 2007 Vue speedometer and limp

My only guess is the analog speedometer may be sticking. The digital signals drives the speedo and not likely to be an ecm or bcm problem.
Attached Files
File Type: pdf instrument-cluster-1-of-1.pdf (73.4 KB, 3 views)
File Type: pdf body-computer-1-of-1.pdf (67.9 KB, 2 views)

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Aura speedometer acting wacky....help!!! streetkings01 Aura General 2 07-11-2015 10:38 AM
Speedometer/Cruise Control Issue, 2007 Vue 5spd chops Vue Tech 5 12-20-2013 06:18 PM
Is my car in limp mode? aficio S-Series Tech 6 08-22-2013 06:35 AM
Limp mode or not aficio L-Series Tech 1 08-20-2013 04:45 PM
Limp Mode proveniebam S-Series Tech 1 06-20-2013 03:23 PM


All times are GMT -5. The time now is 11:16 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.