SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Site Information > Community Center > Introductions & Greetings
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 08-10-2015, 11:30 AM   #1
KellyS
New Member
KellyS is on a distinguished road
 
Join Date: Aug 2015
Posts: 1
Default Tranny or PCM problem

i have a 2000 SL1 that will not shift right. It shifts really hard from first to second, enough to bark the tires but won't shift into third or fourth. I've checked the, fuses, changed the valve body, changed the transmission, changed the connector and nothing changes. The only code that comes up is P1620, low coolant circuit.

REWARD EXCELLENCE!

Add to KellyS's Reputation
Rate the quality of this post and help KellyS reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
KellyS is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 08-12-2015, 10:58 PM   #2
robb_sc2
Member
robb_sc2 is on a distinguished road
 
Join Date: Feb 2015
Location: BC
Posts: 296
 

1999 SC2
Default Re: Tranny or PCM problem

this should probably be moved or asked in the sub-forums, maybe with some activity someone (mods?) will move it for us...

welcome to saturnfans!

...
Gold 1999 SC2 ~385k Kms

REWARD EXCELLENCE!

Add to robb_sc2's Reputation
Rate the quality of this post and help robb_sc2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
robb_sc2 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tranny Problem MustXcape S-Series Tech 11 01-30-2013 09:44 AM
03 L-300 Tranny Problem Streeves L-Series Tech 13 09-04-2012 08:58 AM
tranny problem. Please HELP! 97SLgreen S-Series Tech 11 07-17-2010 06:47 AM
Possible Tranny Problem charlie.deluca S-Series Tech 6 06-22-2009 04:58 PM
Tranny problem merc14424 S-Series Tech 3 01-27-2005 05:51 PM


All times are GMT -5. The time now is 11:28 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.