SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Site Information > Support Forum for Canadian Saturn Owners
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 07-30-2015, 07:36 PM   #1
Biggs2008
New Member
Biggs2008 is on a distinguished road
 
Join Date: Jul 2015
Location: Vancouver, British Columbia, Canada
Posts: 1

2002 SL2
Default Strangely Sluggish 2002 SL2 out of the blue... Stumped

Hey Everyone, just signed into this website, as I have found it very useful. But I am totally stumped on an issue that just came up today driving home from work.
The past 2 days I have had some trouble with the ignition. I will turn the key and nothing will happen, turn it again and again and it will start randomly fine. I replaced the starter 2 weeks ago, and it has been running fine. I was thinking it might be that I hadn't tightened one of the connections to the starter tight enough, Which I intend to check in my shop tomorrow morning.
However, today not only did I have problems with the startup (which sounded like the battery had a low charge) but when she was running I put her into reverse... nothing... until about 5000 rpm, she slowly started to move back. Put her in drive and drove normally until I started hitting traffic. When I was stopped in traffic it was very sluggish. If I put it into neutral I could Rev up normally, but if it was in drive I could push the petal down substantially and could only go to 2000 rpm and it felt as if the e-brake was on, I just couldn't get any power. As I'm driving it would randomly switch back to regular power. Couldn't even drive up a hill..
Having said that (sorry if I am going into too much detail) I recently did do a repair on the intake manifold where the Coolant intake stem had cracked. using a Dorman Repair kit. I had to remove a few things to get to where I needed, and wondering if this could be the problem if I hooked all the connectors up properly.

Thanks for reading. If anyone has any ideas please post. I am Stumped!

REWARD EXCELLENCE!

Add to Biggs2008's Reputation
Rate the quality of this post and help Biggs2008 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Biggs2008 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 07-30-2015, 09:03 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,186
 

2003 L-Series 3.0L Sedan
Default Re: Strangely Sluggish 2002 SL2 out of the blue... Stumped

Loss of power at random can occur from several areas; worn fuel pump, clogged fuel filter, intermittent ignition/spark, blocked exhaust system, etc.. Some more info is needed. Mileage, maintenance done, parts replaced?

If this is an exhaust system blockage, removing the front (exhaust manifold mounted) O2 sensor for an alternate exhaust path should allow power to return immediately. A brief (loud) drive around the block should verify this.

A fuel pressure gauge is needed to measure actual pressures before and after start up.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 11-09-2015, 08:50 PM   #3
hoosierrun
Member
hoosierrun is just really nicehoosierrun is just really nicehoosierrun is just really nicehoosierrun is just really nice
 
Join Date: Nov 2015
Location: Seminole, Florida
Posts: 150

2006 VUE 2.2L
Default Re: Strangely Sluggish 2002 SL2 out of the blue... Stumped

It does sound a little bit like a clogged exhaust (usually the catalytic converter breaking up). If you are going up a hill and the tranny downshifts and then the engine bogs even more, it could suggest a clogged converter. I just hope that you didn't have the timing chain slip a cog. Has there been any noise from the engine like rattling or a whirring sound?

Is the engine light on?

...
John.... 2006 Saturn Vue, 2.2, 186,000 miles Recently junked out - (threw a rod)

REWARD EXCELLENCE!

Add to hoosierrun's Reputation
Rate the quality of this post and help hoosierrun reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
hoosierrun is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 Vue V6 codes.. wow! Very sluggish acceleration Bobby C 02VUE Vue Tech 17 08-29-2012 01:20 PM
2002 Vue has me stumped leichliterk Vue Tech 34 08-14-2012 10:29 PM
HELP ASAP! 2002 Saturn LW300 rev limit at 4k now sluggish V_dub97 L-Series Tech 5 09-15-2011 08:00 PM
L200 2002 sluggish starts mnkdrt L-Series General 5 08-12-2005 07:35 AM
2002 SL2 Silver blue 4 sale. Has some mods JoshuaTree Classifieds 0 11-10-2004 10:59 PM


All times are GMT -5. The time now is 05:38 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.