SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Relay > Relay Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 01-21-2015, 09:12 PM   #1
Los Dos Dave
New Member
Los Dos Dave is on a distinguished road
 
Join Date: Jan 2014
Posts: 1

2006 RELAY-2
Wrench 06 Relay Heater not working - symptom list

Hello gurus,
Hoping for some advice on where to look first to get the heater working in my 2006 Relay. Here are the symptoms that have been observed related to the heater as well as the AC, in no particular order.

* Last winter, when temp control on the dash was set in the red, the air blown into the cab was cold, but the engine temperature gauge would rise rapidly to the overheat range. This would happen whether in defrost or normal heat mode, sitting-still or in-motion. It had been working at the start of the winter and suddenly started this behavior. This winter, we are not seeing the engine over-heat phenomenon.
* The AC fan blows weakly... that is the AC compressor is making cold air but the blower barely pushes it into the cab.
* Once in a while a loud rapid oscillating clicking will occur inside the dash when the mode switch is moved to Normal, and will stop when moved to Max mode.

I realize that I may have three or more issues that I need to tackle, but I don't think my wife is going to tolerate going the rest of the winter with no heat. I suppose that I could have a bad heater-control valve, but don't want to go searching for it and replace it if it sounds like it is more likely to be something else.

Thanks for any recommendations on any of the above listed problems.
dave

REWARD EXCELLENCE!

Add to Los Dos Dave's Reputation
Rate the quality of this post and help Los Dos Dave reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Los Dos Dave is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 01-21-2015, 10:33 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,192
 

2003 L-Series 3.0L Sedan
Default Re: 06 Relay Heater not working - symptom list

A subscription to alldata will give full access to service manuals for anyone intending to service and maintain their own vehicles. You will find more info compared to shared experiences on public message boards. If anything, the forums complement service manuals.

One of the first things to ask about heating and cooling - was the cooling system ever flushed and replaced with new antifreeze? If there's a cabin air filter, was this ever replaced periodically? I'm not 100% familiar with Relays but Saturn doesn't use a coolant shut off valve in most of the model line simply to eliminate a potential problem. In effect, the cooling system is continually circulating and the only requirements are to ensure fluid level in the coolant container is topped off and periodic coolant flushing done. Dexcool was the first antifreeze made for 5 years or 100k miles before requiring replacement and is recommended to ensure long term reliability of the water pump and reduce clogging.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater not working? houstonray Astra General 6 01-13-2015 12:17 PM
heater not working nice186 S-Series Tech 8 01-27-2010 04:22 PM
Heater fan not working tjohnny42 Vue General 4 12-29-2009 05:41 PM
Heater not working 96'SL2 jaguaero S-Series Tech 26 01-18-2008 11:23 PM
Extensive list of issues on our '05 Relay. I contacted Saturn Corp directly. nismopc Relay General 28 06-11-2005 10:31 AM


All times are GMT -5. The time now is 07:15 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.