SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Categories > General Saturn Discussion
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 07-23-2014, 09:03 PM   #21
MakeMeFamous
Junior Member
MakeMeFamous is on a distinguished road
 
Join Date: Jul 2014
Posts: 14
Default Re: Issue with car running, please help!

So you think the leak is before the first o2 sens then?

We know there is a leak down further in the pipe (temp fixed it with aluminum sheets) but that would only affect the second o2 sens right?

REWARD EXCELLENCE!

Add to MakeMeFamous's Reputation
Rate the quality of this post and help MakeMeFamous reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MakeMeFamous is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 07-23-2014, 09:18 PM   #22
SL19302
Master Member
SL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to all
 
SL19302's Avatar
 
Join Date: Jan 2011
Location: Drums, PA
Posts: 3,350

2000 SW2
2002 SL1
Default Re: Issue with car running, please help!

Quote:
Originally Posted by MakeMeFamous View Post
So you think the leak is before the first o2 sens then?

We know there is a leak down further in the pipe (temp fixed it with aluminum sheets) but that would only affect the second o2 sens right?
Any exhaust leak from the exhaust manifold to the Converter inlet will upset the fuel mixture, That front pipe needs to be air tight with welds around the joints, Once its repaired or replaced pull the PCM B fuse in the Under hood Fuse Box for 30 Seconds then re-install the fuse and start the engine and see if it behaves differently. Also check the exhaust flange gasket where the pipe bolts to the exhaust manifold as that gasket fails often, Dont run the car with that leak anymore as the rich fuel mixture will burn up the converter.

...
2015 Subaru Forester Limited "Prinny"
2000 SW2 Still Running Strong- 160K Traded In
2002 SL1 Still has Its Training Wheels on at 88K Traded In


CHECK YOUR OIL!

Last edited by SL19302; 07-23-2014 at 09:31 PM..

REWARD EXCELLENCE!

Add to SL19302's Reputation
Rate the quality of this post and help SL19302 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
SL19302 is offline   Reply With Quote
Old 07-25-2014, 03:45 PM   #23
MakeMeFamous
Junior Member
MakeMeFamous is on a distinguished road
 
Join Date: Jul 2014
Posts: 14
Default Re: Issue with car running, please help!

Just took the manifold off. No cracks in it or the gasket, but it was completely missing a flange gasket lol. Think that would do it?

REWARD EXCELLENCE!

Add to MakeMeFamous's Reputation
Rate the quality of this post and help MakeMeFamous reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MakeMeFamous is offline   Reply With Quote
Old 07-25-2014, 05:48 PM   #24
SL19302
Master Member
SL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to all
 
SL19302's Avatar
 
Join Date: Jan 2011
Location: Drums, PA
Posts: 3,350

2000 SW2
2002 SL1
Default Re: Issue with car running, please help!

Quote:
Originally Posted by MakeMeFamous View Post
Just took the manifold off. No cracks in it or the gasket, but it was completely missing a flange gasket lol. Think that would do it?
Yes the flange gasket where the pipe bolts to the manifold is a common failure, Clean the flange up and install a new gasket, The other leak you were talking about as long as its AFTER the converter it shouldnt affect the engine.

...
2015 Subaru Forester Limited "Prinny"
2000 SW2 Still Running Strong- 160K Traded In
2002 SL1 Still has Its Training Wheels on at 88K Traded In


CHECK YOUR OIL!

REWARD EXCELLENCE!

Add to SL19302's Reputation
Rate the quality of this post and help SL19302 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
SL19302 is offline   Reply With Quote
Old 07-25-2014, 09:00 PM   #25
MakeMeFamous
Junior Member
MakeMeFamous is on a distinguished road
 
Join Date: Jul 2014
Posts: 14
Default Re: Issue with car running, please help!

Put all new gaskets in and re sealed the hole in the exhaust. It runs so much better, but still isn't perfect lol. Sometimes it still hesitates when pressing the accelerator (meaning that the engine sounds like its gonna stall out for a sec then revs up). But the idle is so much smoother and doesn't shake much lol. Cleared and re-scanned codes and got nothing. Any other ideas on why it's hesitating or still takes a couple tries to start? probably gonna put some fuel injector additive in it tomorrow and let it run for a bit unless you think its still running too rich.

REWARD EXCELLENCE!

Add to MakeMeFamous's Reputation
Rate the quality of this post and help MakeMeFamous reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MakeMeFamous is offline   Reply With Quote
Old 07-25-2014, 09:33 PM   #26
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,005
 

2003 L-Series 3.0L Sedan
Default Re: Issue with car running, please help!

Mileage? Compression test?

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 07-25-2014, 10:15 PM   #27
MakeMeFamous
Junior Member
MakeMeFamous is on a distinguished road
 
Join Date: Jul 2014
Posts: 14
Default Re: Issue with car running, please help!

113k miles and haven't done a compression test

REWARD EXCELLENCE!

Add to MakeMeFamous's Reputation
Rate the quality of this post and help MakeMeFamous reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MakeMeFamous is offline   Reply With Quote
Old 07-26-2014, 12:35 AM   #28
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,005
 

2003 L-Series 3.0L Sedan
Default Re: Issue with car running, please help!

A compression test can tell about the condition of the engine, a fuel pressure test will tell you how much pressure is made, and removing spark plugs can tell you if plugs; are worn, fouled in oil, blistered from wrong plug choice, black or soaked in fuel. And a spark test can tell you if all plugs are firing. The gauges may be loaned out from AutoZone in your area.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 07-26-2014, 04:46 AM   #29
SL19302
Master Member
SL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to all
 
SL19302's Avatar
 
Join Date: Jan 2011
Location: Drums, PA
Posts: 3,350

2000 SW2
2002 SL1
Default Re: Issue with car running, please help!

With the engine running so rich from the exhaust leak it might not be a bad idea to replace the plugs as they most likely are fouled, While you have them out peform a compression test.

...
2015 Subaru Forester Limited "Prinny"
2000 SW2 Still Running Strong- 160K Traded In
2002 SL1 Still has Its Training Wheels on at 88K Traded In


CHECK YOUR OIL!

REWARD EXCELLENCE!

Add to SL19302's Reputation
Rate the quality of this post and help SL19302 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
SL19302 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Running lights electrical issue sattyluvr S-Series Tech 9 02-18-2011 12:57 AM
I dare anyone to try to figure this one out, idle/running issue Twin_Cam S-Series Tech 10 02-07-2011 11:14 AM
93 sc2 running issue gumbysucks S-Series Tech 1 07-25-2008 05:43 AM
Running Issue legacy S-Series Tech 5 05-02-2008 05:21 PM
95 Saturn running issue jammeger S-Series General 9 03-01-2008 09:56 AM


All times are GMT -5. The time now is 02:46 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.