SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 08-27-2013, 09:10 PM   #1
ndifrischia
Junior Member
ndifrischia is on a distinguished road
 
Join Date: Aug 2013
Location: Western Pennsylvania
Posts: 26

1997 SL1
Dizzy All Sorts of Problems!... i think

I recently bought a 97 SL1 1.9 SOHC (although im finding that appropriate parts are for a 98) with 209k miles about two months ago or so
Old owner said it ran good with high milage oil and a bottle of injector cleaner in the tank. He said it would throw an EGR engine code (no P0# given) now and then and had some idle oddities and such i would expect of a car of this high milage.
Bought it and ran it solid for two months, changed oil and bypassed the injector cleaner.
Engine light came on for me and i took it to AZ, Codes thrown
P0327
P0404
P0303
Cleaned EGR... with seafoam.. hope that wasnt a mistake
And it was.. mediocre, still ran, shot seafoam smoke out the back
Changed plug wires, still had a miss, still ran it
Then One instance i was stopped on a hill (i typically put the car in neutral at a stop, it seemed to idle better) and i when i took off, complete lack of power, engine light flashing at me and horrible shudder. Limped Home with multiple stops (thought i was about to overheat or destroy the transmission or something bad!) and took it to a local shop and read the codes. Sadly i didnt get the numbers but it had about 17 codes in it and possibly also in the history.
#4 Cylinder has very weak spark and when pulling the plug wire while running it barely affects the engine. Cylinder 1 almost kills it if pulled. Cylinder 2 makes it about half power when pulled. Cylinder four spark plug is DOUSED in fuel when removed, Cylinder four injector has been replaced and doesnt match, it has three ports on the injector tip while the other three look to have a screen on the tip (difference between 97 & 98 i believe). Swapped #4 injector with #1 and now when #4 plug wire is pulled it affects the engine more than with the odd injector. valve lifters seem to be in working order when the cover is pulled. Pulled o2 sensor and took it down the road and it runs rough. I dont know why i keep thinking this but i feel like its over fueling and ... ugh i dont know
Things i have done that havent really helped..
ECTS
02 Sensor
Plugs (NGK)
Wires
Fuel Filt
Cleaned throttle body and IAC
Both coil packs spark while cranking with the boots off the towers
Fuel pressure is reading good
Wires(I tried AC Delco but they were crap and the insulator boot pulled off so i put on an expensive set from a VW that seem to work pretty darn good)
Compression Test - 1=190 2=85 3=210 4=220
now i know the #2 cylinder is running low but the symptoms are very odd. When the odd ball injector was changed to cylinder 1, engine mounting surface, grounding bolts and ICM. I am pulling my hair out... and there wasnt much there to begin with. After most of that i get this string of codes.. under what conditions im not quite sure.. changed a bunch of things around and getting it out to erase the codes is a bit troublesome... so there could be some old/odd data here

P0351
P0405
P0352
P0202
P1599
P0117
P0122
P0304
P0327
P0134
P0300
P0201
P0204
P0341
P0351
P1133

REWARD EXCELLENCE!

Add to ndifrischia's Reputation
Rate the quality of this post and help ndifrischia reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ndifrischia is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 08-28-2013, 12:09 AM   #2
ndifrischia
Junior Member
ndifrischia is on a distinguished road
 
Join Date: Aug 2013
Location: Western Pennsylvania
Posts: 26

1997 SL1
Default Re: All Sorts of Problems!... i think

Im sorry i started a thought there and trailed off...
I With odd ball injector swapped with #1 Cyl, Old ICM/Coils back on (cleaned up a bit), it seems to run good cold... or more like once i decelerate and then try and take off again... feels rather powerless, jerky and misses...

REWARD EXCELLENCE!

Add to ndifrischia's Reputation
Rate the quality of this post and help ndifrischia reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ndifrischia is offline   Reply With Quote
Old 08-28-2013, 07:05 AM   #3
Highmile
Senior Member
Highmile will become famous soon enoughHighmile will become famous soon enough
 
Highmile's Avatar
 
Join Date: Mar 2001
Location: St. Louis, Mo.
Posts: 1,042

1995 SL1
Default Re: All Sorts of Problems!... i think

No matter what you throw at it, until the 85 psi compression on #2 is resolved noting is really going to make it run decently.

It does seem like it has a ton of issues besides and maybe someone else will chime in and help but it really sounds like an electrical/ecm issue to me with the number of codes you have.

Highmile
'95 SL1 526k and counting

...
Highmile
95 sl1 496k (rebuilt engine)

REWARD EXCELLENCE!

Add to Highmile's Reputation
Rate the quality of this post and help Highmile reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Highmile is offline   Reply With Quote
Old 08-28-2013, 10:25 AM   #4
ndifrischia
Junior Member
ndifrischia is on a distinguished road
 
Join Date: Aug 2013
Location: Western Pennsylvania
Posts: 26

1997 SL1
Default Re: All Sorts of Problems!... i think

Will be working on compression issues very soon..
Also will clear codes for a fresh start to see what pops up
Drove into work today and it actually ran okayish

REWARD EXCELLENCE!

Add to ndifrischia's Reputation
Rate the quality of this post and help ndifrischia reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ndifrischia is offline   Reply With Quote
Old 08-29-2013, 11:35 AM   #5
ndifrischia
Junior Member
ndifrischia is on a distinguished road
 
Join Date: Aug 2013
Location: Western Pennsylvania
Posts: 26

1997 SL1
Default Re: All Sorts of Problems!... i think

RPMs raise to 2k at start up and then drop to 800 after 7 seconds... im thnking TPS.. but would love a second opinion. Will be checking compression wet soon

REWARD EXCELLENCE!

Add to ndifrischia's Reputation
Rate the quality of this post and help ndifrischia reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ndifrischia is offline   Reply With Quote
Old 09-02-2013, 02:11 PM   #6
ndifrischia
Junior Member
ndifrischia is on a distinguished road
 
Join Date: Aug 2013
Location: Western Pennsylvania
Posts: 26

1997 SL1
Default Re: All Sorts of Problems!... i think

Current DTCs
P0303
P1133

Will be checking Wet Compression Today

REWARD EXCELLENCE!

Add to ndifrischia's Reputation
Rate the quality of this post and help ndifrischia reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ndifrischia is offline   Reply With Quote
Old 09-05-2013, 10:17 AM   #7
ndifrischia
Junior Member
ndifrischia is on a distinguished road
 
Join Date: Aug 2013
Location: Western Pennsylvania
Posts: 26

1997 SL1
Default Re: All Sorts of Problems!... i think

#2 Cylinder
105 @ 7 cranks dry
110 @ 7 cranks wet

REWARD EXCELLENCE!

Add to ndifrischia's Reputation
Rate the quality of this post and help ndifrischia reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ndifrischia is offline   Reply With Quote
Old 09-05-2013, 10:24 AM   #8
LabRat
Advanced Member
LabRat is on a distinguished road
 
Join Date: Oct 2011
Location: Des Moines, WA (Seattle)
Posts: 580

1998 SL2
1999 SL2
Default Re: All Sorts of Problems!... i think

valve bad, crack or head gasket leak on #2
-LR

REWARD EXCELLENCE!

Add to LabRat's Reputation
Rate the quality of this post and help LabRat reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
LabRat is offline   Reply With Quote
Old 08-02-2014, 09:13 PM   #9
ndifrischia
Junior Member
ndifrischia is on a distinguished road
 
Join Date: Aug 2013
Location: Western Pennsylvania
Posts: 26

1997 SL1
Default Re: All Sorts of Problems!... i think

Well time sure does fly! FINALLY took the head off (burnt exhaust valves). replaced head gasket, intake/exhaust manifold gasket, new wires, plugs, thermostat, radiator and oil cooler line (blew out on the test drive... may have jacked the engine up too high)....


present trouble codes

P0112 (forgot to connect it while putting back together
P0404 (pulled one from an old pontiac... probably a terrible idea)
P0327 ???? cant find listing knock sensor maybe?????
P1620 (when trany line blew out)
P1404 (pretty sure the "1" just means its in the history)

all and all it seems to have breathed new life into this car with 216XXX on the dash but i want to go the distance here...

any recommendations on brand of EGR to buy to replace??
any clue on the P0327??

the IAT code should disappear seeing how its connected now

Thanks guys! This forum is the best!

REWARD EXCELLENCE!

Add to ndifrischia's Reputation
Rate the quality of this post and help ndifrischia reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ndifrischia is offline   Reply With Quote
Old 08-02-2014, 09:22 PM   #10
SL19302
Master Member
SL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to all
 
SL19302's Avatar
 
Join Date: Jan 2011
Location: Drums, PA
Posts: 3,350

2000 SW2
2002 SL1
Default Re: All Sorts of Problems!... i think

Delphi is a good brand for an EGR valve, Make sure the EGR passages are clean and not blocked.

...
2015 Subaru Forester Limited "Prinny"
2000 SW2 Still Running Strong- 160K Traded In
2002 SL1 Still has Its Training Wheels on at 88K Traded In


CHECK YOUR OIL!

REWARD EXCELLENCE!

Add to SL19302's Reputation
Rate the quality of this post and help SL19302 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
SL19302 is offline   Reply With Quote
Old 08-02-2014, 09:51 PM   #11
ndifrischia
Junior Member
ndifrischia is on a distinguished road
 
Join Date: Aug 2013
Location: Western Pennsylvania
Posts: 26

1997 SL1
Default Re: All Sorts of Problems!... i think

... probably should have done that during tear down(!@#$)


any good way to get it done without taking off the manidold/head again?? it was a bit of a process..


THANKS!

REWARD EXCELLENCE!

Add to ndifrischia's Reputation
Rate the quality of this post and help ndifrischia reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ndifrischia is offline   Reply With Quote
Old 08-03-2014, 01:26 AM   #12
Signmaster
Master Member
Signmaster is a name known to allSignmaster is a name known to allSignmaster is a name known to allSignmaster is a name known to allSignmaster is a name known to allSignmaster is a name known to all
 
Join Date: Jan 2007
Location: Virginia Beach, VA
Posts: 5,901
 

1995 SL1
Default Re: All Sorts of Problems!... i think

Get the car/oil up to operating temp, then remove the EGR and start the car. It will bounce off the rev limiter due to the vacuum leak and blow the carbon out of system. Warming the car is just so the oil is up to temp and you have good lubrication at the rev limiter bounce.

REWARD EXCELLENCE!

Add to Signmaster's Reputation
Rate the quality of this post and help Signmaster reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Signmaster is offline   Reply With Quote
Old 08-03-2014, 03:19 PM   #13
DawnR
Member
DawnR is just really niceDawnR is just really niceDawnR is just really niceDawnR is just really nice
 
DawnR's Avatar
 
Join Date: May 2014
Location: Bloomer, WI
Posts: 231
 

1997 SW2
2001 SC2
Default Re: All Sorts of Problems!... i think

Quote:
Originally Posted by Signmaster View Post
Get the car/oil up to operating temp, then remove the EGR and start the car. It will bounce off the rev limiter due to the vacuum leak and blow the carbon out of system. Warming the car is just so the oil is up to temp and you have good lubrication at the rev limiter bounce.
Where does the carbon blow out to...
I picture ashes everywhere or a huge mess.

...
I read, I learn, I try!

REWARD EXCELLENCE!

Add to DawnR's Reputation
Rate the quality of this post and help DawnR reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
DawnR is offline   Reply With Quote
Old 08-03-2014, 04:55 PM   #14
Steve44
Senior Member
Steve44 will become famous soon enoughSteve44 will become famous soon enough
 
Steve44's Avatar
 
Join Date: Apr 2013
Location: Scarborough, On. Canada
Posts: 1,036
 

1999 SL1
1999 SL2
Default Re: All Sorts of Problems!... i think

Yes it does! There really isn't so much that it could hurt you, unless you're under the hood. (You should be starting it from the drivers seat) Don't let your kids or anyone else you like witness this event.

REWARD EXCELLENCE!

Add to Steve44's Reputation
Rate the quality of this post and help Steve44 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Steve44 is offline   Reply With Quote
Old 08-05-2014, 12:34 PM   #15
ndifrischia
Junior Member
ndifrischia is on a distinguished road
 
Join Date: Aug 2013
Location: Western Pennsylvania
Posts: 26

1997 SL1
Default Re: All Sorts of Problems!... i think

Got it up to temp and took EGR off and started it twice, not too much shot out except white smoke from exhaust and EGR passageway

REWARD EXCELLENCE!

Add to ndifrischia's Reputation
Rate the quality of this post and help ndifrischia reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ndifrischia is offline   Reply With Quote
Old 08-05-2014, 01:15 PM   #16
ndifrischia
Junior Member
ndifrischia is on a distinguished road
 
Join Date: Aug 2013
Location: Western Pennsylvania
Posts: 26

1997 SL1
Default Re: All Sorts of Problems!... i think

definitely have a valve cover leak, gonna take care of that today. P0300 i suspect from oil leaking down to the ICM. Hope the Timing cover isnt leaking also. Any culprit for the knock sensor code? Ive been running a higher octane than i should right now (done with that noise! back to the cheap stuff) and figured that may have been causing the sensor code... not sure though

REWARD EXCELLENCE!

Add to ndifrischia's Reputation
Rate the quality of this post and help ndifrischia reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ndifrischia is offline   Reply With Quote
Old 08-05-2014, 05:02 PM   #17
ndifrischia
Junior Member
ndifrischia is on a distinguished road
 
Join Date: Aug 2013
Location: Western Pennsylvania
Posts: 26

1997 SL1
Default Re: All Sorts of Problems!... i think

Compression at 200/215/200/195
New EGR still throws P0404 code even after blowing out passages (didnt seem like a lot came out though)
Still have
P0327
P0300

and I think one more... possibly P0112

This engine ran AMAZINGLY yesterday till in the evening when it started missfiring, thats when i noticed the valve cover leak, think i fixed that, havent driven enough to see if ive fixed it properly... so confused on how well this car was going and then it just feels like crap now.

Compression test = good
Cleaned Grounds
Cleaned ICM/Coil Contacts/Backing Plate

... ive been thinking that the oil that was thrown all over the engine compartment might have leaked down to the CPS... could that be giving me multiple misfires?? It feels like the only thing i havent replaced on this car yet

...
'97 SL1 SOHC 217,000

REWARD EXCELLENCE!

Add to ndifrischia's Reputation
Rate the quality of this post and help ndifrischia reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ndifrischia is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
All sorts of info Zaturn Astra General 19 02-24-2012 10:04 PM
All sorts of crazy stuff going on with a 2001 SC Zosozeppelin S-Series General 9 03-27-2011 11:28 AM
Please help! All sorts of problems... Chapps34 Ion Tech 3 11-24-2009 12:51 PM
A "personal" TSB of sorts.. wolfman Miscellaneous Tech 1 05-09-2003 08:23 AM


All times are GMT -5. The time now is 11:53 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.