SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 04-28-2013, 02:53 AM   #1
MyFirstSaturnNJ
New Member
MyFirstSaturnNJ is on a distinguished road
 
Join Date: Apr 2013
Posts: 2
Thumbs Down 99 saturn SL1 idle issue/ Sporadic fluctuating power

I just purchased my 99 SL1 off a "friend" whose EX-girlfriend owned. He was the middleman/ salesperson for the vehicle. When I 1st went to look at it everything seemed in order. The fluids all looked good and were at proper levels. All lights and instruments worked. And when I started it up it seemed to run smooth and the engine was clean and looked very solid. Granted, I am by no stretch of the imagination tech saavy when it comes to auto repair. But now I am quickly learning.....THE HARD WAY! So the last thing I do before I leave on the day I first looked at it is give it a test drive. It was not insured and didnt have plates so I could only reverse it 25 ft in the parking lot and gun it back to the parking spot. It still seemed to run like a beaut!!! I wasn't a fan of Saturns before. But for $500 and being in need of a reliable vehicle for delivery work, I was willing to give it a chance. So when I park the car the service engine soon light was flashing (it wasnt on until this point) My friends EX-gf who was the owner of the car, and where it was parked, lives above an auto repair shop. So my friend said he'd ask the owner to get the codes out of it for me. He said it came back as an EGR valve. When I bought it I took it to Advance Auto Parts and the guy said no codes were coming up. So now to explain the issues I've had since I bought it. About 5-10 minutes into driving it home it seemed to lose its pickup and engine power. It was putting along maybe 30mph and I practically had to put the pedal to the floor to get it to accelerate to 40mph. The idle goes back and forth for no reason and any given time. At first I thought it was when the engine was warmed up. But lately its been doing it shortly after starting it. The 1st 2 days it drove fine on short trips, although it did stall a few times. And it stalls almost every day. The 3rd day I barely drove it. I cleaned the throttle body (Forgot to remove the sensor and the other thing and spray into the cylinder) But I was careful not to spray into the electrical parts. I gave it about a half hr to dry and reinstalled it. It didnt seem to help and i thought i may have made it worse. So days 4 and 5 (5 being last night) i have been trying to learn how to drive it without stalling. So when I am approaching a stop I shift my automatic into neutral and put my left foot on the brake. When I resume driving I shift into Drive and release my left foot from the brake. I don't know if this hurts the car (advice welcome) but I have no choice. I have done alot of reading for the past 4 days and I have heard alot of possible causes for my problem. I make money almost daily and I am trying to tackle the least expensive ideas 1st and do the bigger things as I have the money. I was going to replace the ECTS and thermostat 1st and see if that helps. Then try new plugs and wires (My neighbor claims to be a retired mechanic of 25 yrs and said it sounds like one of my cylinders isnt firing. He said he'd help me with the job) Then I am going to clean the EGR and the Throttle body correctly and put new gaskets on and see if that works. NOTE:My intake manifold is CAKED with carbon and grease. The one side of my throttle was BLACK as can be and thick. Took 4 sprays and brushings to free all of the gunk. ALSO when the car stalls it stalls very hard and makes alot of noise like the bottom of the car is gonna fall apart. I don't want to make this post too much longer. So I'll leave it at this and see what you guys have to say about it. Thanks for reading. I'm about to pull my hair out over this. Oh wait....I'm already bald. I don't even have THAT going for me

REWARD EXCELLENCE!

Add to MyFirstSaturnNJ's Reputation
Rate the quality of this post and help MyFirstSaturnNJ reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MyFirstSaturnNJ is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 04-28-2013, 03:33 PM   #2
bluesl2
Senior Member
bluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of light
 
bluesl2's Avatar
 
Join Date: Jul 2005
Posts: 1,884
Default Re: 99 saturn SL1 idle issue/ Sporadic fluctuating power

It would be good to do the ects and thermostat as you say, they would be the first things I would recommend. It is possible the egr valve may be sticking open and causing your stall out condition too. You could try removing it to clean it out and the passageways as well.

REWARD EXCELLENCE!

Add to bluesl2's Reputation
Rate the quality of this post and help bluesl2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bluesl2 is offline   Reply With Quote
Old 04-29-2013, 10:44 PM   #3
MyFirstSaturnNJ
New Member
MyFirstSaturnNJ is on a distinguished road
 
Join Date: Apr 2013
Posts: 2
Default Re: 99 saturn SL1 idle issue/ Sporadic fluctuating power

Thanks. I tried changing the plugs and wires this past weekend. The old plugs were pretty bad. But there was no noticeable difference. Nonetheless it was probably a good idea to change them anyway. I forgot to use dialetic grease but i did use the anti-seize around the threads. So I guess this weekend I will do the ECTS and thermostat. If we dont get rain again tomm I am going to attempt cleaning out the EGR and maybe reclean the throttle body properly. Is there a certain way to clean out the intake manifold?? There is a ton of carbon built up in there. I am a newbie at auto repair so any help/tips would be highly appreciated.

REWARD EXCELLENCE!

Add to MyFirstSaturnNJ's Reputation
Rate the quality of this post and help MyFirstSaturnNJ reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MyFirstSaturnNJ is offline   Reply With Quote
Old 04-30-2013, 08:19 AM   #4
lamping.ap
Advanced Member
lamping.ap will become famous soon enoughlamping.ap will become famous soon enough
 
Join Date: Jan 2008
Location: Cincinnati, OH
Posts: 999
 

1998 SC2
Default Re: 99 saturn SL1 idle issue/ Sporadic fluctuating power

If you're determined to clean the intake manifold, it is recommended to remove it from the car to keep the loosened carbon from entering the motor.

REWARD EXCELLENCE!

Add to lamping.ap's Reputation
Rate the quality of this post and help lamping.ap reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
lamping.ap is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluctuating Idle saturn95 Ion Tech 16 02-28-2013 03:52 PM
Sporadic Starting Issue 97 SC2 Medic-5150 S-Series Tech 10 05-11-2011 07:39 PM
sporadic rattle at idle only ShuttlecraftX47 S-Series General 11 08-12-2009 11:19 AM
Idle RPM fluctuating senorpineapple Ion Tech 3 01-28-2008 07:29 AM
Eratic, sporadic idle! John Head S-Series Tech 20 02-20-2007 10:45 PM


All times are GMT -5. The time now is 01:15 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.