SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 04-08-2013, 07:12 PM   #1
Gmaan39
New Member
Gmaan39 is on a distinguished road
 
Join Date: Apr 2013
Posts: 3
Question Rough Idle and misfire

My 2001 L200 2.2 (35,000 miles) has been idling rough and misfiring with no acceleration problems. The cooling fan sometimes will come on as soon as the car is started and stay on while other times it goes on and off intermitently. (A/C is off). I just replaced the ICM and I'm still having the same problem. I checked the intake manifold and there are no leaks. Any other thoughts before I run out and drop tons of money on all parts imaginable? Thanks!

REWARD EXCELLENCE!

Add to Gmaan39's Reputation
Rate the quality of this post and help Gmaan39 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Gmaan39 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 04-08-2013, 07:40 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 38,996
 

2003 L-Series 3.0L Sedan
Default Re: Rough Idle and misfire

Check for a disconnected/damaged air temperature sensor behind the front grille.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 04-08-2013, 08:11 PM   #3
Gmaan39
New Member
Gmaan39 is on a distinguished road
 
Join Date: Apr 2013
Posts: 3
Default Re: Rough Idle and misfire

I'll check that out. Also, just on a side note, I pulled the codes and I'm getting the P0300. I also uninstalled the new ICM and reinstalled the old one. I'm still having the problem but not as severely.

REWARD EXCELLENCE!

Add to Gmaan39's Reputation
Rate the quality of this post and help Gmaan39 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Gmaan39 is offline   Reply With Quote
Old 04-09-2013, 02:20 PM   #4
u35828
Junior Member
u35828 is on a distinguished road
 
u35828's Avatar
 
Join Date: Apr 2008
Location: Evanston, IL
Posts: 35

2003 L-Series 2.2L Wagon
Default Re: Rough Idle and misfire

I had a similar complaint with my 2003 LW200. Diagnostic codes determined that a bad fuel injector was at fault.

...
"There's no replacement for displacement."

-Walter Owen Bentley

REWARD EXCELLENCE!

Add to u35828's Reputation
Rate the quality of this post and help u35828 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
u35828 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SL1 - Intermittent rough idle, misfire, almost stalls... hydromech S-Series Tech 8 09-27-2012 10:24 AM
99 sl2 misfire rough idle jalanshort S-Series Tech 23 04-30-2012 12:47 AM
Misfire, Rough Idle getz_999 S-Series Tech 2 07-15-2010 01:59 PM
Misfire PO306 and rough idle mmendez L-Series General 3 03-09-2008 01:19 PM
rough idle, rough sluggish pickup, 97slw smiles233 S-Series General 7 10-14-2005 03:28 PM


All times are GMT -5. The time now is 12:47 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.