SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 01-14-2013, 08:44 PM   #1
RDO
Junior Member
RDO is on a distinguished road
 
RDO's Avatar
 
Join Date: Jun 2009
Location: Lawrenceville, GA
Posts: 18

2001 SL2
1995 SC2
Default New TPS, SES still lit - 2001 SL2

SES came on. AZ read codes: p0122 and p0341. Replaced TPS SES still on.
AZ now reads only p0122. Disconnected battery during install & thought that would reset computer. Returned TPS thinking it was faulty. Still have SES with 2nd new TPS.
Can anyone please help? Recommended fix?

REWARD EXCELLENCE!

Add to RDO's Reputation
Rate the quality of this post and help RDO reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
RDO is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 01-14-2013, 10:16 PM   #2
bluesl2
Senior Member
bluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of lightbluesl2 is a glorious beacon of light
 
bluesl2's Avatar
 
Join Date: Jul 2005
Posts: 1,885
Default Re: New TPS, SES still lit - 2001 SL2

Try wiggling the connector on the tps with the motor running and see if it changes idle speed, you may have a wiring/connector problem. For po341, change plugs,wires and make sure the bottom two coil retaining bolts are free of rust on the underside of the bolt head.

REWARD EXCELLENCE!

Add to bluesl2's Reputation
Rate the quality of this post and help bluesl2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bluesl2 is offline   Reply With Quote
Old 01-14-2013, 11:50 PM   #3
td1238
Master Member
td1238 will become famous soon enoughtd1238 will become famous soon enough
 
Join Date: Mar 2010
Location: Milwaukee
Posts: 2,108

1999 SL2
Default Re: New TPS, SES still lit - 2001 SL2

P0341 is often set by crossing plug wires 4 and 1, and/or not arranging the wires in an orderly fashion so that they remain in the same sequence from the coils to the plugs. They should be connected from left to right at the coils as viewed: 4,1,2,3. At the plugs it should be 1,2,3,4, as that's the positions of the cylinders as viewed from left to right while standing in front of the car.

Faulty plugs and wires can also set this code.

REWARD EXCELLENCE!

Add to td1238's Reputation
Rate the quality of this post and help td1238 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
td1238 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What to do with my 2001 SL2? MissTraci S-Series General 4 02-24-2012 10:41 PM
2001 SL2 Help winnipegsaturn S-Series Tech 12 02-11-2011 08:15 PM
2001 sc2 help please XxDarkKnightsxX S-Series Tech 19 11-12-2010 06:08 AM
Fs:2001 Sl2 saturnhawaiiguy Classifieds 1 11-08-2002 09:39 PM
2001 L & S oshte L-Series General 7 05-19-2000 10:02 PM


All times are GMT -5. The time now is 07:35 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.