SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 04-30-2012, 07:09 PM   #1
actnbill
Junior Member
actnbill is on a distinguished road
 
actnbill's Avatar
 
Join Date: Dec 2005
Posts: 29
 
Default High Idle and code P0507

I have a 2000 SL1 5 speed with about 120K......( my 4th Saturn )

Recently the SL1 idle has been racing up to 4,000 rpms and generating a P0507 code......

I have changed the ECTS with a brass one, a new IAC valve, cleaned the throttle body, new plugs and wires......

After I stop driving and set the parking brake the idle slowly lowers back to normal idle around 800 rpms.....( it takes about 1 minute to go from 4,000 down to 800 rpms.....and only when the car is parked...it races forever at 4,000rpm when I put it into neutral and coast down the road....)

Other than the high idle, it runs like a champ....

Anyone have any ideas what I can try to fix ?????

Bill

...
2003 L200
2000 SL1

REWARD EXCELLENCE!

Add to actnbill's Reputation
Rate the quality of this post and help actnbill reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
actnbill is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 04-30-2012, 08:17 PM   #2
bluesl2
Senior Member
bluesl2 is a jewel in the roughbluesl2 is a jewel in the roughbluesl2 is a jewel in the roughbluesl2 is a jewel in the rough
 
bluesl2's Avatar
 
Join Date: Jul 2005
Posts: 1,697
Default Re: High Idle and code P0507

Check for vacuum leaks.

REWARD EXCELLENCE!

Add to bluesl2's Reputation
Rate the quality of this post and help bluesl2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bluesl2 is offline   Reply With Quote
Old 04-30-2012, 08:24 PM   #3
ssewall
Senior Member
ssewall is on a distinguished road
 
Join Date: Jun 2011
Location: Maine
Posts: 1,086

2002 SL2
Default Re: High Idle and code P0507

Spray some carb cleaner around the #1 cylinder intake runner, on top and underneath. Try not to do it on a very hot engine. If the idle suddenly changes you have the intake manifold gasket leak that plagues 00-02 Sx1s. If this fails check for vacuum leaks elsewhere. Disconnected or broken vacuum hoses are good culprits.

REWARD EXCELLENCE!

Add to ssewall's Reputation
Rate the quality of this post and help ssewall reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ssewall is offline   Reply With Quote
Old 05-01-2012, 09:42 AM   #4
BV22
Senior Member
BV22 will become famous soon enoughBV22 will become famous soon enough
 
Join Date: Feb 2011
Location: Texas
Posts: 1,559

2002 SC1
Default Re: High Idle and code P0507

Idle at 4000 rpm indicates a major vacuum leak. Check the big hoses, particularly the one to the brake booster and the PCV valve hose. Could be the intake manifold gasket, but it would be a really tremendous leak to make the idle that high. Did you remove the throttle body to clean it, and if so, did you replace the gasket?

...
BV22
2002 SC1 5M
242k 09/14

REWARD EXCELLENCE!

Add to BV22's Reputation
Rate the quality of this post and help BV22 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
BV22 is offline   Reply With Quote
Old 05-01-2012, 10:55 AM   #5
fm2200
Member
fm2200 is on a distinguished road
 
Join Date: Mar 2011
Location: staten island ny
Posts: 221

2001 SL
Happy Re: High Idle and code P0507

Try changing the TPS that is a primary reason for a high idle. It's a cheap fix, if the TPS doesn't fix it. Then check all the other things like air leaks.

REWARD EXCELLENCE!

Add to fm2200's Reputation
Rate the quality of this post and help fm2200 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fm2200 is offline   Reply With Quote
Old 05-01-2012, 11:22 AM   #6
PlasticCarsRock
Master Member
PlasticCarsRock is a jewel in the roughPlasticCarsRock is a jewel in the roughPlasticCarsRock is a jewel in the rough
 
PlasticCarsRock's Avatar
 
Join Date: Dec 2005
Location: Brookline, MA
Posts: 4,303
 

1995 SL2
Default Re: High Idle and code P0507

Quote:
Originally Posted by fm2200 View Post
Try changing the TPS that is a primary reason for a high idle. It's a cheap fix, if the TPS doesn't fix it. Then check all the other things like air leaks.
Don't just waste money throwing parts at it. It would be wise to test the TPS (see richpin video on youtube if you don't know how), but while a TPS can cause a high idle situation, they don't typically make it idle anywhere near that high.

Checking for vacuum leaks (particularly one this big) is pretty easy. Any brake cleaner (or carb cleaner, throttle body cleaner, propane, etc) sprayed near the leak will cause an audible change in the idle. (Obviously, you should be careful because you will be spraying something highly flammable near a running engine.)

With a leak large enough to rev to 4000 rpm, you can probably hear the leak just by listening with the hood open.

...
High compression build: .033" shaved/ported head, flat-faced valves; gen3 rods, pistons, tie-plate; OE header, custom CAI, SDA street cams with adjustable sprockets, WBO2, SAFCII, LSD. ASE A1-A8+L1

REWARD EXCELLENCE!

Add to PlasticCarsRock's Reputation
Rate the quality of this post and help PlasticCarsRock reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
PlasticCarsRock is offline   Reply With Quote
Old 05-02-2012, 03:30 PM   #7
actnbill
Junior Member
actnbill is on a distinguished road
 
actnbill's Avatar
 
Join Date: Dec 2005
Posts: 29
 
Default Re: High Idle and code P0507

update : I took some carb cleaner and sprayed it on all the vacuum hoses and intake manifold gasket area.....no change in high idle rpms.....

I took the throttle body off again and cleaned it really well....... no change to high idle......

Next, while the car was running, I unplugged the TPS electical connector from the throttle body and the rpms went down to 600-900 range instead of the 4,000 rpms I was experiencing......

Other than generating a code for an unplugged TPS sensor, the car idled pretty well..... ( it would wander a bit between 600-900 though )

My biggest question is should I replace the TPS, because the car will go right back to 3,000-4,000 rpms after I shut the car off and restart it with everything plugged in normally.....( a sign of a bad TPS is that the idle will reset after restarts )......mine doesn't...it stays high

...
2003 L200
2000 SL1

REWARD EXCELLENCE!

Add to actnbill's Reputation
Rate the quality of this post and help actnbill reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
actnbill is offline   Reply With Quote
Old 05-02-2012, 09:59 PM   #8
fdryer
Super Member
fdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant future
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 29,703
 

2003 L-Series 3.0L Sedan
Default Re: High Idle and code P0507

Remove the air intake tube so you can see the throttle body with the engine idling. If you can start and idle at 4000rpm, quickly block off the hole in the throttle body that's in front of the throttle plate.

Does the high idling drop immediately back down? And at what rpm?

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 05-03-2012, 11:28 PM   #9
spettro9
Junior Member
spettro9 is on a distinguished road
 
spettro9's Avatar
 
Join Date: Jan 2011
Location: North Jersey
Posts: 11

2001 SC1
Default Re: High Idle and code P0507

I have been having the same problem,
although after restarting car, everything seems normal..

i've already replaced idle air control valve, and cleaned throttle body once,
and the high idle still happens sometimes, when put in park (usually after longish or highway drive),
(or sometimes even stopped at a light, or going slow, i can feel that the idle seems a little more powerful, and if I quick drop the tranmission into neutral, the engine speed is higher than it should be)

anyway, I think it's the TPS. I have already bought it and will try change it soon.

PS: maybe related but maybe not, this morning my check engine light came on a few minutes after leaving home; a minute later I noticed that the temperature gauge was inactive, when the car should have been about up to operating temperature ("closed loop") already. I figured the 2 situations were related and sure enough when i got home, the scanner found
error P0118 - "Engine coolant temp sensor input above max acceptable range"
and pending errors P 0118 (ditto as above) and P0125 "Timed it takes to enter closed-loop fuel control is excessive"

In the parking lot of the auto parts store, I looked quick at the ECTS and the 2 wires to it looked literally like they were cut. Not melted or burned, but cut.
Don't have any clue how this would have happened, but I reconnected the wires using some 20 gauge braided wire I had and little butt connectors from radio shack. Was hard to fish them out of that massive spinal cord of wires but I got them, and put everything back pretty neat and safe. Will add a little liquid elec. tape tomorrow.
In driving this evening, temp. gauge functions fine again, and I think I still had the high idle at one point.

...
2001 Silver SC1, from craigslist in Clifton, NJ 2011/01/21, with 70k miles, $3K,
27 normal (winter 25 mpg) / 37-40 highway
(just have to watch oil a bit... seems to be 3/4 qt in 1000 miles, )

REWARD EXCELLENCE!

Add to spettro9's Reputation
Rate the quality of this post and help spettro9 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
spettro9 is offline   Reply With Quote
Old 05-04-2012, 08:15 AM   #10
actnbill
Junior Member
actnbill is on a distinguished road
 
actnbill's Avatar
 
Join Date: Dec 2005
Posts: 29
 
Default Re: High Idle and code P0507

I think I will have to get a new TPS sensor.....( I doubt it's the IAC because I just changed it and cleaned the throttle body )

If the TPS doesn't help, then I think I'll replace the intake manifold gasket.... ( My SL1 doesn't have power steering so I am guessing it's a bit easier to change the intake gasket on my car than one with ps. )

Bill

...
2003 L200
2000 SL1

REWARD EXCELLENCE!

Add to actnbill's Reputation
Rate the quality of this post and help actnbill reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
actnbill is offline   Reply With Quote
Old 12-01-2012, 12:20 PM   #11
spettro9
Junior Member
spettro9 is on a distinguished road
 
spettro9's Avatar
 
Join Date: Jan 2011
Location: North Jersey
Posts: 11

2001 SC1
Default Re: High Idle and code P0507

I did indeed change the TPS since then, and it did fix the issue; no more revving...

PS
right now putting head + timing cover + oil pan back on... it seems head gasket developed oil leak near where alternator is (near the pressurized oil channel through gasket...)

...
2001 Silver SC1, from craigslist in Clifton, NJ 2011/01/21, with 70k miles, $3K,
27 normal (winter 25 mpg) / 37-40 highway
(just have to watch oil a bit... seems to be 3/4 qt in 1000 miles, )

REWARD EXCELLENCE!

Add to spettro9's Reputation
Rate the quality of this post and help spettro9 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
spettro9 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Idle then code 49 MacG S-Series Tech 2 04-01-2012 12:51 PM
Code P0507 and engine dies instantly at idle actnbill S-Series Tech 0 10-17-2011 07:21 PM
IAC Code and high Idle hammerheadlrrp S-Series Tech 7 05-12-2008 06:56 PM
high idle P0507 solved scotttomlin S-Series Tech 2 02-23-2006 06:47 PM
high idle P0507 scotttomlin S-Series Tech 2 02-20-2006 06:09 PM


All times are GMT -5. The time now is 07:15 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.