SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 03-01-2012, 11:55 PM   #1
wilson.kegler
New Member
wilson.kegler is on a distinguished road
 
Join Date: Mar 2012
Location: Southern Oregon
Posts: 4

2000 SW2
Question Turn Signals and Hazards Quit Working

2000 SW2

Yesterday my hazards and blinkers quit working at the same time. I was on the side of the road with the hazards on when they quit. The first thing I did was check the fuse for the signals. It was blown and when I put in a spare it immediately blew as soon as the fuse touched the panel. Then I tried a 15A instead of 10 and it lasted for a couple seconds before it blew. My initial conclusion was that because of the recent snow and precipitation this week that I got some water on a wire or connector and the circuit shorted out somewhere. I checked the UHAUL trailer plug that hangs from the hitch and it had some water in it but even after cleaning it and drying it out, it still blew a fuse as soon as I put one in. If it is a short, can somebody teach me how to trace it down? Is there any other possibilities? Would a bad flasher relay cause the fuses to blow?

REWARD EXCELLENCE!

Add to wilson.kegler's Reputation
Rate the quality of this post and help wilson.kegler reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
wilson.kegler is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 03-02-2012, 12:48 AM   #2
OldNuc
Super Member
OldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant future
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 63,249
 

1998 SC2
Default Re: Turn Signals and Hazards Quit Working

One of the marker bulbs or flasher bulbs has failed and shorted to ground. Start pulling all bulbs and looking at them.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Old 03-02-2012, 01:57 AM   #3
madpogue
Super Member
madpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud of
 
Join Date: Sep 2004
Location: Madison, WI USA
Posts: 25,713
 

1996 SW2
Default Re: Turn Signals and Hazards Quit Working

And don't ever put in a higher capacity fuse, just to test. As you learned, it will still blow, but if it takes any time to blow, it can damage the circuit in that time.

REWARD EXCELLENCE!

Add to madpogue's Reputation
Rate the quality of this post and help madpogue reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
madpogue is offline   Reply With Quote
Old 03-02-2012, 10:56 PM   #4
wilson.kegler
New Member
wilson.kegler is on a distinguished road
 
Join Date: Mar 2012
Location: Southern Oregon
Posts: 4

2000 SW2
Default Re: Turn Signals and Hazards Quit Working

This morning I checked the signals in the front and they appeared to be fine. I attempted to check the ones in the back but I was having difficulty getting the sockets out of the housing. I also noticed that the UHAUL plug was all the way dry. So I said what the hell, I will try another fuse. It didn't blow immediately so I assumed the problem was taken care of with the UHAUL plug and I put the rear light housings back on and I taped the plug really well to keep any water out in the future. The turn signals and hazards worked fine all day today but the fuse blew just now on the way home from the store. So I guess I will look around in the rear housings again tomorrow. It's too cold outside to be hand signaling every turn! LOL

REWARD EXCELLENCE!

Add to wilson.kegler's Reputation
Rate the quality of this post and help wilson.kegler reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
wilson.kegler is offline   Reply With Quote
Old 03-03-2012, 01:27 AM   #5
OldNuc
Super Member
OldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant future
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 63,249
 

1998 SC2
Default Re: Turn Signals and Hazards Quit Working

Sounds like you have located the general location of the problem. If a bulb has a broken filament it will light sometimes and short out at others. The dual filament brake/tail light bulbs are known for this failure.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Old 03-03-2012, 02:00 AM   #6
ruley73
Master Member
ruley73 is a name known to allruley73 is a name known to allruley73 is a name known to allruley73 is a name known to allruley73 is a name known to allruley73 is a name known to all
 
ruley73's Avatar
 
Join Date: Aug 2006
Location: Is this heaven?....No, it's Iowa!
Posts: 2,732
 

2007 ION-2 Quad Coupe
Default Re: Turn Signals and Hazards Quit Working

If you've never had the problem before. I'd suspect something is awry with the lights on the UHAUL trailer.

...
2007 Ion 2 Quad Coupe 5-speed manual 170K miles
2007 Chevy Equinox LT 155K miles

REWARD EXCELLENCE!

Add to ruley73's Reputation
Rate the quality of this post and help ruley73 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ruley73 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
98 sl2 - turn signals not working / hazards working normal Jetfixer10 S-Series Tech 14 10-31-2016 03:10 PM
Turn signals not working. Hazards work cwills2 L-Series Tech 17 03-20-2016 07:37 PM
Turn signals & hazards intermittent in 91 SL2 Cartell S-Series General 2 09-19-2011 12:14 AM
Turn signals don't work, hazards do a7x_audiojunkie S-Series Tech 2 06-03-2009 04:03 PM
turn signals and hazards just stopped working renadena S-Series General 6 05-14-2005 03:14 PM


All times are GMT -5. The time now is 11:07 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.