SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Advanced Forum Search | Advanced Photo Search

Reply
 
Thread Tools Display Modes
Old 03-01-2012, 12:28 AM   #1
donseattle
New Member
donseattle is on a distinguished road
 
Join Date: Oct 2008
Posts: 7
Default L300 power loss under load

i have a 2001 L300 (v-6). The car has been throwing a code of a cylinder 3 misfire and a multiple misfire. The car loses power (a lot)under load - when really stepping on the gas the car loses power - i changed the plugs - there are new o2 sensors - any ideas? Could it be one of the coil packs? Any way to test that?

Thanks

REWARD EXCELLENCE!

Add to donseattle's Reputation
Rate the quality of this post and help donseattle reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
donseattle is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 03-01-2012, 01:31 AM   #2
lw300v6
Junior Member
lw300v6 is on a distinguished road
 
Join Date: Dec 2009
Posts: 41
Default Re: L300 power loss under load

I had a similar problem with my car and one of the coil packs had gone. Replacing the coil pack fixed my hesitation and Power loss but my power loss was consistent! My coil pack smelt like it had burnt out so maybe smell it to see if it smells very strong like burning

REWARD EXCELLENCE!

Add to lw300v6's Reputation
Rate the quality of this post and help lw300v6 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
lw300v6 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 L300... At a loss... HELP PLEASE! SJBooth L-Series Tech 2 02-19-2012 12:44 AM
2003 Saturn L300 loss of power Bhmm444 L-Series Tech 15 11-26-2011 11:43 PM
2001 L300 Loss of Power gagirl678 L-Series Tech 0 11-05-2011 09:56 PM
Power Steering fluid Loss on L300 Rogue L-Series Tech 4 01-23-2007 09:07 AM
94 SL2 - loss of power under load CPL0341 S-Series Tech 5 06-08-2004 02:20 PM


All times are GMT -5. The time now is 06:52 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.