SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 09-01-2011, 01:45 PM   #1
craeshe
New Member
craeshe is on a distinguished road
 
Join Date: Sep 2011
Posts: 8
Wrench P0442 + Ramdon Idle Problems + Random Start Problems

Hey Guys! First time to the forums posting, but I have definitely gotten a lot of information from the sight. Here's the problem that only Saturn fans like yourselves can help me with.

Bought a 2001 SC2, 60,000 miles. Within the second week, the Service Engine light came on, checked it at Auto Zone, got the P0442. I replaced the Fuel Cap and reset the car by unplugging the battery. The light went off for about 800 miles, then reappeared today! Among all of this starting in the first week of purchase, the car would idle funny: As in staying at 2k-rpm unless I pressed the gas to make it go higher, then it would settle correctly back at about 900. It has also been starting very funny. Occasionally, it seems that when I start it, it wants to die within the first 3 or 4 seconds of the start, and sometimes it does just that...dies. It 'seems' to do this when the car has been used a couple times.....ie went to the store --> turned it off, then went to the movies ---> turned it off...then about the 3+ time, it will start the description above.

Ultimate question: Can this all be because of a vacuum leak? If I fix the vacuum leak, do you think the other problems would go away?

Any help would be appreciated.

THANKS!

Last edited by craeshe; 09-01-2011 at 01:58 PM..

REWARD EXCELLENCE!

Add to craeshe's Reputation
Rate the quality of this post and help craeshe reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
craeshe is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 09-01-2011, 02:01 PM   #2
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 63,596
 

1998 SC2
Default Re: P0442 + Ramdon Idle Problems + Random Start Problems

An intake vacuum leak is possible and the high RPM idle sounds like a bad TPS. The TPS should be an OEM part so get a replacement at the local Junk Yard. Aftermarket part is not worth the cost. You want a TPS from either a SOHC or DOHC 00-02 car. Then you need to check the intake for a vacuum leak. Check that the small vacuum line from the throttle body is connected to the purge solenoid located above the starter.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Old 09-01-2011, 02:10 PM   #3
craeshe
New Member
craeshe is on a distinguished road
 
Join Date: Sep 2011
Posts: 8
Default Re: P0442 + Ramdon Idle Problems + Random Start Problems

As a simpler person who doesn't know too much about the tech part of your answer. How do I test for a leak? Do I need to take it to a shop and have it lifted?

REWARD EXCELLENCE!

Add to craeshe's Reputation
Rate the quality of this post and help craeshe reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
craeshe is offline   Reply With Quote
Old 09-01-2011, 03:30 PM   #4
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 63,596
 

1998 SC2
Default Re: P0442 + Ramdon Idle Problems + Random Start Problems

Get car warm and idling and then lightly spray brake cleaner along the joint between the manifold and head. I f there is a leak and you hit it the idle will change.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Old 09-02-2011, 08:03 PM   #5
craeshe
New Member
craeshe is on a distinguished road
 
Join Date: Sep 2011
Posts: 8
Default Re: P0442 + Ramdon Idle Problems + Random Start Problems

Thanks for a quick response. If it is a leak in the EVAP, could it be why the car dies or has problems starting as stated in my first post?...Or does that sound more like a fuel filter/pump issue?

Craeshe

REWARD EXCELLENCE!

Add to craeshe's Reputation
Rate the quality of this post and help craeshe reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
craeshe is offline   Reply With Quote
Old 09-02-2011, 08:37 PM   #6
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 63,596
 

1998 SC2
Default Re: P0442 + Ramdon Idle Problems + Random Start Problems

Check that the vacuum line from the throttle body is attached to the purge solenoid, if it is not then you get the 442 leak code. The purge solenoid is on the back of the block just above the starter.

Last edited by OldNuc; 09-02-2011 at 08:43 PM..

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Old 09-08-2011, 11:19 AM   #7
craeshe
New Member
craeshe is on a distinguished road
 
Join Date: Sep 2011
Posts: 8
Default Re: P0442 + Ramdon Idle Problems + Random Start Problems

Possibly fixed! I replaced the ECTS and the rev'ing problem went away. Now I am waiting for the SES light to go away.

REWARD EXCELLENCE!

Add to craeshe's Reputation
Rate the quality of this post and help craeshe reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
craeshe is offline   Reply With Quote
Old 09-08-2011, 11:27 AM   #8
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 63,596
 

1998 SC2
Default Re: P0442 + Ramdon Idle Problems + Random Start Problems

If you want to clear the codes yourself just pull the PCM B fuse for a couple of minutes and put it back. It is in the engine fuse box and the diagram is in the lid.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1993 SL2 random problems ZachIsMyName89 S-Series Tech 8 03-30-2009 11:19 PM
2006 ION 2 - Random Electronic Problems / Posessed! mwheeler1982 Ion Tech 2 01-02-2009 06:59 PM
Idle Problems SL2 Sara26 S-Series General 5 04-06-2008 09:14 PM
94 SW2 start/idle problems sbluestubes S-Series Tech 8 03-06-2007 02:35 PM
1996 saturn sl1 idle and start up problems stagfish S-Series General 1 08-21-2006 11:55 AM


All times are GMT -5. The time now is 05:25 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.