SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 08-22-2013, 11:33 AM   #21
Northeaster22
Junior Member
Northeaster22 will become famous soon enoughNortheaster22 will become famous soon enough
 
Northeaster22's Avatar
 
Join Date: Feb 2011
Posts: 20
Default Re: Problems with 2003 Saturn wagon LW300 auto transmission

Posting update on 2 problems solved with this car (from the January 2013 post):

Highpitched screeching noise that didn't go away after warmup was the serpentine belt and entire mechanism (pulley?). When those were replaced, noise stopped entirely.

ALSO GONE: "REDUCED POWER LIGHT" , dead power, in middle of rolling turn. Guessing the serpentine lost its "grip" in the force of turning, so the car temporarily died then recovered after the turn was done.

Never had to try the "remove PS fluid with turkey baster" fix, was unnecessary, and am pretty relieved to think that the engine on/off/reduced power problem doesn't seem to have been "crank position sensor announcing its impending failure," as fdryer had suggested here http://www.saturnfans.com/forums/arc.../t-163940.html

...
210,000 miles (8/20/13) ... do I hear 300,000...?

2003 V6 3.0L LW300 Automatic (my big red wagon)
1993 4cyl 1.9L SL2 stick (my little green tin sardine can, traded in for above at 167k)

REWARD EXCELLENCE!

Add to Northeaster22's Reputation
Rate the quality of this post and help Northeaster22 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Northeaster22 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 08-26-2017, 10:55 AM   #22
riviera8
New Member
riviera8 is on a distinguished road
 
Join Date: Jan 2011
Posts: 4
Default Re: Problems with 2003 Saturn wagon LW300 auto transmission

Hi: Thanks for making the effort to record your fascinating journey with your Saturn lw300. We have one too and are trying to get to 200K miles. People like you help us all. Thanks again.
Larry and Sharon Lapham

REWARD EXCELLENCE!

Add to riviera8's Reputation
Rate the quality of this post and help riviera8 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
riviera8 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto Transmission Problems BustedSL2 S-Series Tech 4 10-07-2009 09:49 AM
2003 LW300 Electrical Problems Cbrawls L-Series Tech 5 05-17-2007 02:15 PM
2003 vs. 2006 Auto Transmission kilcher Ion General 8 08-29-2005 02:57 PM
L200 2003 auto transmission pan bklyn87 L-Series General 4 10-15-2004 07:00 PM
squeak -lw300 wagon negindy L-Series Tech 3 07-10-2002 03:44 PM


All times are GMT -5. The time now is 12:54 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.