SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 11-28-2010, 08:21 PM   #1
blackcatsl2
Junior Member
blackcatsl2 is on a distinguished road
 
Join Date: Nov 2010
Location: Charlotte NC
Posts: 11

1997 SL2
Default Check Engine light still coming on after replacement of both O2 sensors!

Good evening Fellow Saturn fans:

I am a newbie I have own my 97 SL2 for for years and every year its a pain to get it inspected. Last year in December I replaced both O2 sensors reset ted the check engine light by disconnecting the battery over night drove the car about 60 miles as I'm driving the check engine light flashes intermittently around 70-75 mph or when there's a slight change in throttle position. I passed my emissions last year in December soon after in January 10th check engine light came again and stayed on had the code check it was said to be O2 sensor once again. Recently I have replaced the O2 sensor once again and the Catalytic Converter because it was shot and the check engine light is still coming on, I am completely baffled by this and its time for my emissions again please help.

Sincerely

Blackcatsl2

P.S. Check engine light starts dancing at at high speeds. The car is running fine no problems otherwise great mpg?

REWARD EXCELLENCE!

Add to blackcatsl2's Reputation
Rate the quality of this post and help blackcatsl2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
blackcatsl2 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 11-28-2010, 08:46 PM   #2
Growser
Advanced Member
Growser is on a distinguished road
 
Growser's Avatar
 
Join Date: Aug 2008
Location: New Prague, Minnesota
Posts: 958
 

2002 SL2
2000 SL1
Default Re: Check Engine light still coming on after replacement of both O2 sensors!

The check engine light indicates a problem code that's stored. You need to bring your car to an auto parts store and ask them to read the code for you. Write down the exact code number(s) and report them back here and many of us can help you.

...
7 Saturn Car Family with + 900,000 miles.
2002 SL2, 2000 SL1, 1997 SC2, 1997 SC1, 1996 SC1, 1994 SC2, and now a 93 SC2 project car.

REWARD EXCELLENCE!

Add to Growser's Reputation
Rate the quality of this post and help Growser reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Growser is offline   Reply With Quote
Old 11-28-2010, 08:58 PM   #3
fetchitfido
Super Member
fetchitfido is a splendid one to beholdfetchitfido is a splendid one to beholdfetchitfido is a splendid one to beholdfetchitfido is a splendid one to beholdfetchitfido is a splendid one to beholdfetchitfido is a splendid one to behold
 
fetchitfido's Avatar
 
Join Date: May 2006
Posts: 10,813
 

1996 SC2
1997 SW2
Default Re: Check Engine light still coming on after replacement of both O2 sensors!

If you can't do it yourself have someone you trust check the welds on the exhaust to make sure the people that put it in weren't lazy b-tards that couldn't take off ~5 bolts/nuts to drop the exhaust enough to weld the final 1/8" of the top side of the pipe.

That was the problem with my '96 & the O2 sensor codes, still has the problem but I think it's because my clamp job sucks with the header->stock cat.

Usually a flashing CEL/SES light means misfire and it should set a misfire code indicating which cyl it's in but if yours hates you it'll just give the code for "random misfire."

...
Collection of S-Series info: "https://drive.google.com/folderview?id=0B5D8XfJgavxrdE5mcHBlMG5rbUU&usp=sharing"
3 ECTS pigtails, 1 ECTS FS

REWARD EXCELLENCE!

Add to fetchitfido's Reputation
Rate the quality of this post and help fetchitfido reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fetchitfido is offline   Reply With Quote
Old 11-28-2010, 09:06 PM   #4
madpogue
Super Member
madpogue is a splendid one to beholdmadpogue is a splendid one to beholdmadpogue is a splendid one to beholdmadpogue is a splendid one to beholdmadpogue is a splendid one to beholdmadpogue is a splendid one to beholdmadpogue is a splendid one to behold
 
Join Date: Sep 2004
Location: Madison, WI USA
Posts: 25,387
 

1996 SW2
Default Re: Check Engine light still coming on after replacement of both O2 sensors!

Indeed, flashing SES means a severe misfire, enough to damage the catalytic.

What were the codes the first time the SES light was on, that prompted you to replace both O2 sensors? What are the codes now?

REWARD EXCELLENCE!

Add to madpogue's Reputation
Rate the quality of this post and help madpogue reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
madpogue is offline   Reply With Quote
Old 11-29-2010, 07:57 PM   #5
blackcatsl2
Junior Member
blackcatsl2 is on a distinguished road
 
Join Date: Nov 2010
Location: Charlotte NC
Posts: 11

1997 SL2
Default Re: Check Engine light still coming on after replacement of both O2 sensors!

The code I'm getting when read is P1131 HO2S Circuit Low Variance Bank 1 Sensor 2. I had both sensors replaced when I had the new catalytic converter put on this past Saturday 11/27/10, please help so I can relay message to mechanic.

REWARD EXCELLENCE!

Add to blackcatsl2's Reputation
Rate the quality of this post and help blackcatsl2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
blackcatsl2 is offline   Reply With Quote
Old 11-29-2010, 08:21 PM   #6
OldNuc
Super Member
OldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant future
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 51,529
 

1998 SC2
Default Re: Check Engine light still coming on after replacement of both O2 sensors!

Back of block above the starter right under #4 intake runner is a 10mm bolt with 2 tan wires on 1 ring terminal and 2 black/white wires on a separate ring terminal. The bolt can be reached from above if you remove the air intake tube. Gently clean both ring terminals and clean up the block mating surface and reattach. Reset all codes by removing the PCM B fuse located in engine compartment fuse box and test drive.

If any dielectric grease or other chemical cleaners were used on the rear O2 sensor connector mounted on the rear cradle rail the O2 sensor is contaminated and may never function.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Old 12-13-2010, 01:09 AM   #7
blackcatsl2
Junior Member
blackcatsl2 is on a distinguished road
 
Join Date: Nov 2010
Location: Charlotte NC
Posts: 11

1997 SL2
Default Re: Check Engine light still coming on after replacement of both O2 sensors!

Hey fellow Saturn fans I think I found the culpit of my problem which seemed to have been the map/mass flow sensor. After replacing it with a GM original, I've resetted the computer which is taking a lot longer to get ready for emission inspection. I have been back to the inspection station 3x after 90,130,220 miles of driving and still getting a not ready error. Went there yesterday and the inspector could not link up to my on board computer, he had to do a manual read. How long does it take a Saturn to get rid of this error my mechanic told me about 220 miles, what's your take on this? Only the catalyic convertor and O2 sensors are coming up not ready both which I have had replace in the last 2 1/2 weeks.

REWARD EXCELLENCE!

Add to blackcatsl2's Reputation
Rate the quality of this post and help blackcatsl2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
blackcatsl2 is offline   Reply With Quote
Old 12-13-2010, 01:41 AM   #8
fdryer
Super Member
fdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant future
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 29,714
 

2003 L-Series 3.0L Sedan
Default Re: Check Engine light still coming on after replacement of both O2 sensors!

While you were distracted with the obvious error codes pointing to the O2 sensors, the ready monitors not setting/passing is hinting at one or two inconspicuous items some times not mentioned early on; the original plastic engine coolant temperature sensor (ECTS) and possibly worn out thermostat. One or the other will keep coolant temps lower than required and will not allow emissions self tests to run - the readiness monitors conducted at every start up. One of the best hints of a faulty coolant sensor/thermostat is a high idle above 800-900rpm and/or the temperature needle hovering on the 1/4 scale mark instead of at 3/8ths or between the first and second tick mark on the temperature gauge. The colder coolant temps is preventing the OBD II self diagnostics from continuing and completing emissions testing so it hangs up in the process - ready monitors not set until the problems are fixed.

Replacing the original plastic coolant sensor and thermostat (195F) will bring operating temperatures back up where they should be and in short order the readiness monitors will set for passing state inspection. You won't need a long drive at all, just replacing the two items and one drive will be all that's needed as OBD II needs the correct coolant temps to conduct self emissions tests, as quickly as it takes to drive back to the inspection station or if you can plug in a reader (Autozone?) to check the readiness monitors before going back to the inspection station.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is online now   Reply With Quote
Old 12-13-2010, 09:13 AM   #9
SLCraig
Master Member
SLCraig is on a distinguished road
 
Join Date: Aug 2007
Location: London, ON
Posts: 2,916

1996 SL2
2000 SW2
Default Re: Check Engine light still coming on after replacement of both O2 sensors!

fdryer said what I wanted to say.
When I bought my 96 it had a bad t-stat as every Saturn I've ever bought has, and it tripped the check engine light before I got around to changing it.

Once I changed the thermostat it got rid of my o2 sensor code because the engine was running at a proper operating temp from that point forward.

...
1996 SL2 5MT. 239KMs. Gone, but not forgotten.
2000 SW2 5MT. 133KMs. Gone, but not forgotten.

REWARD EXCELLENCE!

Add to SLCraig's Reputation
Rate the quality of this post and help SLCraig reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
SLCraig is offline   Reply With Quote
Old 12-13-2010, 09:32 AM   #10
OldNuc
Super Member
OldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant future
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 51,529
 

1998 SC2
Default Re: Check Engine light still coming on after replacement of both O2 sensors!

Replace the thermostat, STANT 14279 brand is the correct one to use. If your temperature gauge does not reach 3/8, half way between the 1/4 and 1/2 marks then the monitors will not reset, ever.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light and antitheft light 2004 L300 jonus311 L-Series Tech 2 01-31-2009 08:55 AM
Saturn SL1 - Engine Light came on twice then stopped coming on. foo S-Series General 22 05-03-2008 09:08 AM
Check Engine Light/ Temperture light storm_amoure S-Series Tech 3 07-28-2007 10:07 PM
Check Engine Light W/ Reduced Power light saturnfreak01 L-Series Tech 5 01-24-2004 11:04 PM
Engine/transaxle light coming on 94sc293sl1 S-Series Tech 13 05-21-2003 07:58 PM


All times are GMT -5. The time now is 06:09 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.