SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 10-04-2011, 07:30 PM   #1
gingermiss
New Member
gingermiss is on a distinguished road
 
Join Date: Oct 2011
Location: logan, ohio
Posts: 1

2002 SL1
Default sl1 help

i have an sl1, 2002...
i have changed throttle sensor, 1 of O2 sensor, fuel pump/ filter, plug/wires, engine coolant temp sensor, map sensor, and full oil change

the car starts and idles perfectly, runs great until u come to first complete stop..then it doesnt want to accelerate and when it does wont go above 15 mph without dying..

i am at a loss as to what it could be...can someone please help

REWARD EXCELLENCE!

Add to gingermiss's Reputation
Rate the quality of this post and help gingermiss reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
gingermiss is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 10-04-2011, 07:46 PM   #2
TXSaturn02
Master Member
TXSaturn02 has a spectacular aura aboutTXSaturn02 has a spectacular aura aboutTXSaturn02 has a spectacular aura about
 
TXSaturn02's Avatar
 
Join Date: Dec 2006
Location: Houston
Posts: 4,042
 

2002 SL2
Default Re: sl1 help

The throttle sensor and the fuel filter (I assume you meant filter, because the pump rarely goes out that early) needs to be OEM. What did you put in there?

...
2002 SL2 Manual - new in November, 2001
Sticker: $13,995 As of 09/30/17: 223,751 Miles - SOLD

2013 Mazda 3 HB - new in October 2012
Sticker: $20,850 As of 09/30/17: 38,381 Miles

REWARD EXCELLENCE!

Add to TXSaturn02's Reputation
Rate the quality of this post and help TXSaturn02 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
TXSaturn02 is offline   Reply With Quote
Old 10-04-2011, 09:09 PM   #3
velleguy73
Senior Member
velleguy73 is on a distinguished road
 
Join Date: Oct 2008
Location: Farmington MI
Posts: 1,206
 

2001 SL
2002 SL
Default Re: sl1 help

Is the check engine light on? Throwing any codes?

REWARD EXCELLENCE!

Add to velleguy73's Reputation
Rate the quality of this post and help velleguy73 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
velleguy73 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:24 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.