SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Ion > Ion General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 03-07-2010, 11:03 PM   #1
jess3292
Junior Member
jess3292 is on a distinguished road
 
Join Date: May 2006
Location: Yorktown Heights ,NY
Posts: 41

2003 ION-3 Sedan
Default "Service Vehicle" Message on Dash

I have a 2003 ION 3 with 127K miles - The car is working fine and I keep it well maintained and in order. Today I recevied a "Service Vehicle" message on the odometer on the dash when I started the car - nothing appeared wrong and it went away when I pressed in the odometer button. I drove the car for a while and all is good. Later when I started the car again I got the message again. I have an OBD II tester and I tried to see if the car had any codes posted - it did not. Again al appears to be fine. I used the tester to clear the "Service Vehicle" message and it has not come back again since. When I checked the owners manual, it says that this message indicates a non-emissions related error. My questions are simple:

1) What types of issues does the "Service vehicle" message actually indicate?

2) How do you diagnose these types of problems or find the codes for them?

Not sure if this has anything to do with the problem, but today was the warmest day we have had in months by over 20 degrees (F)..

Any help, guidance or advice would really be appreciated... Thanks in advance!

REWARD EXCELLENCE!

Add to jess3292's Reputation
Rate the quality of this post and help jess3292 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
jess3292 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 03-07-2010, 11:24 PM   #2
2006 ion2
Master Member
2006 ion2 will become famous soon enough2006 ion2 will become famous soon enough
 
Join Date: Jun 2007
Location: Da U.P, EH!
Posts: 8,114
 

2007 ION-2 Sedan
Default Re: "Service Vehicle" Message on Dash

if your scanner is not canbus compatible, it will not read codes on our cars. if you cannot read the codes, only GM can, and sometimes even they cannot if one is not stored.

...
2007 Saturn Ion 2
2003 Chevrolet venture lt

trifecta dealer for the U.P. and WI. There is no two door ion. Proudly driving one of the last saturns produced before gm killed the brand.

REWARD EXCELLENCE!

Add to 2006 ion2's Reputation
Rate the quality of this post and help 2006 ion2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
2006 ion2 is offline   Reply With Quote
Old 03-07-2010, 11:35 PM   #3
jess3292
Junior Member
jess3292 is on a distinguished road
 
Join Date: May 2006
Location: Yorktown Heights ,NY
Posts: 41

2003 ION-3 Sedan
Default Re: "Service Vehicle" Message on Dash

I do not beleive that my scanner is Can Bus compatible...Soa are you saying that my only option is to go to a GM dealer and see if they can access the Can Bus info?

REWARD EXCELLENCE!

Add to jess3292's Reputation
Rate the quality of this post and help jess3292 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
jess3292 is offline   Reply With Quote
Old 03-08-2010, 12:06 AM   #4
2006 ion2
Master Member
2006 ion2 will become famous soon enough2006 ion2 will become famous soon enough
 
Join Date: Jun 2007
Location: Da U.P, EH!
Posts: 8,114
 

2007 ION-2 Sedan
Default Re: "Service Vehicle" Message on Dash

no, parts stores can usually scan your car for free (california excluded) and the canbus system is basically OBD2.5, the only reason it can't be considered OBD3 is the plug is the same as OBDII.

...
2007 Saturn Ion 2
2003 Chevrolet venture lt

trifecta dealer for the U.P. and WI. There is no two door ion. Proudly driving one of the last saturns produced before gm killed the brand.

REWARD EXCELLENCE!

Add to 2006 ion2's Reputation
Rate the quality of this post and help 2006 ion2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
2006 ion2 is offline   Reply With Quote
Old 03-08-2010, 01:31 AM   #5
MoparNut
Advanced Member
MoparNut will become famous soon enough
 
MoparNut's Avatar
 
Join Date: Mar 2004
Location: Buffalo
Posts: 591
 
Default Re: "Service Vehicle" Message on Dash

It may just be your Oil Life Monitor telling you your oil change is due. Press the trip button once to bring up reset screen, then press and hold until it chimes 5X.

REWARD EXCELLENCE!

Add to MoparNut's Reputation
Rate the quality of this post and help MoparNut reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MoparNut is offline   Reply With Quote
Old 03-08-2010, 07:08 AM   #6
2006 ion2
Master Member
2006 ion2 will become famous soon enough2006 ion2 will become famous soon enough
 
Join Date: Jun 2007
Location: Da U.P, EH!
Posts: 8,114
 

2007 ION-2 Sedan
Default Re: "Service Vehicle" Message on Dash

the OLM says change oil, not service vehicle. don't reset the OLM.

...
2007 Saturn Ion 2
2003 Chevrolet venture lt

trifecta dealer for the U.P. and WI. There is no two door ion. Proudly driving one of the last saturns produced before gm killed the brand.

REWARD EXCELLENCE!

Add to 2006 ion2's Reputation
Rate the quality of this post and help 2006 ion2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
2006 ion2 is offline   Reply With Quote
Old 03-08-2010, 12:09 PM   #7
lgodave
Senior Member
lgodave will become famous soon enough
 
Join Date: Apr 2004
Location: WI
Posts: 1,648
 

2003 ION-3 Sedan
Default Re: "Service Vehicle" Message on Dash

Quote:
Originally Posted by MoparNut View Post
It may just be your Oil Life Monitor telling you your oil change is due. Press the trip button once to bring up reset screen, then press and hold until it chimes 5X.
If you are a chronological reader and RAN out to do this before reading 2006 ion2's post in the morning... you'll need to now change your oil within 3,000 miles (unless you're oil is already "long in the tooth" and your OLM was going to go off anyway say past 6,000+ miles... then I wouldn't recommend pushing your Oil an "extra" 3,000 miles)

Basically. If you reset the Oil Life Monitor BEFORE it tells you to change the Oil... then you're in for an early (possibly unneeded) Oil Change OR a possibly EXTRA long one which might be problematic.

As for one possible cause of a SERVICE VEHICLE light... I had an electronic component which Saturn at first thought was a "fluck" and reset it. A few days to a week later the component actually failed (gave me the same SERVICE VEHICLE message). I think it was a sensor. Not too happy about the repeat visit but electrical shorts can be a real pain some times. Everything looks fine until it doesn't.

Not a SERVICE VEHICLE light issue but my Dad's GMC Truck had a bad Power Lock Actuator which was intermittent (thought it might be wiring) AND an Air Bag Light (again thought it might be wiring or a very serious/expensive component failure)... it was the connection on an arming sensor that had rotted/corroded away.

The SERVICE VEHICLE message might be something simple (cheap) or it could be something serious (expensive)... only thing to do is hope it is leaving a Code or you/your mechanic can diagnose the issue another way. Hopefully looking at the simple/easy stuff first... before looking for shorted wires and disassembling your dash or something.

REWARD EXCELLENCE!

Add to lgodave's Reputation
Rate the quality of this post and help lgodave reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
lgodave is offline   Reply With Quote
Old 03-09-2010, 12:41 PM   #8
2006 ion2
Master Member
2006 ion2 will become famous soon enough2006 ion2 will become famous soon enough
 
Join Date: Jun 2007
Location: Da U.P, EH!
Posts: 8,114
 

2007 ION-2 Sedan
Default Re: "Service Vehicle" Message on Dash

and one decided to join our forums, posting nothing but juvenile insults. they did it on the ion, vue, ect... forums.

...
2007 Saturn Ion 2
2003 Chevrolet venture lt

trifecta dealer for the U.P. and WI. There is no two door ion. Proudly driving one of the last saturns produced before gm killed the brand.

REWARD EXCELLENCE!

Add to 2006 ion2's Reputation
Rate the quality of this post and help 2006 ion2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
2006 ion2 is offline   Reply With Quote
Old 03-09-2010, 11:11 PM   #9
chilipepper1327
Advanced Member
chilipepper1327 is on a distinguished road
 
chilipepper1327's Avatar
 
Join Date: Jul 2009
Location: Listowel, Ontario, Canada
Posts: 979

2006 ION-3 Quad Coupe
Default Re: "Service Vehicle" Message on Dash

Quote:
Originally Posted by jess3292 View Post
I have a 2003 ION 3 with 127K miles - The car is working fine and I keep it well maintained and in order. Today I recevied a "Service Vehicle" message on the odometer on the dash when I started the car - nothing appeared wrong and it went away when I pressed in the odometer button. I drove the car for a while and all is good. Later when I started the car again I got the message again. I have an OBD II tester and I tried to see if the car had any codes posted - it did not. Again al appears to be fine. I used the tester to clear the "Service Vehicle" message and it has not come back again since. When I checked the owners manual, it says that this message indicates a non-emissions related error. My questions are simple:

1) What types of issues does the "Service vehicle" message actually indicate?

2) How do you diagnose these types of problems or find the codes for them?

Not sure if this has anything to do with the problem, but today was the warmest day we have had in months by over 20 degrees (F)..

Any help, guidance or advice would really be appreciated... Thanks in advance!
All cars can throw out ghost readings or errors. Disconnect your battery for 30 minutes, the positive cable. Under the floor in the trunk. Make sure your stereo is not password protected. Check your manual for this. Reconnect your battery and drive around for 20 minutes or so to set the EMC. If the reading is gone and stays away, don't worry about it. I have an '04 and every once in awhile this happens for no apparent reason. If it keeps coming back after connecting the battery, there is probably something going on. My EMC is wonky. And it almost killed me. Every once in awhile, my cars enging will just shut down out of the blue. It doesn't stall, it just quits. On a snowy road, going about 50, my enging quit. Well you can guess what happened. I had no steering cause the wheels were no longer turning on the snow and ice and no control. Ended up doing a 360, into the snow bank on the highway. No damage or accident thank God as very little traffic. Hasn't happened in awhile so I think I am due again.

REWARD EXCELLENCE!

Add to chilipepper1327's Reputation
Rate the quality of this post and help chilipepper1327 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
chilipepper1327 is offline   Reply With Quote
Old 03-10-2010, 02:16 AM   #10
lgodave
Senior Member
lgodave will become famous soon enough
 
Join Date: Apr 2004
Location: WI
Posts: 1,648
 

2003 ION-3 Sedan
Default Re: "Service Vehicle" Message on Dash

Quote:
Originally Posted by chilipepper1327 View Post
All cars can throw out ghost readings or errors. <Clip> My EMC is wonky. And it almost killed me. Every once in awhile, my cars enging will just shut down out of the blue. It doesn't stall, it just quits. On a snowy road, going about 50, my enging quit. Well you can guess what happened. I had no steering cause the wheels were no longer turning on the snow and ice and no control. Ended up doing a 360, into the snow bank on the highway. No damage or accident thank God as very little traffic. Hasn't happened in awhile so I think I am due again.
Care to share any troubleshooting you've tried besides resetting the computer? Just out of the blue I'd check your ignition switch.

REWARD EXCELLENCE!

Add to lgodave's Reputation
Rate the quality of this post and help lgodave reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
lgodave is offline   Reply With Quote
Old 03-10-2010, 08:18 AM   #11
2006 ion2
Master Member
2006 ion2 will become famous soon enough2006 ion2 will become famous soon enough
 
Join Date: Jun 2007
Location: Da U.P, EH!
Posts: 8,114
 

2007 ION-2 Sedan
Default Re: "Service Vehicle" Message on Dash

you disconnect the negative cable usually, it's less traumatic to the system to connect and disconnect (notice no spark when you do the negative). also, I agree to check your ignition and key chain weight when it cuts out on you, since heavy key rings and/or worn ignition lock cylinders are known to shut off when the key chain pulls it into the accessory position.

...
2007 Saturn Ion 2
2003 Chevrolet venture lt

trifecta dealer for the U.P. and WI. There is no two door ion. Proudly driving one of the last saturns produced before gm killed the brand.

REWARD EXCELLENCE!

Add to 2006 ion2's Reputation
Rate the quality of this post and help 2006 ion2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
2006 ion2 is offline   Reply With Quote
Old 03-10-2010, 03:59 PM   #12
chilipepper1327
Advanced Member
chilipepper1327 is on a distinguished road
 
chilipepper1327's Avatar
 
Join Date: Jul 2009
Location: Listowel, Ontario, Canada
Posts: 979

2006 ION-3 Quad Coupe
Default Re: "Service Vehicle" Message on Dash

Quote:
Originally Posted by 2006 ion2 View Post
you disconnect the negative cable usually, it's less traumatic to the system to connect and disconnect (notice no spark when you do the negative). also, I agree to check your ignition and key chain weight when it cuts out on you, since heavy key rings and/or worn ignition lock cylinders are known to shut off when the key chain pulls it into the accessory position.
Got you but this is not the issue. It is the EMC and it does other wierd things as well. Saturn said to buy a new one. Yeah. Right. Great support eh?

Things happen like the engine will race. In other words, you are going say 50kph and you have to press the accelerator to keep the same speed and the enging RPM's keep going up. It is either the TCM or the ECM. Haven't figured that one out yet.

Turning the car off and back on does not fix it. When I disconnect the battery, it is ok. No error codes. There are other little quirks as well, and disconnecting the battery and reconnecting it works.

As I said in an earlier post, it is getting better. Don't know why. In other words longer and longer intervals between events. And it seems to happen mostly in the summer, except for the engine cutting out. That happens any time. And no, its not the key way. It is always still in the run position when this happens.

I should knock on wood cause I am due for another "event" at any time! lol!

REWARD EXCELLENCE!

Add to chilipepper1327's Reputation
Rate the quality of this post and help chilipepper1327 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
chilipepper1327 is offline   Reply With Quote
Old 03-10-2010, 10:47 PM   #13
lgodave
Senior Member
lgodave will become famous soon enough
 
Join Date: Apr 2004
Location: WI
Posts: 1,648
 

2003 ION-3 Sedan
Default Re: "Service Vehicle" Message on Dash

Well did Saturn do any diagnostic work to suggest the ECM or was it just a guess? If they did tests then why do you think it might be the TCM?

You did say the issue almost killed you. Seems like you might be able to find a new or used ECM (one of those doesn't need special programming or dealer install does it?) and swap it out... while you use the Battery Reset trick as a temp work around only.

Seems kind of a simple fix. Don't deny that the battery reset is only masking the problem.

REWARD EXCELLENCE!

Add to lgodave's Reputation
Rate the quality of this post and help lgodave reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
lgodave is offline   Reply With Quote
Old 03-10-2010, 11:04 PM   #14
2006 ion2
Master Member
2006 ion2 will become famous soon enough2006 ion2 will become famous soon enough
 
Join Date: Jun 2007
Location: Da U.P, EH!
Posts: 8,114
 

2007 ION-2 Sedan
Default Re: "Service Vehicle" Message on Dash

an ECU requires dealership programing, used or not., but if it's almost killing you, ignoring it and band aids are not the answer.

...
2007 Saturn Ion 2
2003 Chevrolet venture lt

trifecta dealer for the U.P. and WI. There is no two door ion. Proudly driving one of the last saturns produced before gm killed the brand.

REWARD EXCELLENCE!

Add to 2006 ion2's Reputation
Rate the quality of this post and help 2006 ion2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
2006 ion2 is offline   Reply With Quote
Old 03-11-2010, 01:39 AM   #15
chilipepper1327
Advanced Member
chilipepper1327 is on a distinguished road
 
chilipepper1327's Avatar
 
Join Date: Jul 2009
Location: Listowel, Ontario, Canada
Posts: 979

2006 ION-3 Quad Coupe
Default Re: "Service Vehicle" Message on Dash

Quote:
Originally Posted by 2006 ion2 View Post
an ECU requires dealership programing, used or not., but if it's almost killing you, ignoring it and band aids are not the answer.
Of course I had it checked out. Cost me 60 and tax and it came back no problems. Like I said earlier, no codes were thrown out earlier. Not easy to find a care with the exact same set up. Look to the thread were the user swapped out his VTi for an Aisan. What he had to go through with the ECM and TCM. It has to match. I am sure there are some out there, but when I was looking for parts, there was only one Quad coupe in all of Ontario at the wreckers. Sigh.

REWARD EXCELLENCE!

Add to chilipepper1327's Reputation
Rate the quality of this post and help chilipepper1327 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
chilipepper1327 is offline   Reply With Quote
Old 03-11-2010, 01:12 PM   #16
lgodave
Senior Member
lgodave will become famous soon enough
 
Join Date: Apr 2004
Location: WI
Posts: 1,648
 

2003 ION-3 Sedan
Default Re: "Service Vehicle" Message on Dash

Quote:
Originally Posted by chilipepper1327 View Post
I am sure there are some out there, but when I was looking for parts, there was only one Quad coupe in all of Ontario at the wreckers. Sigh.
Any chances GM used the ECU on any other model vehicles? Maybe ones that are more readily available in a Canadian Scrap Yard? I got my fingers crossed.

REWARD EXCELLENCE!

Add to lgodave's Reputation
Rate the quality of this post and help lgodave reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
lgodave is offline   Reply With Quote
Old 03-11-2010, 01:52 PM   #17
2006 ion2
Master Member
2006 ion2 will become famous soon enough2006 ion2 will become famous soon enough
 
Join Date: Jun 2007
Location: Da U.P, EH!
Posts: 8,114
 

2007 ION-2 Sedan
Default Re: "Service Vehicle" Message on Dash

other models' ECUs would especially need to be reprogrammed, saturns use their own programming.

...
2007 Saturn Ion 2
2003 Chevrolet venture lt

trifecta dealer for the U.P. and WI. There is no two door ion. Proudly driving one of the last saturns produced before gm killed the brand.

REWARD EXCELLENCE!

Add to 2006 ion2's Reputation
Rate the quality of this post and help 2006 ion2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
2006 ion2 is offline   Reply With Quote
Old 03-11-2010, 06:49 PM   #18
kentwth
New Member
kentwth is on a distinguished road
 
Join Date: Mar 2010
Location: California
Posts: 1

2003 ION-1 Sedan
2001 SL
Default Re: "Service Vehicle" Message on Dash

I have a 2003 ION. I occasionally have the dash warning "Service vehicle" at start-up and it will not start. At first I thought it was the run/crank relay and replaced it. It started right up, one week later, same issue and yes another relay. After the third time this happened within a total of 10 days, I put one of the previous replays back in it and it started. (Not a relay issue) I have since discovered that if I simply let the car set for about 15 minutes, the "Service Vehicle" light goes off and the car will start. Anyone know anything about this problem? My main problem though is this, I hook up my code reader and I get a "Link Error" message on my reader. It will read my 2001 S model but not my ION. What could possibly be going on with the canbus system on my ION?

REWARD EXCELLENCE!

Add to kentwth's Reputation
Rate the quality of this post and help kentwth reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
kentwth is offline   Reply With Quote
Old 03-11-2010, 06:51 PM   #19
chilipepper1327
Advanced Member
chilipepper1327 is on a distinguished road
 
chilipepper1327's Avatar
 
Join Date: Jul 2009
Location: Listowel, Ontario, Canada
Posts: 979

2006 ION-3 Quad Coupe
Default Re: "Service Vehicle" Message on Dash

Quote:
Originally Posted by lgodave View Post
Any chances GM used the ECU on any other model vehicles? Maybe ones that are more readily available in a Canadian Scrap Yard? I got my fingers crossed.
The Saturn Ion Quade Coupe Level 3, 2003 and 2004 have the VTi for the automatic. The ECM for this model speaks to the TCM for the transmission. Therefor they have to be for this actual model. Can it be reprogrammed? I have no idea as it is pretty specific. So, if you are going to get a replacement, used, make sure you get the one for your vehicles transmission type. The standard transmission has no TCM

REWARD EXCELLENCE!

Add to chilipepper1327's Reputation
Rate the quality of this post and help chilipepper1327 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
chilipepper1327 is offline   Reply With Quote
Old 03-11-2010, 06:53 PM   #20
chilipepper1327
Advanced Member
chilipepper1327 is on a distinguished road
 
chilipepper1327's Avatar
 
Join Date: Jul 2009
Location: Listowel, Ontario, Canada
Posts: 979

2006 ION-3 Quad Coupe
Default Re: "Service Vehicle" Message on Dash

Quote:
Originally Posted by kentwth View Post
I have a 2003 ION. I occasionally have the dash warning "Service vehicle" at start-up and it will not start. At first I thought it was the run/crank relay and replaced it. It started right up, one week later, same issue and yes another relay. After the third time this happened within a total of 10 days, I put one of the previous replays back in it and it started. (Not a relay issue) I have since discovered that if I simply let the car set for about 15 minutes, the "Service Vehicle" light goes off and the car will start. Anyone know anything about this problem? My main problem though is this, I hook up my code reader and I get a "Link Error" message on my reader. It will read my 2001 S model but not my ION. What could possibly be going on with the canbus system on my ION?
Try resseting your ECM. Remove the negative battery cable for 10 minutes and reattach. Be sure you don't have the password enabled on your stereo, and if you do, be sure you remember it.

See if that makes a difference.

This is an edit.

Also, try removing the cables for the ECM at the engine, inspect the harness for wear(ie insulation missing or tape missing etc.), clean contacts on both the cable and the junction. They should all be a shiny brass colour.

Hope this helps.

Last edited by chilipepper1327; 03-11-2010 at 06:58 PM..

REWARD EXCELLENCE!

Add to chilipepper1327's Reputation
Rate the quality of this post and help chilipepper1327 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
chilipepper1327 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
"Oil life" message in message center ion_blackline Ion Tech 11 11-07-2008 10:07 AM
Saturn Picks Up "Most Significant Vehicle" Honor at Auto Show with 2009 Vue Hybrid Charlie Vue Green Line 1 01-19-2008 10:45 PM
Service Vehicle Message teebird Ion Tech 2 06-22-2006 09:49 AM
"CHG OIL" message finally pops up Henry_02SC1 Ion General 11 03-24-2005 04:46 PM
03/04 ION no start/blinking "service vehicle" smoothrider Ion General 14 02-19-2005 10:04 AM


All times are GMT -5. The time now is 10:41 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.