SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 01-10-2010, 10:23 PM   #1
01SC02
Member
01SC02 is on a distinguished road
 
Join Date: Sep 2009
Posts: 60
Default Elusive high idle, not your typical noob question

Hello all,

Having an elusive high idle problem constant at 1500 to 2000 rpm's. So far here is what I have done in no perticular order:

- Replaced intake manifold gasket
- Replaced EGR
- Replaced ECTS
- Tested the IACV (tapping it and restarting engine)
- Replaced MAF

Any other ideas on what to check next ?

REWARD EXCELLENCE!

Add to 01SC02's Reputation
Rate the quality of this post and help 01SC02 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
01SC02 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 01-10-2010, 11:48 PM   #2
Tom64
Member
Tom64 is on a distinguished road
 
Join Date: Nov 2007
Location: Connecticut
Posts: 65

1994 SL2
1993 SL2
Default Re: Elusive high idle, not your typical noob question

I had all kinds of problems, including high idle. I don't know if it will work for you, but after I changed spark plug wires, my problems went away.

REWARD EXCELLENCE!

Add to Tom64's Reputation
Rate the quality of this post and help Tom64 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Tom64 is offline   Reply With Quote
Old 01-10-2010, 11:53 PM   #3
01SC02
Member
01SC02 is on a distinguished road
 
Join Date: Sep 2009
Posts: 60
Default Re: Elusive high idle, not your typical noob question

Quote:
Originally Posted by Tom64 View Post
I had all kinds of problems, including high idle. I don't know if it will work for you, but after I changed spark plug wires, my problems went away.
Thanks Tom, yep changed wires and plugs and did'nt help... Yes I did use copper plugs

REWARD EXCELLENCE!

Add to 01SC02's Reputation
Rate the quality of this post and help 01SC02 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
01SC02 is offline   Reply With Quote
Old 01-11-2010, 11:35 AM   #4
rc1488
Master Member
rc1488 has a spectacular aura aboutrc1488 has a spectacular aura about
 
rc1488's Avatar
 
Join Date: Jun 2007
Location: Carmel, NY
Posts: 5,658
 

1997 SL2
1995 SC2
Default Re: Elusive high idle, not your typical noob question

Quote:
Originally Posted by 01SC02 View Post
Hello all,

Having an elusive high idle problem constant at 1500 to 2000 rpm's. So far here is what I have done in no perticular order:

- Replaced intake manifold gasket
- Replaced EGR
- Replaced ECTS
- Tested the IACV (tapping it and restarting engine)
- Replaced MAF

Any other ideas on what to check next ?
This does not effect the IAC. We suggest that for a fualty TPS. Remove the throttle body and clean it including the IAC. Follow Richpins videos for instructions.

...
Current: 95 SC2 Man 97 SL2 Auto 98 SL1 Auto 01 SL1 Man 02 SL1 Man
Past: 94 SL2 Man 95 SL2 Man 95 SL2 Man 96 SL2 Auto 97 SL2 Man 98 SL2 Auto 99 SL2 Auto
2010 SCCA Mohud Street Championship-2nd Place

REWARD EXCELLENCE!

Add to rc1488's Reputation
Rate the quality of this post and help rc1488 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
rc1488 is offline   Reply With Quote
Old 01-11-2010, 02:55 PM   #5
fjmg
Member
fjmg will become famous soon enough
 
Join Date: Aug 2009
Posts: 55
Default Re: Elusive high idle, not your typical noob question

My 98 sl1 had the same issue which also caused difficulty engaging 1st gear at a stop (not to mention a fair amount of pinging). I noticed that my temp gauge only moved up to about a 1/4 of the gauge even on hot days. I deduced that the coolant sensor was informing the computor that my engine is still cold resulting in an improper timing advance. I changed the coolant sensor and the car immediately has a 750 rpm idle, 1st is no problem at a stop and the pinging is pretty much eliminated.

REWARD EXCELLENCE!

Add to fjmg's Reputation
Rate the quality of this post and help fjmg reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fjmg is offline   Reply With Quote
Old 01-11-2010, 03:13 PM   #6
OnDaGround
Master Member
OnDaGround has a spectacular aura aboutOnDaGround has a spectacular aura about
 
OnDaGround's Avatar
 
Join Date: Jun 2008
Location: Get off my lawn!!
Posts: 4,823
 

1993 SC2
Default Re: Elusive high idle, not your typical noob question

Quote:
Originally Posted by rc1488 View Post
This does not effect the IAC. We suggest that for a fualty TPS. Remove the throttle body and clean it including the IAC. Follow Richpins videos for instructions.
What? You mean it was a typical "noob" question? Lol, j/k. Had to bust your chops. Follow RC's advice.

http://www.saturnfans.com/forums/sho...d.php?t=132844

...
Saturnless...

REWARD EXCELLENCE!

Add to OnDaGround's Reputation
Rate the quality of this post and help OnDaGround reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OnDaGround is offline   Reply With Quote
Old 01-11-2010, 03:47 PM   #7
RobertGary1
Master Member
RobertGary1 is just really niceRobertGary1 is just really niceRobertGary1 is just really niceRobertGary1 is just really niceRobertGary1 is just really nice
 
Join Date: Jun 2005
Location: Sacramento
Posts: 3,749
 

1996 SC2
2006 VUE 3.5L
Default Re: Elusive high idle, not your typical noob question

Spray some soapy water all around the intake manifold and see if you can make a temporary seal (the soap will temporarily seal a small leak and cause the RPM's to return to normal). You could even have a cracked manifold. I assume you probably also replaced the gasket behind the TB.
I wonder too if for some reason your IAC is sticking. Perhaps try pulling it out and seeing if its stuck in high idle?


-Robert


Quote:
Originally Posted by 01SC02 View Post
Hello all,

Having an elusive high idle problem constant at 1500 to 2000 rpm's. So far here is what I have done in no perticular order:

- Replaced intake manifold gasket
- Replaced EGR
- Replaced ECTS
- Tested the IACV (tapping it and restarting engine)
- Replaced MAF

Any other ideas on what to check next ?

REWARD EXCELLENCE!

Add to RobertGary1's Reputation
Rate the quality of this post and help RobertGary1 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
RobertGary1 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Idle AND now High RPMs 1995 SC2 randibou S-Series Tech 3 03-20-2009 04:52 PM
High Idle Question carl S-Series General 21 10-10-2006 08:17 PM
Noob with a high idle on 93 SC2 Wizard Prang S-Series Tech 0 02-07-2006 03:58 PM
TEC - SeaFoam Question (Not typical) Red97sc2 S-Series Tech 8 02-08-2005 10:17 AM
93 SL2 Idle..... typical kentuckyfan23 S-Series Tech 4 09-04-2004 03:52 AM


All times are GMT -5. The time now is 03:27 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.