SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 09-12-2009, 05:19 PM   #1
edgillen
New Member
edgillen is on a distinguished road
 
Join Date: Nov 2008
Location: Concord CA
Posts: 5

1999 SC2
Default 99 SC2 Speedometer not working

Speedometer not working
Coolant light flashing
Service engine light on

Codes P0108, P0125, P0415 P0500

Replaced the ECTS and connector -
Topped the colant to normal level
Cleared codes
Drove it on the freeway a few miles
Service engine light off (for now?)
Seems to run fine
Temp gauge betweek 1/4 and 1/2

Speedometer not working
Coolant light flashing
HELP ANYONE

REWARD EXCELLENCE!

Add to edgillen's Reputation
Rate the quality of this post and help edgillen reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
edgillen is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 09-12-2009, 05:31 PM   #2
beermonkey
Member
beermonkey is on a distinguished road
 
beermonkey's Avatar
 
Join Date: Mar 2009
Location: des plaines, il
Posts: 226

1994 SL1
Default Re: 99 SC2 Speedometer not working

the speedo isnt werking because theres a gear in there thats lost a tooth and needs to be replaced. search for SPEEDOMETER GEAR and theres a thread on it. i had to replace mine, wasnt too hard but its annoying.

...
1994 SL1 - R.I.P.
1997 SL2 - sold :)
1978 El Camino - still fixing...
1999 I30t - daily driver
2007 Cag Daytona - fixing
"Gimmie a Pickle jar, I'll open that B***h up like a MotherF**ker!"

REWARD EXCELLENCE!

Add to beermonkey's Reputation
Rate the quality of this post and help beermonkey reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
beermonkey is offline   Reply With Quote
Old 09-12-2009, 08:07 PM   #3
madpogue
Super Member
madpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud of
 
Join Date: Sep 2004
Location: Madison, WI USA
Posts: 25,713
 

1996 SW2
Default Re: 99 SC2 Speedometer not working

Quote:
Originally Posted by beermonkey View Post
the speedo isnt werking because theres a gear in there thats lost a tooth and needs to be replaced. search for SPEEDOMETER GEAR and theres a thread on it. i had to replace mine, wasnt too hard but its annoying.
Um, NO. There is NO "speedometer gear".

Automatic or manual tranny? If an automatic, is it shifting normally? If a manual, try this: sit in the driveway with the engine running and floor the throttle. You'll notice the engine RPMs "bounce off the ceiling" at about 4000-4200 RPM, and it won't go any faster. That's normal. Now, take it up to speed at a place you can coast safely for a bit, push in the clutch, and while coasting, floor the throttle again. See if it bounces off 4000-ish RPM again, or will wind out up to 5000 or more. If the former, suspect your VSS (vehicle speed sensor, on the tranny), or the connection to it. If the latter, it's either the wiring from the PCM to the speedo head, or the speedo head itself.

Coolant light - if you're SURE the reservoir is full (at the seam) and it's still flashing, the float is stuck. Drain enough coolant into a clean vessel to empty the reservoir. Remove it and wash it out with something low-suds (automatic dishwasher detergent is a favorite). Rinse; you should now actually hear the float rattling in there as you shake or turn the tank. Reinstall, pour the coolant back in (thus the "clean vessel"). Light should go off.

REWARD EXCELLENCE!

Add to madpogue's Reputation
Rate the quality of this post and help madpogue reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
madpogue is offline   Reply With Quote
Old 09-12-2009, 09:17 PM   #4
PurdueGuy
Master Member
PurdueGuy is a jewel in the roughPurdueGuy is a jewel in the roughPurdueGuy is a jewel in the rough
 
PurdueGuy's Avatar
 
Join Date: Feb 2005
Location: Blackfoot, ID
Posts: 6,483

1999 SC2
1999 SC1
Default Re: 99 SC2 Speedometer not working

Quote:
Originally Posted by beermonkey View Post
the speedo isnt werking because theres a gear in there thats lost a tooth and needs to be replaced. search for SPEEDOMETER GEAR and theres a thread on it. i had to replace mine, wasnt too hard but its annoying.
You are confusing the odometer and the speedometer, though a '99 has a digital odometer, so it doesn't have a gear there either.

...
SaturnSeries.net owner

REWARD EXCELLENCE!

Add to PurdueGuy's Reputation
Rate the quality of this post and help PurdueGuy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
PurdueGuy is offline   Reply With Quote
Old 09-13-2009, 12:25 AM   #5
edgillen
New Member
edgillen is on a distinguished road
 
Join Date: Nov 2008
Location: Concord CA
Posts: 5

1999 SC2
Thumbs Up Re: 99 SC2 Speedometer not working

It is a manual....
I will try that tomorrow..
SEL on again, P0500, so it is probably the VSS or wiring


I suspect the later...my son crashed this car a month ago and dented the fender and frame near the fuse box knock a couple of the relays off (since replaced)..still waiting to see if the insurance is going to pay.

Although the car seems to run Ok...idle seems to be a bit uneven..1200 then down 800rpm at start up...my test drive on the freeway, felt loss of acceleration(and as I recall it did not tach over 4000)

REWARD EXCELLENCE!

Add to edgillen's Reputation
Rate the quality of this post and help edgillen reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
edgillen is offline   Reply With Quote
Old 09-13-2009, 10:21 AM   #6
edgillen
New Member
edgillen is on a distinguished road
 
Join Date: Nov 2008
Location: Concord CA
Posts: 5

1999 SC2
Default Re: 99 SC2 Speedometer not working

Cleaned the radiator reserivoir.....Then decided to check all the fuses...B/U fuse was bad, turns out this is also the fuse for the coolant temp switch..This problem solved

Took the test drive as suggested...When coasting, clutch in, the engine will not rev over 4200RPM>..time to find the VSS

REWARD EXCELLENCE!

Add to edgillen's Reputation
Rate the quality of this post and help edgillen reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
edgillen is offline   Reply With Quote
Old 09-13-2009, 01:33 PM   #7
edgillen
New Member
edgillen is on a distinguished road
 
Join Date: Nov 2008
Location: Concord CA
Posts: 5

1999 SC2
Default Re: 99 SC2 Speedometer not working

Bad wiring due to accident -- should have check this first...spliced 4 wires..seems to be fine...speedo working

REWARD EXCELLENCE!

Add to edgillen's Reputation
Rate the quality of this post and help edgillen reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
edgillen is offline   Reply With Quote
Old 09-14-2009, 10:24 AM   #8
madpogue
Super Member
madpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud of
 
Join Date: Sep 2004
Location: Madison, WI USA
Posts: 25,713
 

1996 SW2
Default Re: 99 SC2 Speedometer not working

Dented the fender?

REWARD EXCELLENCE!

Add to madpogue's Reputation
Rate the quality of this post and help madpogue reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
madpogue is offline   Reply With Quote
Old 09-15-2009, 07:10 PM   #9
edgillen
New Member
edgillen is on a distinguished road
 
Join Date: Nov 2008
Location: Concord CA
Posts: 5

1999 SC2
Default Re: 99 SC2 Speedometer not working

Ok Dent maybe have been the incorrect word, more like turned into chunks of plastic(fiberglass?)

REWARD EXCELLENCE!

Add to edgillen's Reputation
Rate the quality of this post and help edgillen reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
edgillen is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer Not working Need Help jcardzcollects S-Series Tech 3 05-04-2008 10:16 AM
1994 sc2 speedometer/ instrument panel not working jedw63 S-Series General 7 10-18-2007 07:32 AM
speedometer not working danabanana Vue Tech 2 04-25-2007 04:57 PM
SC2 Speedometer and Tachometer not working after near crash. Fox S-Series General 3 07-03-2006 09:33 PM
Speedometer... not working wrightco S-Series Tech 5 12-30-2002 08:06 AM


All times are GMT -5. The time now is 10:42 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.