SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Vue > Vue Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 12-10-2008, 05:35 PM   #1
Killa_G
New Member
Killa_G is on a distinguished road
 
Join Date: Dec 2008
Posts: 4
Default Bad rings-Possibly?

I have an 02 vue with about 117k miles on it. The past week I have noticed that the car has no power at higher RPM's and it smokes alot at high RPM's. On the way home from school today I stopped at a stop sign, accelerated, and the car immediatley lost power. The check engine light flashed. I turned into my friends driveway and we took a look at it. The oil was about halfway empty. When I rev the engine up grayish colored smoke comes out.

I am thinking its the piston rings. Does anyone know how much this costs at the dealership?

Our dealership down here is so crappy I'm not sure I would even trust them to do the job (especially of this magnitude). I took the car to them once just to see why the CEL light was coming on and they left two oxygen sensors un-plugged.

If anyone else has any other ideas let me know. I would also like to know the price that comes with replacing the rings from the dealership if anyone knows it.

Thanks!

Last edited by Killa_G; 12-10-2008 at 05:44 PM..

REWARD EXCELLENCE!

Add to Killa_G's Reputation
Rate the quality of this post and help Killa_G reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Killa_G is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 12-10-2008, 05:47 PM   #2
Tom92SCm
Master Member
Tom92SCm has a spectacular aura aboutTom92SCm has a spectacular aura about
 
Tom92SCm's Avatar
 
Join Date: Sep 2003
Location: Colorado
Posts: 4,960
 

2004 VUE 2.2L
Default Re: Bad rings-Possibly?

What's your coolant look like?

...
Not a Saturn.

REWARD EXCELLENCE!

Add to Tom92SCm's Reputation
Rate the quality of this post and help Tom92SCm reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Tom92SCm is offline   Reply With Quote
Old 12-10-2008, 05:51 PM   #3
Killa_G
New Member
Killa_G is on a distinguished road
 
Join Date: Dec 2008
Posts: 4
Default Re: Bad rings-Possibly?

The coolant level is fine. If its the slightest bit low it will trip off the sensor and I would know about it. Plus I checked it today at my friends.

And the oil isnt milky either.

REWARD EXCELLENCE!

Add to Killa_G's Reputation
Rate the quality of this post and help Killa_G reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Killa_G is offline   Reply With Quote
Old 12-10-2008, 08:33 PM   #4
1saxman
Master Member
1saxman is on a distinguished road
 
Join Date: Nov 2002
Posts: 2,285

2003 VUE 3.0L
Default Re: Bad rings-Possibly?

6 or 4? It may be in the head, not rings. Possible bad oil seals. The V6 has an oil cooler under the intake manifold and some kind of 'vacuum chamber' - sounds like a match made in hell to me.

REWARD EXCELLENCE!

Add to 1saxman's Reputation
Rate the quality of this post and help 1saxman reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
1saxman is offline   Reply With Quote
Old 12-10-2008, 10:29 PM   #5
Killa_G
New Member
Killa_G is on a distinguished road
 
Join Date: Dec 2008
Posts: 4
Default Re: Bad rings-Possibly?

Its the V6.

I'm going to take it in to the dealer tomorrow and figure out what the deal is.

Its getting sold after it gets fixed-mayby before if its rings. Last week it was the Crank position sensor. Leaving me stranded at neumerous shoplights/signs randomly, extremely frustrating. Especially from a sensor that is not needed in the first place.

REWARD EXCELLENCE!

Add to Killa_G's Reputation
Rate the quality of this post and help Killa_G reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Killa_G is offline   Reply With Quote
Old 12-10-2008, 11:26 PM   #6
1saxman
Master Member
1saxman is on a distinguished road
 
Join Date: Nov 2002
Posts: 2,285

2003 VUE 3.0L
Default Re: Bad rings-Possibly?

They can rule out bad rings with a compression test. Based on what others have posted about dealer service on major engine problems with the L81, the most likely response will be to replace the engine. In that case you can put a used one in or find somebody to work on yours. Sometimes it's no more expensive and usually quicker to put another engine in.

REWARD EXCELLENCE!

Add to 1saxman's Reputation
Rate the quality of this post and help 1saxman reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
1saxman is offline   Reply With Quote
Old 12-11-2008, 01:37 PM   #7
Killa_G
New Member
Killa_G is on a distinguished road
 
Join Date: Dec 2008
Posts: 4
Default Re: Bad rings-Possibly?

And yet another bad thing is that I dont even know where the hell the spark plugs are on this thing. I think they are under the IM and from what I have heard they are no fun to get to. Which rules out me even being halfway able to give the car a compression test myself.

If the vue requires a new engine I believe I will call it all done.

The car has been falling apart. It currently needs a paint job, new struts all around, and now, a new engine.

REWARD EXCELLENCE!

Add to Killa_G's Reputation
Rate the quality of this post and help Killa_G reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Killa_G is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
02 Saturn SL1 - Bad Rings ?? Cassie S-Series Tech 10 08-12-2009 12:49 PM
Possibly bad (new) battery??? lc23112 L-Series Tech 14 12-06-2007 11:25 AM
96' SL2 148K in frame rebuild 'rings bad' 2strkBlu S-Series Tech 73 09-01-2007 08:28 AM
This is possibly a first... DeCaff2006 S-Series General 4 06-27-2006 06:02 AM
Bad rings or Cylinder head? BuzzStPoint S-Series Tech 7 01-21-2005 03:01 PM


All times are GMT -5. The time now is 09:52 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.