SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 05-14-2008, 03:27 PM   #1
26point2
New Member
26point2 is on a distinguished road
 
Join Date: Jul 2007
Posts: 8
Default Sluggish, No Power & Hard Idle (Changed ECTS & Plugs) Help Please!!!

98 SLI 250,000 miles, standard Tranny

Two days ago I started loosing power when driving and the car was almost sputtering. It is also idling lower than normal at around 500 RPMs but very hard and sporadically like it wants to quit and engine is shaking. I need to give it gas at a stop sign to keep the idle up. From there it is slow to get up to speed and very sluggish.

Today I changed the ECTS, put in new plugs and plug wires and I still have the same problem. Car was running perfectly before. Any help

REWARD EXCELLENCE!

Add to 26point2's Reputation
Rate the quality of this post and help 26point2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
26point2 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 05-14-2008, 06:34 PM   #2
Signmaster
Master Member
Signmaster is a name known to allSignmaster is a name known to allSignmaster is a name known to allSignmaster is a name known to allSignmaster is a name known to allSignmaster is a name known to all
 
Join Date: Jan 2007
Location: Virginia Beach, VA
Posts: 5,054
 

1995 SL1
Default Re: Sluggish, No Power & Hard Idle (Changed ECTS & Plugs) Help Please!!!

Any codes?

I'd look for codes and work from there, but with that many miles there could be all types of things contributing. If you don't have any codes I'd check the obvious things you already did, and probably move to a compression test from there.

REWARD EXCELLENCE!

Add to Signmaster's Reputation
Rate the quality of this post and help Signmaster reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Signmaster is offline   Reply With Quote
Old 05-14-2008, 09:16 PM   #3
fdryer
Super Member
fdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant future
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 30,113
 

2003 L-Series 3.0L Sedan
Default Re: Sluggish, No Power & Hard Idle (Changed ECTS & Plugs) Help Please!!!

Plugged converter. Go to a muffler shop for a test or remove the O2 sensor for another exit hole; if the engine power returns replace the converter.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 05-15-2008, 12:44 PM   #4
26point2
New Member
26point2 is on a distinguished road
 
Join Date: Jul 2007
Posts: 8
Default Re: Sluggish, No Power & Hard Idle (Changed ECTS & Plugs) Help Please!!!

Thanks for the info. I was thinking it may be the converter. Was not sure how to get it tested. I will check with a local muffler shop and see if that may be the culprit.

Also, I drove it last night to try and see what was happening and SES would flash when I attempted to climb a hill, if this helps with the diagnosis.

REWARD EXCELLENCE!

Add to 26point2's Reputation
Rate the quality of this post and help 26point2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
26point2 is offline   Reply With Quote
Old 05-15-2008, 01:09 PM   #5
rickp
New Member
rickp is on a distinguished road
 
Join Date: Jul 2007
Posts: 2
Default Re: Sluggish, No Power & Hard Idle (Changed ECTS & Plugs) Help Please!!!

With past other vehicles that I have owned, I would have to replace the fuel filter as it was dirty and not supplying enough fuel/pressure. If the exhaust system is okay and you have not replaced the filter lately, might be worth a try.

Rick

REWARD EXCELLENCE!

Add to rickp's Reputation
Rate the quality of this post and help rickp reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
rickp is offline   Reply With Quote
Old 05-15-2008, 01:21 PM   #6
madpogue
Super Member
madpogue is a splendid one to beholdmadpogue is a splendid one to beholdmadpogue is a splendid one to beholdmadpogue is a splendid one to beholdmadpogue is a splendid one to beholdmadpogue is a splendid one to beholdmadpogue is a splendid one to behold
 
Join Date: Sep 2004
Location: Madison, WI USA
Posts: 25,450
 

1996 SW2
Default Re: Sluggish, No Power & Hard Idle (Changed ECTS & Plugs) Help Please!!!

Quick-and-dirty (and very loud and ugly) test for a clogged converter -- REMOVE (don't just disconnect, but REMOVE the front O2 sensor, and take it for a SHORT test drive. It'll be VERY loud. This is a sort of "emergency tracheotomy", which allows the engine to breathe out exhaust through the bung hole. If this improves performance, it means that you're literally doing most of the exhaust out through that hole, which means the main exhaust, most likely the catalytic, is severly restricted.

A blinking SES light means a general misfire that could be damaging the emissions control systems (usually the catalytic). So if the cat is plugged, that may be a symptom of some other running problem that, if not addressed, could just clog up a new converter.

REWARD EXCELLENCE!

Add to madpogue's Reputation
Rate the quality of this post and help madpogue reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
madpogue is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I just changed my Platinums for Coppers & MPG StevieC S-Series Tech 7 05-03-2009 09:58 AM
Changed Plugs and Wires now rough idle stinka S-Series Tech 8 08-17-2006 07:48 AM
'95 SL1 Auto & A/C - Runs rough & stalls at idle & low rpm's BusyGuy S-Series General 3 03-18-2006 09:58 PM
Non-Normal Temps & Sluggish Perf cozkramer S-Series Tech 21 06-04-2004 07:51 AM
02 Changed & Results Luke S-Series Tech 13 08-14-2002 09:04 PM


All times are GMT -5. The time now is 05:54 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.