SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 03-11-2008, 10:48 AM   #1
Kenk
Junior Member
Kenk is on a distinguished road
 
Join Date: Mar 2008
Location: Vestal, NY
Posts: 17

2000 L-Series 2.2L Sedan
2000
Default Turn Signal Problem on 2000 LS1

Hi All,
I am new to this forum, and a new Saturn owner. My sister just gave me her 2000 LS1. When I got in and started driving it, I noticed the turn signals didn't always come on. She said that happens from time to time, nothing major. Since I purchased this from out of state, I need to get it inspected, and don't need any surprises at the inspection. I saw there was a recall on a similar problem, and called Saturn directly. They said my car was not part of the recall. I noticed in some of the other posts that people mentioned the relay that would fix it. What is the relay number for this car, and where is it located. I would like to try that first, before I get into having to get the wiring harness changed. Any help/suggestions would be greatly appreciate. Thanks for this wonderful exchange of information.

Ken

REWARD EXCELLENCE!

Add to Kenk's Reputation
Rate the quality of this post and help Kenk reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Kenk is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 03-11-2008, 10:54 AM   #2
CrewCab
Advanced Member
CrewCab will become famous soon enough
 
CrewCab's Avatar
 
Join Date: Apr 2007
Posts: 623
 

2008 AURA XE
1996 SL2
Default Re: Turn Signal Problem on 2000 LS1

The hazzard button is the relay/flasher assembly, too. Just replace the hazzard button and you will be all set.

REWARD EXCELLENCE!

Add to CrewCab's Reputation
Rate the quality of this post and help CrewCab reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
CrewCab is offline   Reply With Quote
Old 03-11-2008, 11:00 AM   #3
Kenk
Junior Member
Kenk is on a distinguished road
 
Join Date: Mar 2008
Location: Vestal, NY
Posts: 17

2000 L-Series 2.2L Sedan
2000
Default Re: Turn Signal Problem on 2000 LS1

CrewCab,
Thanks for the quick response. How easy/difficult is it to replace this? Is this something I can get at a autoparts store, or do I have to get it directly from Saturn ? Thanks again.

Ken

REWARD EXCELLENCE!

Add to Kenk's Reputation
Rate the quality of this post and help Kenk reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Kenk is offline   Reply With Quote
Old 03-11-2008, 11:12 AM   #4
CrewCab
Advanced Member
CrewCab will become famous soon enough
 
CrewCab's Avatar
 
Join Date: Apr 2007
Posts: 623
 

2008 AURA XE
1996 SL2
Default Re: Turn Signal Problem on 2000 LS1

Quote:
Originally Posted by Kenk View Post
CrewCab,
Thanks for the quick response. How easy/difficult is it to replace this? Is this something I can get at a autoparts store, or do I have to get it directly from Saturn ? Thanks again.

Ken
It is real simple to replace. I'll send you directions soon. I'm thinking you can only get it from a dealer. Call a local parts store and see. Not every part is cheaper in the aftermarket.

The # is 22707123 http://saturnparts.net/ sells it for $17.

REWARD EXCELLENCE!

Add to CrewCab's Reputation
Rate the quality of this post and help CrewCab reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
CrewCab is offline   Reply With Quote
Old 03-11-2008, 11:30 AM   #5
CrewCab
Advanced Member
CrewCab will become famous soon enough
 
CrewCab's Avatar
 
Join Date: Apr 2007
Posts: 623
 

2008 AURA XE
1996 SL2
Default Re: Turn Signal Problem on 2000 LS1

You will need to remove the center trim panel. Just grab the panel and pull towards you. It comes off easily.
Flip it over and unhook the electrical connectors. Label them if necessary.
On the side of the hazzard switch (looking at it from the back) there are 2 clips. Unhook them and slide the switch out the front.
Slide in the new switch from the front.
Reconnect and switches that were unhooked.
Reinstall the center panel.

REWARD EXCELLENCE!

Add to CrewCab's Reputation
Rate the quality of this post and help CrewCab reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
CrewCab is offline   Reply With Quote
Old 03-11-2008, 12:24 PM   #6
Kenk
Junior Member
Kenk is on a distinguished road
 
Join Date: Mar 2008
Location: Vestal, NY
Posts: 17

2000 L-Series 2.2L Sedan
2000
Default Re: Turn Signal Problem on 2000 LS1

CrewCab,
Thank your very much. I called our local Saturn dealer, and just picked up the part. $20 + tax, not much different, and I have it in hand. Hopefully tonight I will install it, and let you know in the morning how things went. I appreciate all your help.
I do have another unrelated ?? question. Last night when I went to get into the car, it was dark. I checked the dome light switch, and it was off. When I moved it to door, it stayed on, and never turned off.
Not sure if this is a switch issue, or if there may be something else going on. This isn't a real big deal, but with small kids, it can be a problem..
Thanks again.

Ken

REWARD EXCELLENCE!

Add to Kenk's Reputation
Rate the quality of this post and help Kenk reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Kenk is offline   Reply With Quote
Old 03-12-2008, 07:11 AM   #7
Kenk
Junior Member
Kenk is on a distinguished road
 
Join Date: Mar 2008
Location: Vestal, NY
Posts: 17

2000 L-Series 2.2L Sedan
2000
Default Re: Turn Signal Problem on 2000 LS1

CrewCab,
That fixed the problem. As you said it took 2 minutes to pull off the front, and replace the part. Turn signals now working fine, and an added bonus. The dome light is now working properly. Somehow they must be connected. I would have never guess that, but am glad to have both problems fixed at mininmal cost. If you are ever in the Binghamton, NY area, a cold one is waiting for you. Thanks again.

Ken

REWARD EXCELLENCE!

Add to Kenk's Reputation
Rate the quality of this post and help Kenk reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Kenk is offline   Reply With Quote
Old 03-12-2008, 02:34 PM   #8
CrewCab
Advanced Member
CrewCab will become famous soon enough
 
CrewCab's Avatar
 
Join Date: Apr 2007
Posts: 623
 

2008 AURA XE
1996 SL2
Default Re: Turn Signal Problem on 2000 LS1

Your welcome.
If you need help with anything else, let me know.

REWARD EXCELLENCE!

Add to CrewCab's Reputation
Rate the quality of this post and help CrewCab reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
CrewCab is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signal Problem mikey109ca S-Series Tech 1 01-06-2010 07:08 PM
Intermittent turn signal problem Robor007 Astra General 1 03-27-2009 09:19 AM
Turn signal problem-PLEASE HELP!! mac99sl2 S-Series Tech 3 02-19-2008 09:31 PM
Turn signal Problem wolly6973 S-Series Tech 6 05-11-2007 11:14 AM
replace turn/multifunction switch 2000 ls1 JoeB L-Series Tech 4 01-24-2007 10:32 PM


All times are GMT -5. The time now is 08:20 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.