SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 06-27-2007, 04:19 PM   #1
gfreek1
Member
gfreek1 is on a distinguished road
 
Join Date: Feb 2006
Location: Sabres Country
Posts: 59
Default Cruise Control not working

02 SL2, switch lite on steering wheel is on, but no cruise. checked all fuses and they are good. Last time this happened, when I bought the car, they replaced the brake pedal switch. Could it be this again and is there a test to be sure that's whats wrong ?

REWARD EXCELLENCE!

Add to gfreek1's Reputation
Rate the quality of this post and help gfreek1 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
gfreek1 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 06-27-2007, 05:55 PM   #2
madpogue
Super Member
madpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud of
 
Join Date: Sep 2004
Location: Madison, WI USA
Posts: 25,713
 

1996 SW2
Default Re: Cruise Control not working

Usually, if it's the brake pedal switch that's failed, it's failed "closed", so the brake lights will be on all the time. Are they?

REWARD EXCELLENCE!

Add to madpogue's Reputation
Rate the quality of this post and help madpogue reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
madpogue is offline   Reply With Quote
Old 06-27-2007, 08:50 PM   #3
gfreek1
Member
gfreek1 is on a distinguished road
 
Join Date: Feb 2006
Location: Sabres Country
Posts: 59
Default Re: Cruise Control not working

No they are not on all the time.

REWARD EXCELLENCE!

Add to gfreek1's Reputation
Rate the quality of this post and help gfreek1 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
gfreek1 is offline   Reply With Quote
Old 06-28-2007, 05:43 AM   #4
BarnOwl
Super Member
BarnOwl is just really niceBarnOwl is just really niceBarnOwl is just really niceBarnOwl is just really nice
 
BarnOwl's Avatar
 
Join Date: May 2005
Location: Hickory, NC
Posts: 10,025
 

2000 SW2
1998 SL2
Default Re: Cruise Control not working

I would say that if the brake lights work right then it's not the brake light switch. Are there any other driveability issues with the car? Is the SES light on? The reason I'm asking is that I don't believe the cruise control will work if you aren't going into closed loop.

...
There is nothing more frightening than ignorance in action.

REWARD EXCELLENCE!

Add to BarnOwl's Reputation
Rate the quality of this post and help BarnOwl reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
BarnOwl is offline   Reply With Quote
Old 06-28-2007, 11:34 AM   #5
gfreek1
Member
gfreek1 is on a distinguished road
 
Join Date: Feb 2006
Location: Sabres Country
Posts: 59
Default Re: Cruise Control not working

After driving for awhile the service wrench & security lite comes on. Check engine lite not on. They are off after restart. My son took it to a dealer in Michigan, they had no answers. Don't get me started on that ...... Can you explain to me what you mean by "closed loop"

REWARD EXCELLENCE!

Add to gfreek1's Reputation
Rate the quality of this post and help gfreek1 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
gfreek1 is offline   Reply With Quote
Old 06-28-2007, 09:38 PM   #6
ssicarman
Super Member
ssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to behold
 
ssicarman's Avatar
 
Join Date: Oct 2000
Location: Western Canada
Posts: 10,366
 
Default Re: Cruise Control not working

When driving try carefully pulling up on the brake pedal (with your foot) while trying to set the cruise. If it now works adjust the brake pedal switch.

...
A lousy day in paradise is still a day in paradise.

REWARD EXCELLENCE!

Add to ssicarman's Reputation
Rate the quality of this post and help ssicarman reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ssicarman is offline   Reply With Quote
Old 06-29-2007, 10:55 AM   #7
gfreek1
Member
gfreek1 is on a distinguished road
 
Join Date: Feb 2006
Location: Sabres Country
Posts: 59
Default Re: Cruise Control not working

ssicarman, I tried pulling up on the pedal, cruise still did not work, Any other ideas??

REWARD EXCELLENCE!

Add to gfreek1's Reputation
Rate the quality of this post and help gfreek1 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
gfreek1 is offline   Reply With Quote
Old 06-29-2007, 11:07 AM   #8
hit_n_run
Senior Member
hit_n_run is on a distinguished road
 
Join Date: Jan 2007
Location: Northeast PA
Posts: 1,016
 
Default Re: Cruise Control not working

My vote is the BCM. I'm having similar issues with the cruise control on my 93 SC2 auto. Sometimes CC works, sometimes it doesn't. Sometimes it will work, then stop working after a very short period of time.

As for the brake pedal switch, how does one adjust that if that is my problem?

REWARD EXCELLENCE!

Add to hit_n_run's Reputation
Rate the quality of this post and help hit_n_run reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
hit_n_run is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cruise control not working xraytec1 Ion General 12 05-28-2015 09:54 AM
Cruise control no longer working SL1Guy S-Series Tech 3 10-01-2009 07:21 PM
Cruise control, A/C not working Scout238 S-Series Tech 8 08-20-2008 10:42 PM
Cruise control upgrade - now AC is not working kodok S-Series Tech 7 07-18-2006 08:22 AM
Cruise Control Is Working!!! BarnOwl S-Series Tech 2 11-10-2005 10:43 AM


All times are GMT -5. The time now is 04:03 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.