SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 11-17-2011, 10:58 PM   #1
mtbdsavage
New Member
mtbdsavage is on a distinguished road
 
Join Date: Apr 2010
Location: Murfreesboro, TN
Posts: 7

2001 SL1
Default high idle 2001 SL1

Got a pretty high idle sometimes on my 01 SL1...been lookin through my manual and seems like the culprits are the TPS, IAC, or maybe the computer itself. It comes and goes but seems to be getting more and more common. If you let it just sit there and run it will idle back down to normal after 8-10 seconds. Anybody got any thoughts?
mtbdsavage is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 11-18-2011, 08:44 AM   #2
hoseppi
Advanced Member
hoseppi will become famous soon enough
 
hoseppi's Avatar
 
Join Date: Oct 2009
Location: Bowie, Md.
Posts: 608

2002 SL1
2008 Astra XE
Default Re: high idle 2001 SL1

I believe you probably already know the most likely culprit is the TPS. Seems I saw this post on another site.
hoseppi is offline   Reply With Quote
Old 11-18-2011, 09:31 AM   #3
velleguy73
Senior Member
velleguy73 is on a distinguished road
 
Join Date: Oct 2008
Location: Farmington MI
Posts: 1,208
 

2001 SL
2002 SL
Default

Quote:
Originally Posted by hoseppi View Post
I believe you probably already know the most likely culprit is the TPS. Seems I saw this post on another site.
Find the procedure for the intake manifold gasket leak 1st, clean the throttle body 2nd, then look at tps. To you have a stock coolant temp sensor still? If not, replace it.
velleguy73 is offline   Reply With Quote
Old 11-18-2011, 10:25 PM   #4
mtbdsavage
New Member
mtbdsavage is on a distinguished road
 
Join Date: Apr 2010
Location: Murfreesboro, TN
Posts: 7

2001 SL1
Default Re: high idle 2001 SL1

I had previously replaced the ECTS last year with a brass one. Ran into a buddy of mine today that works on cars. Said to just disconnect the IAC and see what happens. Disconnected it and it idles perfectly. Also cleaned the throttle body for the heck of it. It was pretty dirty. But here's what's got me really confused. Ran a compression check just to see what I had. It has 185,000 on it and the readings are from 1-4...55, 90, 120, 155....but it runs fine with no loss of power...it's crazy. Seems to be just as much power today as it was the day i bought it with 126,000. Poured a little tranny fluid in the cylinders and they each came up 30-40 lbs. each. Shouldn't it be low on power those readings?
mtbdsavage is offline   Reply With Quote
Old 11-18-2011, 10:39 PM   #5
td1238
Master Member
td1238 will become famous soon enoughtd1238 will become famous soon enough
 
Join Date: Mar 2010
Location: Milwaukee
Posts: 2,169

1999 SL2
Default Re: high idle 2001 SL1

While all of those other parts mentioned could be faulty, and your compression is a bit low, if those are in fact correct compression numbers, if you can turn your ignition switch off and back on really quickly, and the idle falls back to a normal speed, then your TPS is almost certainly the problem. When the TPS becomes worn, and the wiper is wiping over worn parts of resistance material, contact is poor, and so when the throttle is closed, resistance, and subsequent voltage, doesn't always return to the value originally seen when the engine was first turned on. Since it must fall back to that original value for the computer to think that the throttle is in its closed position, the computer thinks that the throttle is still open.
td1238 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 SL1 High idle - cant get ECTS clip off eriklane S-Series General 16 01-10-2010 05:00 PM
High idle problems 2001 SL1 thevaledic S-Series Tech 5 05-08-2009 04:37 PM
2001 SL1 high idle after cleaning Throttle Body rickystarshine S-Series Tech 6 11-19-2006 09:33 AM
2001 SC2 High Idle and Stall Problems 440sixPack S-Series Tech 0 03-20-2006 12:19 PM
2001 sc2 w/ a high idle Mean Green SC2 General Saturn Discussion 0 10-27-2004 10:56 PM


All times are GMT -4. The time now is 08:24 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.