SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 01-05-2006, 07:07 PM   #1
gypsy35
Junior Member
gypsy35 is on a distinguished road
 
Join Date: Sep 2005
Location: louisiana
Posts: 22

2000 SL1
Default i found out want was the lack of power problem and shifting problem

well i didn't relize that when i used the generic dex 3 transmission oil that my car would react this way, well it ran slow on take off, had a little trouble shifting too, well i change my tran-oil again and used dex 3 castrol tran oil and guess want its running like a new car. i hope this helps other people too, i was thinking all kinds of things were wrong with my car.

REWARD EXCELLENCE!

Add to gypsy35's Reputation
Rate the quality of this post and help gypsy35 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
gypsy35 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 01-05-2006, 07:30 PM   #2
peppermrj
Advanced Member
peppermrj is on a distinguished road
 
peppermrj's Avatar
 
Join Date: Feb 2005
Location: Pgh. Pa,
Posts: 906
 

1996 SC2
Default Re: i found out want was the lack of power problem and shifting problem

Hmmmm! Very interesting.

REWARD EXCELLENCE!

Add to peppermrj's Reputation
Rate the quality of this post and help peppermrj reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
peppermrj is offline   Reply With Quote
Old 01-05-2006, 09:15 PM   #3
dcp
Advanced Member
dcp is on a distinguished road
 
dcp's Avatar
 
Join Date: Jul 2002
Location: MO.
Posts: 601

1998 SL2
Default Re: i found out want was the lack of power problem and shifting problem

Thanks for letting us know!

REWARD EXCELLENCE!

Add to dcp's Reputation
Rate the quality of this post and help dcp reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
dcp is offline   Reply With Quote
Old 01-05-2006, 11:05 PM   #4
wolfman
Super Member
wolfman is a glorious beacon of lightwolfman is a glorious beacon of lightwolfman is a glorious beacon of lightwolfman is a glorious beacon of lightwolfman is a glorious beacon of lightwolfman is a glorious beacon of light
 
wolfman's Avatar
 
Join Date: Jun 2002
Location: Texas
Posts: 12,066
 
Default Re: i found out want was the lack of power problem and shifting problem

Mobil 1 synthetic ATF....there is no substitute.

...
Old Saturns never die, people KILL them, so check your damn oil!
"Unthinking respect for authority is the greatest enemy of truth." Albert Einstein

REWARD EXCELLENCE!

Add to wolfman's Reputation
Rate the quality of this post and help wolfman reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
wolfman is offline   Reply With Quote
Old 01-06-2006, 08:49 AM   #5
alfieferenzo84
Member
alfieferenzo84 is on a distinguished road
 
Join Date: Oct 2004
Location: North Ridgeville, Ohio
Posts: 287
 

1998 SL2
2004 ION-1 Sedan
Default Re: i found out want was the lack of power problem and shifting problem

Yes mobil 1 i have cheap stuff in there now to just verify no leaks and to clean it and ect just for a week, and i know there is a huge difference in everything its really strange how you can notice that much just with different fuild!!! i will be changing to mobil one asp just wanted to make sure everything was okay before i put 20 bucks worth of fuild in there!!!

REWARD EXCELLENCE!

Add to alfieferenzo84's Reputation
Rate the quality of this post and help alfieferenzo84 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
alfieferenzo84 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Found problem in my 97sc2 A/C saturncrzy S-Series Tech 5 05-07-2009 12:41 PM
found out the problem... or did i? 1994_SC2 S-Series Tech 8 04-11-2007 03:46 AM
I found out the problem w/ my SL2 Nickdfresh S-Series Tech 2 09-07-2006 05:03 PM
lack of power problem and sputtering gypsy35 S-Series General 20 09-21-2005 10:56 PM
Well I found my problem! rkuris S-Series Tech 5 07-11-2005 11:02 AM


All times are GMT -4. The time now is 09:36 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.