SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 08-06-2012, 02:07 PM   #1
gruelens
Junior Member
gruelens has a spectacular aura aboutgruelens has a spectacular aura about
 
Join Date: Aug 2012
Posts: 20

1999 SL2
Default Transmission advice please

Hi,

I am new to this forum and am grateful to have found you. I first posted this in the "general" section, but was advised to move it here.

I have a '99 SL2 w/ 115,000 miles. About a month ago while in the shop, the mechanic said my transmission fluid was burnt and he changed it along with the filter. I had not noticed any problems other than occasionally a hard downshift from fourth to third when a lot of gas was applied on a hill.

Fast forward to yesterday. My SL2 now clunks a little bit occasionally when shifting. The RPM's are higher than normal for given road speed. Example: at highway speed cruising it is about 300-400 more RPM than before (like it is slipping.) I have not detected any issues yet in reverse.

I have read some info about faulty valve body and input shaft nut. Any opinions would be appreciated.

George in PA.

REWARD EXCELLENCE!

Add to gruelens's Reputation
Rate the quality of this post and help gruelens reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
gruelens is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 08-06-2012, 05:53 PM   #2
Chazberry
Master Member
Chazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to behold
 
Chazberry's Avatar
 
Join Date: Feb 2005
Posts: 7,103

1995 SW2
2003 VUE 3.0L
Default Re: Transmission advice please

Quote:
Originally Posted by gruelens View Post
I have a '99 SL2 w/ 115,000 miles. About a month ago while in the shop, the mechanic said my transmission fluid was burnt and he changed it along with the filter.
When was the fluid last changed before this?

Quote:
Originally Posted by gruelens View Post
Fast forward to yesterday. My SL2 now clunks a little bit occasionally when shifting. The RPM's are higher than normal for given road speed. Example: at highway speed cruising it is about 300-400 more RPM than before (like it is slipping.) I have not detected any issues yet in reverse.
No SES light or codes?

REWARD EXCELLENCE!

Add to Chazberry's Reputation
Rate the quality of this post and help Chazberry reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Chazberry is offline   Reply With Quote
Old 08-06-2012, 06:04 PM   #3
Woodpecker
Member
Woodpecker is on a distinguished road
 
Join Date: Aug 2005
Location: Houston, Tx
Posts: 230

2007 VUE 3.5L
Default Re: Transmission advice please

Just 300-400 rpms above normal at cruising speed has me suspect of the torque converter clutch (the clutch itself or the solenoid, or fuse, etc on that system).

REWARD EXCELLENCE!

Add to Woodpecker's Reputation
Rate the quality of this post and help Woodpecker reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Woodpecker is offline   Reply With Quote
Old 08-06-2012, 08:50 PM   #4
gruelens
Junior Member
gruelens has a spectacular aura aboutgruelens has a spectacular aura about
 
Join Date: Aug 2012
Posts: 20

1999 SL2
Default Re: Transmission advice please

In response to the two questions.

The previous transmission fluid had 50K miles on it. It was Amsoil synthetic, advertised to go 150K.

Yes my SES light is on. I do not have a code reader.

Thanks,
George

REWARD EXCELLENCE!

Add to gruelens's Reputation
Rate the quality of this post and help gruelens reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
gruelens is offline   Reply With Quote
Old 08-06-2012, 09:39 PM   #5
Chazberry
Master Member
Chazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to behold
 
Chazberry's Avatar
 
Join Date: Feb 2005
Posts: 7,103

1995 SW2
2003 VUE 3.0L
Default Re: Transmission advice please

Quote:
Originally Posted by gruelens View Post
Yes my SES light is on. I do not have a code reader.
Do you have an Autozone or some other FLAPS that can read your codes? They will provide some clues.

REWARD EXCELLENCE!

Add to Chazberry's Reputation
Rate the quality of this post and help Chazberry reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Chazberry is offline   Reply With Quote
Old 08-07-2012, 08:01 PM   #6
ssewall
Senior Member
ssewall is on a distinguished road
 
Join Date: Jun 2011
Location: Maine
Posts: 1,087

2002 SL2
Default Re: Transmission advice please

Quote:
occasionally a hard downshift from fourth to third when a lot of gas was applied on a hill.
Bad line pressure solenoid.

Testing and fixing the LP solenoid isn't too difficult. Here's the testing procedure:

http://www.youtube.com/watch?v=1tDmBlKn2jI

It's unlikely changing the fluid broke anything, unless he used the wrong fluid (it should be an aftermarket brand universal dexron III/mercon, not dexron VI).

REWARD EXCELLENCE!

Add to ssewall's Reputation
Rate the quality of this post and help ssewall reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ssewall is offline   Reply With Quote
Old 08-07-2012, 10:54 PM   #7
campus189
Member
campus189 is on a distinguished road
 
campus189's Avatar
 
Join Date: Jul 2010
Location: Kingsport Tennessee
Posts: 397

1997 SL1
1997 SL2
Default Re: Transmission advice please

Quote:
Originally Posted by ssewall View Post
Bad line pressure solenoid.

Testing and fixing the LP solenoid isn't too difficult. Here's the testing procedure:

http://www.youtube.com/watch?v=1tDmBlKn2jI

It's unlikely changing the fluid broke anything, unless he used the wrong fluid (it should be an aftermarket brand universal dexron III/mercon, not dexron VI).
If your going to be checking the solenoid, then check connector on top of transmission while your at it.
Heres the video.

...
1997 Saturn SL2 144,000 Miles
1997 Saturn SL1 254,000 Miles
1997 Saturn SL1 157,000 Miles
1996 Saturn SL1 97,000 Miles

Also known as FiremanCV on YouTube

REWARD EXCELLENCE!

Add to campus189's Reputation
Rate the quality of this post and help campus189 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
campus189 is offline   Reply With Quote
Old 08-23-2012, 02:55 PM   #8
gruelens
Junior Member
gruelens has a spectacular aura aboutgruelens has a spectacular aura about
 
Join Date: Aug 2012
Posts: 20

1999 SL2
Default Re: Transmission advice please

Thanks to all forum members for your help and advice. Here is the final info, hopefully someone can learn from this.

My codes were :
PO732 incorrect gear ratio
PO741 torque converter clutch stuck off
PO764 shift solenoid intermittent
PO782 2-3 shift problem

I purchased a rebuilt transmission valve body from ebay seller "dink2954". I spoke with him twice on the phone and he was very helpful.

Installing the rebuilt valve body (also changed trans fluid and filter) fixed up my car's transmission and all is working well now.

George in PA.
============================

Quote:
Originally Posted by Chazberry View Post
Do you have an Autozone or some other FLAPS that can read your codes? They will provide some clues.

REWARD EXCELLENCE!

Add to gruelens's Reputation
Rate the quality of this post and help gruelens reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
gruelens is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SC2 transmission advice Skipp S-Series Tech 5 05-06-2011 01:54 AM
Transmission Advice Tubagod767 Ion Tech 29 04-11-2010 09:00 AM
Transmission Advice Please kobe4404 S-Series General 6 02-19-2010 10:28 AM
Transmission Advice antheab S-Series General 11 06-20-2004 06:23 PM
VTI transmission stranded us, need advice mattb Vue General 18 08-18-2003 01:25 AM


All times are GMT -4. The time now is 05:02 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.