SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 11-11-2008, 10:50 PM   #1
RyboCollier
New Member
RyboCollier is on a distinguished road
 
Join Date: Nov 2008
Posts: 8
Default 1998 Saturn SL1 Idle Issues

Hello all,

I'm sure this has been a thread that has been posted quite a few times as this seems to be an issue with a lot of Saturn owners. I'm having difficulty finding out what the problem is with my car. When I start my car it idles fine, but when I start driving(sometimes without even shifting gears) the car will idle at 1500-2000k. The problem does fix itself sometimes but it always seems to rear its ugly head again. Now, I have replaced two parts on my car. My memory is kind of bad but I know I have replaced the IAC Valve, and the ECTS? I'm not to sure about the 2nd one, but both from what I've been told can cause the car to idle iregularly. Now, im being hopeful and thinking that the IAC valve that I replaced may be faulty and a solution to this problem would be a quick replacement of the part. Im wanting to know if there is anything else that I should look out for? The throttle body has been cleaned as well as I understand that could cause problems too. Im open for any insight to this problem, thanks!

REWARD EXCELLENCE!

Add to RyboCollier's Reputation
Rate the quality of this post and help RyboCollier reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
RyboCollier is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 11-11-2008, 11:03 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 43,625
 

2003 L-Series 3.0L Sedan
Default Re: 1998 Saturn SL1 Idle Issues

The engine coolant temperature sensor wouldn't allow the engine to be erratic if its been replaced and the connector checked for corrosion. This may be a throttle position sensor issue; one hint is if the engine idles high and the engine is shut off immediately with a re-start with a normal idle, the tps is worn and needs to be replaced.

To be sure about whether the coolant sensor was replaced or not (it is a must) go to the bottom of this page and use the Forum Jump to look in the How-to library for the pictures of the old one next to the replacement brass one.

The iacv is reliable enough not to be any concern.

...
VCX NANO

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is online now   Reply With Quote
Old 11-12-2008, 07:47 PM   #3
RyboCollier
New Member
RyboCollier is on a distinguished road
 
Join Date: Nov 2008
Posts: 8
Default Re: 1998 Saturn SL1 Idle Issues

Thanks for your reply, I appreciate it. I forgot to mention that when I got the IAC replaced the car ran perfectly for about 4 weeks, then the problem came back..

REWARD EXCELLENCE!

Add to RyboCollier's Reputation
Rate the quality of this post and help RyboCollier reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
RyboCollier is offline   Reply With Quote
Old 11-12-2008, 07:49 PM   #4
RyboCollier
New Member
RyboCollier is on a distinguished road
 
Join Date: Nov 2008
Posts: 8
Default Re: 1998 Saturn SL1 Idle Issues

Oh, and I confirmed with your help I have had the ECTS Coolant Temp Sensor replaced.

REWARD EXCELLENCE!

Add to RyboCollier's Reputation
Rate the quality of this post and help RyboCollier reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
RyboCollier is offline   Reply With Quote
Old 11-12-2008, 08:26 PM   #5
RyboCollier
New Member
RyboCollier is on a distinguished road
 
Join Date: Nov 2008
Posts: 8
Default Re: 1998 Saturn SL1 Idle Issues

Well, I've purchased a TPS and I will be installing it tomorrow. Gotta love this forum I didnt know how to replace the TPS but I found that awesome video tutorial on how to do it.

Thanks guys! Lets hope this fixes the problem!

REWARD EXCELLENCE!

Add to RyboCollier's Reputation
Rate the quality of this post and help RyboCollier reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
RyboCollier is offline   Reply With Quote
Old 11-12-2008, 10:25 PM   #6
justinkennedy
Junior Member
justinkennedy is on a distinguished road
 
justinkennedy's Avatar
 
Join Date: May 2008
Location: Angus, Ontario
Posts: 48
 

2000 SC1
2005 ION-2 Sedan
Default Re: 1998 Saturn SL1 Idle Issues

I had the same problem a little while ago. TPS fixed it and along with a new PCV valve my car runs like new. Hope to hear from you when you put the TPS in.

REWARD EXCELLENCE!

Add to justinkennedy's Reputation
Rate the quality of this post and help justinkennedy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
justinkennedy is offline   Reply With Quote
Old 11-16-2008, 04:34 PM   #7
RyboCollier
New Member
RyboCollier is on a distinguished road
 
Join Date: Nov 2008
Posts: 8
Default Re: 1998 Saturn SL1 Idle Issues

Well, i'm happy to report that the TPS has seemed to fix the problem for now, lets hope it stays that way. Thanks a lot guys!

REWARD EXCELLENCE!

Add to RyboCollier's Reputation
Rate the quality of this post and help RyboCollier reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
RyboCollier is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
94 SL1 Idle issues Bagbyboy S-Series Tech 10 11-18-2009 12:32 PM
2002 SL1 idle issues. mike2002 S-Series Tech 3 06-23-2009 02:46 PM
1998 Saturn Sl1 (Rough Idle)(OBD2 codes 200-300) WadeNKC S-Series Tech 5 04-30-2009 12:56 PM
1998 SL1 Transmission Issues KingRex S-Series Tech 1 03-26-2009 05:48 PM
1998 SL1: Idle issues and flashing lights miss_smase S-Series Tech 2 06-11-2007 01:50 PM


All times are GMT -4. The time now is 06:57 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.