SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 08-26-2016, 11:58 PM   #1
Lahms
New Member
Lahms is on a distinguished road
 
Join Date: Jul 2016
Posts: 1
Default Vehicle lurches when reaches running temp

I got a 96 SL2 that I have been driving for 3 years now. Havent had any problems. Car is super reliable, 219k miles and still going strong... but, for a couple months now, the car jerks and lurches. But this only happens when I reach my normal running temp. It makes driving in town with a bunch of lights unbearable. Another symptom is the moment the car does its thing, I push on the clutch, the RPMs plummet to around 600-700 and sometimes even as low as 400. This is only for a brief second. The car idles just fine but accelerating is terrible. And during days when its hotter than 85 outside, its even worse. I dread driving home from work when its 100 outside. I do pop a p0404 code (EGR valve failure). I took the valve off the car, gave it a good cleaning with carb cleaner and such. Put it back on with a new gasket. Awhile back I thought it was the MAP sensor, replaced it and cleaned the hole it sits in. No joy. Does anyone have experience with this? Taking it to dealer/shop is the last thing I wanna do because I am confident I can fix this myself. Will I need to buy a new EGR valve. Bought a new engine coolant sensor and I am installing it tomorrow morning. Any insight would be VERY MUCH APPRECIATED!
Lahms is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 08-27-2016, 12:23 PM   #2
billr
Master Member
billr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to behold
 
Join Date: Jul 2013
Posts: 7,438
Default Re: Vehicle lurches when reaches running temp

If you have a scanner with live-data, you could check the MAP, EGR, ECT, and much more, without just throwing parts at it. The EGR valve (and other stuff) can be checked with an electrical multimeter, though, it's just more difficult to do.

Easiest to try with the EGR is to just block off the ports under it, see if that stops the lurching.
billr is offline   Reply With Quote
Reply

Tags
egr valve, sl2 1996


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine BARELY running after vehicle was parked. Help DawnR S-Series Tech 27 10-07-2015 05:44 PM
Loss of power when car reaches operating temp, transmission related? jushinator S-Series Tech 10 02-07-2011 08:50 AM
loss of power when car reaches operating temp.... Help needed jushinator S-Series General 67 02-07-2011 01:02 AM
00' Sl2 not hitting running temp WesB S-Series General 18 01-07-2011 04:39 PM
Vehicle running great, still change ECTS? Vue&SL1 S-Series Tech 14 12-04-2007 10:27 PM


All times are GMT -4. The time now is 03:22 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.