SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 07-27-2017, 08:43 PM   #1
jacmic97
New Member
jacmic97 is on a distinguished road
 
Join Date: Jul 2017
Posts: 1
Default How I fixed a weird issue with cruise control

Hi all,
Thought I would make an account and say what I had to do to get cruise control installed working in my SL1 that did not originally have it, in the hope that this info helps someone else trying to do this.

As detailed in other guides I had to get the cruise switches that attach to the steering wheel and the module that attaches to the gas pedal from a car at the junkyard. These plugged right in, the wiring was all there. I watched a video by richpin06a on YouTube that walked me through this. After this, I had to take my car to the dealership to get them to program the car to see the cruise components.

But after this was done, the cruise control worked somewhat. It would hold a speed for about 20 seconds and then disengage and I would have to turn cruise off and back on again.

As it turns out, a missing or dead instrument bulb in the "Service Wrench" dash light can cause the cruise to act kooky. I replaced this and my odometer bulb (because it was burnt out) and the cruise works great now

Hopefully this helps someone having issues similar to the one I had. Not really an obvious logical connection between cause and effect on this one, it took a bit of digging to figure this out.

Jack

REWARD EXCELLENCE!

Add to jacmic97's Reputation
Rate the quality of this post and help jacmic97 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
jacmic97 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 07-27-2017, 10:44 PM   #2
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 66,693
 

1998 SC2
Default Re: How I fixed a weird issue with cruise control

Several cruise faults show up as a service wrench light. If the bulb has failed then the PCM disables cruise as there is no monitoring of its critical functions. You should also have a SES light for the failed service wrench bulb also will illuminate the SES light.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Old 07-28-2017, 11:12 AM   #3
alordofchaos
Super Member
alordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud of
 
alordofchaos's Avatar
 
Join Date: Jan 2009
Location: Central MI
Posts: 12,837
 

2002 SC2
1998 SL2
Default Re: How I fixed a weird issue with cruise control

This is interesting, I would have never made the connection between a bulb being out and a cruise malfunction, but it makes sense as explained.

Thanks to both of you!

...
I'm not worthy to grovel in the shadow of Signmaster's wisdom

11/2016 red 2002 5 spd SC2 151k DD
7/2010 Craigslist white 1997 SC2 project
12/2008 eBay silver 1998 SL2 5 spd 102k, now 201k+ miles

REWARD EXCELLENCE!

Add to alordofchaos's Reputation
Rate the quality of this post and help alordofchaos reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
alordofchaos is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise Control Issue FINCH Vue Tech 4 11-27-2016 07:16 PM
2005 Ion cruise control intermittant then stops working-fixed lcd60 Ion Tech 7 01-04-2014 11:26 AM
Cruise Control going weird, HELP PLEASE macman90 L-Series Tech 13 08-18-2010 04:57 PM
97 SL2 - Cruise control issue jnawalker S-Series Tech 3 06-15-2007 01:59 PM
Cruise control issue FL_SL2 S-Series Tech 7 08-27-2005 10:35 PM


All times are GMT -4. The time now is 03:53 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.