SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Closed Thread
 
Thread Tools Display Modes
Old 01-28-2005, 03:05 AM   #1
pantero21
New Member
pantero21 is on a distinguished road
 
Join Date: Dec 2004
Posts: 5

1996 SC2
Default 1996 SC2 electrical failure

Here's my story. Car (1996 SC2 manual) was running fine. Left it parked (outdoors, rainy weather) for three days. Then started up and heard a high-pitched variable whirring, first time ever - as car was accelerating, sounded sort of like a siren (I kept looking in rear-view mirror for flashing lights!). Other than sound, ran fine. 24 hours later, drove again, whirring was much less. Started three times with no problem in the course of the night, then I stopped to gas her up (in the rain). Started again with no problem but immediately the interior lights looked really dim, someone honked at me as if my headlights were off (I got out and checked and they were on but they seemed really dim from inside the car), while driving home the windshield wiper was really weak then just stopped working, the radio stopped working but picked up electrical noise from the engine. I just about made it home but as I was parallel parking in front of the house, it stalled and wouldn't start again. Now I am recharging the battery from the house electricity. Any ideas what might be wrong? A short draining the battery? Alternator shot? Help!
pantero21 is offline  
SaturnFans.com Sponsored Links
Old 01-28-2005, 03:10 AM   #2
pantero21
New Member
pantero21 is on a distinguished road
 
Join Date: Dec 2004
Posts: 5

1996 SC2
Default Re: 1996 SC2 electrical failure

And also, the air bag light was on (steady, not flashing) on that nasty drive home. And the car smelled a little like something burning when I got out. And, when I removed the battery, the hot terminal had some white corrosion junk on it.
pantero21 is offline  
Old 01-28-2005, 03:16 AM   #3
LowSC2
Member
LowSC2 is on a distinguished road
 
LowSC2's Avatar
 
Join Date: Jan 2001
Location: Livermore, CA
Posts: 351
 

1999 SC1
1991 SL2
Default Re: 1996 SC2 electrical failure

Sounds like the alternator went out. Replace it. But make sure the battery is charged first or you can kill the new alternator.
LowSC2 is offline  
Old 01-28-2005, 11:39 AM   #4
madpogue
Super Member
madpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud of
 
Join Date: Sep 2004
Location: Madison, WI USA
Posts: 25,715
 

1996 SW2
Default Re: 1996 SC2 electrical failure

First check the belt. The combination of noise, smell and electrical problems points to it. If it turns out the alt is bad, I'd recommend replacing the belt anyway. If the alt. went bad physically, that is, its bearings made it harder to turn, that would put excess wear on the belt. Besides, you're doing ALL the labor for replacing the belt if you're replacing the alt.
madpogue is offline  
Old 01-29-2005, 01:19 AM   #5
ssicarman
Super Member
ssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to behold
 
ssicarman's Avatar
 
Join Date: Oct 2000
Location: Western Canada
Posts: 10,455
 
Default Re: 1996 SC2 electrical failure

Classic symptoms of a dead alterntor. Make sure that you clean the corrosion off of the battery and the terminal as well.
...
A lousy day in paradise is still a day in paradise.
ssicarman is offline  
Old 01-30-2005, 12:24 AM   #6
Dr. Bob
Master Member
Dr. Bob is on a distinguished road
 
Join Date: Mar 2000
Location: SE Minnesota
Posts: 2,041
Default Re: 1996 SC2 electrical failure

You don't mention that the electrical system light (the one that looks like a battery) came on.

After the battery is charges and the alternator fixed, you may want to verify the bulb is good.
Dr. Bob is offline  
Old 01-30-2005, 05:42 PM   #7
pantero21
New Member
pantero21 is on a distinguished road
 
Join Date: Dec 2004
Posts: 5

1996 SC2
Default Re: 1996 SC2 electrical failure

Took it to the dealer, paid $400 p/l to have the alternator replaced (with a remanufactured one). The remanufactured unit does NOT have a lifetime warranty - only 3 yr/36K miles. Interesting point about the battery light - it flashes on momentarily at startup so the bulb is fine and I have no idea why it didn't go on during the crisis.
pantero21 is offline  
Old 01-30-2005, 06:32 PM   #8
RalliArt16
Senior Member
RalliArt16 is on a distinguished road
 
RalliArt16's Avatar
 
Join Date: Dec 2004
Location: Orlando, FL
Posts: 1,415
 

1996 SC1
1995 SC2
Default Re: 1996 SC2 electrical failure

thats quite a bit of $$$... did you not want to attempt it yourself? At first anything car related looks overwhelming.. but if you break it down into steps.. its easier than you would think (assuming you have the necessary tools and space )
RalliArt16 is offline  
Old 01-30-2005, 08:21 PM   #9
madpogue
Super Member
madpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud of
 
Join Date: Sep 2004
Location: Madison, WI USA
Posts: 25,715
 

1996 SW2
Default Re: 1996 SC2 electrical failure

Did they install a new belt? It was probably due for one if it was the original, and if you smelled something, the bad alternator was probably dragging the belt. They should have charged you only for the part, as the labor would be part of the labor for the alt. change.
madpogue is offline  
Closed Thread

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
odd intermittent electrical failure.. daveb_sc2 S-Series Tech 2 10-01-2009 11:44 AM
Complete Electrical Failure epicwake S-Series Tech 9 11-08-2008 04:52 PM
2002 L300 - Intermittent total electrical failure - unsafe? andymcconnell L-Series Tech 3 09-04-2008 11:46 AM
2003 L200 - Electrical Failure - Help! MGeorge L-Series Tech 3 05-14-2008 02:51 PM
Electrical system failure in 95 SL2 helikid15 S-Series Tech 6 01-20-2003 09:07 PM


All times are GMT -4. The time now is 08:19 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.