SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn Aura > Aura General

Reply
 
Thread Tools Display Modes
Old 09-16-2020, 02:48 AM   #21
joeperil
Junior Member
joeperil is on a distinguished road
 
Join Date: Apr 2008
Posts: 12
Default Re: "Service Traction" - "Service ESC" comes up

I have had this numerous times on my '07 Aura.

It was always either a bad wheel speed sensor or a break or short in the ABS wiring harness.

Unfortunately if it is a bad wheel speed sensor you will have to replace the wheel bearing and hub as it had the stupid speed sensor integrated into it. This turns a $50-$100 problem into one costing several hundred if a shop does it for you.

If it is the wiring you have to chase down to where the problem is and repair it. After two repairs I recently just had a mechanic replace the ABS wiring harness. The first time it was damaged by a mouse. The second time a wire just broke. The last time some water might have gotten into one of the prior repairs and caused the signal to fail.

If you are lucky, it could be just on of the connectors at the hub is loose.

And yes, for those that are selling, I can't see getting a decent price for the car with this problem since it lights up the ABS, traction control off, and stability control lights as well as always flashing "SERVICE TRACTION" on the display.
joeperil is offline   Reply With Quote
SaturnFans.com Sponsored Links
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 L 3.0L 85K miles speedometer and "service engine soon" codes v-bob L-Series Tech 5 02-11-2009 07:24 PM
Another "SERVICE ESC" question Budd Aura General 0 09-24-2008 07:40 PM
OBDII code "Service Engine Soon" 03 VUE 2.2 / 5sp skijay Vue Tech 2 10-30-2006 05:14 PM
Can "Service for Engine" light be caused by improper auto repairs?? Aurora88 S-Series Tech 3 06-08-2005 01:13 PM
This week's VUE glitch (or "My service dept is nice but dim") wmacblue Vue General 4 05-24-2002 03:40 PM


All times are GMT -4. The time now is 05:40 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.