SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-04-2015, 05:14 PM   #1
mpit91
New Member
mpit91 is on a distinguished road
 
Join Date: Jan 2015
Posts: 4
Default QUICK QUESTION... Symptoms of bad TPS?

Quick question here. Can I get some symptoms of a bad or failing throttle position sensor?

Im having downshift issues when the engine/trans gets hot and i am braking to a stop. By this, i mean that the car doesnt want cycle down the gears like it is supposed to. I think it is staying in 2nd or something.

To avoid this problem, I put the car in neutral when braking and coming to a stop light. The RPMs stay at around 2 until i come to a full and complete stop and then the car decides to idle very normally, right at 750.

Reason I suspect the TPS is because I installed a new one, (not sure if the old one was bad) and apparently there is a learning process. I tried resetting the PCM with the battery disconnected for 10 mins, but it didnt fix the problem above.

I dont think its the IAC valve because i just cleaned away all the carbon buildup in the throttle body which made the car idle better.

Any insight would be appreciated!

REWARD EXCELLENCE!

Add to mpit91's Reputation
Rate the quality of this post and help mpit91 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
mpit91 is offline   Reply With Quote
SaturnFans.com Sponsored Links
 



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
strange symptoms...(another A/C question) colonelhogan44 S-Series Tech 2 05-31-2008 11:04 AM
quick question colonelhogan44 S-Series General 2 06-08-2007 02:38 AM
quick quick quick question about flywheel. Jinjo S-Series General 3 09-07-2006 09:31 AM
Quick question beensmoked L-Series General 0 11-10-2005 10:35 PM
Quick Question and not so quick one... John Marshall Miscellaneous Tech 5 02-19-2004 10:22 AM


All times are GMT -5. The time now is 07:40 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.