SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 11-22-2015, 05:04 AM   #1
KMW
New Member
KMW is on a distinguished road
 
Join Date: Oct 2015
Posts: 9
Default 2000 sL2 starting problems

So about a week ago, my SL2 started having problems with starting up. When I went to turn it on, it would have diifficulty staying on, with the rpms flucuating below 1000 rpms before stalling out on me completely, but it would start back up immediately, still hesitating before staying at the usual rpm level that ive always seen it at, which is at about 1000-1200 rpms, flucuating whenever I was in idle. Well, a couple of days ago, I tried to turn my car on and the engine just started turning over and not starting . I'm still not able to get it to work. Does anybody have any idea as to what it is?
KMW is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 11-22-2015, 09:14 AM   #2
SL19302
Master Member
SL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to allSL19302 is a name known to all
 
SL19302's Avatar
 
Join Date: Jan 2011
Location: Drums, PA
Posts: 3,350

2000 SW2
2002 SL1
Default Re: 2000 sL2 starting problems

One good place to start is your coolant temp sensor, Was that ever replaced?
...
2015 Subaru Forester Limited "Prinny"
2000 SW2 Still Running Strong- 160K Traded In
2002 SL1 Still has Its Training Wheels on at 88K Traded In


CHECK YOUR OIL!
SL19302 is offline   Reply With Quote
Old 11-22-2015, 06:10 PM   #3
KMW
New Member
KMW is on a distinguished road
 
Join Date: Oct 2015
Posts: 9
Default Re: 2000 sL2 starting problems

Quote:
Originally Posted by SL19302 View Post
One good place to start is your coolant temp sensor, Was that ever replaced?
I'm actually not quote sure if it's been replaced or not. I just bought this car used from a dealership a couple of months ago. Don't know if the previous owner has changed it out
KMW is offline   Reply With Quote
Old 11-22-2015, 07:46 PM   #4
KMW
New Member
KMW is on a distinguished road
 
Join Date: Oct 2015
Posts: 9
Default Re: 2000 sL2 starting problems

Just read the code on it and I got a P0107 code
KMW is offline   Reply With Quote
Old 11-22-2015, 08:02 PM   #5
fetchitfido
Super Member
fetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant future
 
fetchitfido's Avatar
 
Join Date: May 2006
Posts: 14,495
 

2001 SC2
Default Re: 2000 sL2 starting problems

P0107 - Map sensor low voltage.
Try wiggling & cleaning out the map sensor connector.

Attached diagnostic flow chart, wire diagram & FSM code description/operation.

One time I somehow managed to put the wrong ECTS to the PCM, starting would work fine once warmed up or when outside temp's were above ~50f but one cold snowy midnight after work the dang thing wouldn't start...pulled the connector off the ECTS and "vroom". Left it that way for the drive home, fixed it properly the next morning with the right ECTS...point is a bad ECTS could act the same way as the wrong one.
Attached Files
File Type: pdf P0107.pdf (68.6 KB, 13 views)
...
The proper way to fix a S-Series automatic is to replace it with a 5spd O:)
fetchitfido is offline   Reply With Quote
Old 12-13-2015, 09:05 PM   #6
KMW
New Member
KMW is on a distinguished road
 
Join Date: Oct 2015
Posts: 9
Default Re: 2000 sL2 starting problems

Alright, I'm having another problem with it starting. I took it to an independent mechanic a week ago, which he switched out the spark plugs, which looked like they were the original spark plugs that came with the car, 149,000 miles ago. The car started up, and he also took it for a test drive and saw that the engine was getting way too much gas due to a bad fuel pressure regulator so he switched that out too with a new filter on it.

Now I've had it for a week and I've noticed something that happened only twice: the engine wouldn't start unless I gave it a little gas. I tried to go to work today and all of a sudden, it wouldn't start. Only cranks. I'm also getting a service engine soon light on with it.
KMW is offline   Reply With Quote
Old 12-13-2015, 10:15 PM   #7
KMW
New Member
KMW is on a distinguished road
 
Join Date: Oct 2015
Posts: 9
Default Re: 2000 sL2 starting problems

I also smelled gas when I tried to turn it on, so I'm not quite sure if it's the ECTS or engine flooding.
KMW is offline   Reply With Quote
Old 12-14-2015, 12:05 AM   #8
KMW
New Member
KMW is on a distinguished road
 
Join Date: Oct 2015
Posts: 9
Default Re: 2000 sL2 starting problems

And now it started just fine.
KMW is offline   Reply With Quote
Old 12-14-2015, 01:27 AM   #9
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 43,910
 

2003 L-Series 3.0L Sedan
Default Re: 2000 sL2 starting problems

You were given one of the best suggestions for S-series owners new to Saturnfans - examining and replacing the coolant sensor if its the original one. The original ones fail and tends to run the engine rich all the time and floods engines on occasions.
Attached Images
File Type: jpg plastic-brass cts.jpg (82.6 KB, 5 views)
fdryer is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 LS2 Starting problems AngusAR L-Series Tech 11 08-10-2013 03:09 PM
Starting problems. 2000 saturn SL. Need help please thanks! nlange S-Series Tech 8 09-23-2009 11:56 AM
Starting problems. 2000 saturn SL. Need help please thanks! nlange Canadian Saturn Owners 4 09-21-2009 10:17 PM
Problems starting my 2000 SL2 cherubkiss S-Series Tech 10 03-12-2007 11:49 AM
Problems starting my 2000 SL2 cherubkiss L-Series Tech 3 03-09-2007 03:46 PM


All times are GMT -4. The time now is 09:55 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.