SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-05-2017, 09:23 AM   #1
Kaspar7
Junior Member
Kaspar7 has a spectacular aura aboutKaspar7 has a spectacular aura aboutKaspar7 has a spectacular aura about
 
Join Date: Jun 2017
Location: Durham, NC
Posts: 17

1999 SW1
Default 19999 SW1 temp gauge behaving oddly after radiator replacement

First, I bought the car used about 3 months ago and it didn't come with maintenance records. It has 212K miles. After a few weeks, it started losing a little coolant. There was a small leak on the plastic part of the radiator that someone had tried to patch with epoxy and the patch wasn't holding. This past Saturday, that trickle became a massive leak.

I bought a new radiator and upper/lower hoses and installed them Monday. Leak at the radiator is fixed. I've done this before, so I knew to expect some trapped air in the cooling system to take a little time to get out to the recovery tank. I've added a little coolant 2-3 times because of this. there is a sort of gurgling/hissing sound coming from the coolant recovery tank but I can't tell for sure if there is a leak there.

Before the repair, (and after replacing the ECTS), the temperature gauge was consistently at 1/4 any time that the engine was warmed up. Now, the gauge goes up to 1/2 and sometimes a little over 1/2.

I forgot (silly me!) to replace the thermostat while I had the hoses off. Maybe I should have done that - and maybe I will need to? I'll have to drain and replace most of the coolant to replace the thermostat, so I need to know whether this is a necessary repair.

Mostly, I want to be sure that the car isn't running too hot.

any help would be appreciated!

Thanks in advance.

REWARD EXCELLENCE!

Add to Kaspar7's Reputation
Rate the quality of this post and help Kaspar7 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Kaspar7 is offline   Reply With Quote
SaturnFans.com Sponsored Links
 



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
air cond. fuel gauge and temp gauge not working. Help?? brielle L-Series General 12 09-14-2016 08:07 PM
Wierd Saturn L200 Gas Gauge/ Temp Gauge and change oil light probs! Crittercage L-Series General 1 09-09-2016 12:23 PM
This is oddly hot. XRL Vue Mods 5 07-04-2009 01:21 AM
Temp Gauge Dead, ECTS Replacement? DecayingOmega S-Series Tech 5 05-19-2007 10:24 AM
New Engine and radiator.. Temp gauge input needed!!!! sideout303 S-Series Tech 5 11-25-2003 11:41 PM


All times are GMT -5. The time now is 03:50 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.