SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Categories > General Saturn Discussion

Reply
 
Thread Tools Display Modes
Old 12-08-2019, 05:51 PM   #1
Wallyo
Junior Member
Wallyo is on a distinguished road
 
Join Date: Sep 2011
Location: Princeton, NJ
Posts: 24

1997 SW1
Default Did I cause engine damage?

I did a stupid thing. I changed the oil in my Saturn, started the engine to check for leaks, got distracted, came back and notice loud valve lifter clicking and realized I didn't put in the new oil! I turned the engine off after about a half minute of running it dry. When I put in the new oil and started it again, it went well, except that there's now one lifter clicking pretty loud, and I can't say for sure if that's a new sound. Do you think I did damage? It's a 97 SW1, about 185,000 miles.

While we're at it, does anyone know where the engine coolant level sensor is? The radiator and reservoir are full but the coolant warning light flashes as soon as I start the engine. I think it's a faulty sensor, but can't find it.

Finally, why do I have to add oil so often? I don't see any oil spots on the driveway, and there's not a trace of blue smoke or smell in the exhaust.

I love this site, and thanks again for the many good tips on keeping my Saturn on the road.
Wallyo is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 12-08-2019, 10:19 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 44,331
 

2003 L-Series 3.0L Sedan
Default Re: Did I cause engine damage?

I think you should repost this again in the S-series Tech forums. You'll probably get immediate replies.
fdryer is offline   Reply With Quote
Old 12-11-2019, 02:12 PM   #3
alordofchaos
Super Member
alordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud of
 
alordofchaos's Avatar
 
Join Date: Jan 2009
Location: Central MI
Posts: 13,048
 

2002 SC2
1998 SL2
Default Re: Did I cause engine damage?

^ ^ ^
+1, post in the model-specific forums.

You coolant level sensor is a simple float, located in the surge tank (some folks call it the reservoir) located on the passenger inside fender.

First, make sure that the tank is really full - the minimum cold level is at about the halfway mark on the tank. Full is at the tank seam, almost to the top of the tank.

If that doesn't fix it, drain and remove the tank, add a dash of dish soap and warm water using your fingers to plug the holes, and give it a decent shaking. That should unstick the float - you should hear it rattle / move. Rinse, install, and refill
...
I'm not worthy to grovel in the shadow of Signmaster's wisdom

11/2016 red 2002 5 spd SC2 151k DD
7/2010 Craigslist white 1997 SC2 project
12/2008 eBay silver 1998 SL2 5 spd 102k, now 201k+ miles
alordofchaos is offline   Reply With Quote
Reply

Bookmarks

Tags
coolant light, lifter noise, no oil


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 Vue - low oil engine damage? SLMike Vue Tech 10 06-03-2011 04:15 PM
engine oil pan saturn l200 2.2l damage guillermoqr2000 L-Series Tech 3 03-09-2011 02:10 AM
has any1 thrown a timing chain and NOT had engine damage on SOHC sl1 type engine? MacExperts S-Series Tech 14 09-21-2006 06:04 PM
Damage to Engine Cradle karaoke diva S-Series General 1 10-21-2005 05:13 PM
SC2 Maroon w/ tan interior. no engine, front end damage DiehlLane Classifieds 11 01-11-2005 08:38 PM


All times are GMT -4. The time now is 06:41 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.