SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Ion > Ion General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 02-12-2020, 06:46 PM   #1
Knightjams523
New Member
Knightjams523 is on a distinguished road
 
Join Date: Feb 2020
Location: Parsons, WV
Posts: 1

2005 ION-1 Sedan
Default Headlight problems

I have a 2005 saturn ion 1 with a 2.2 liter engine and this is the first time I owned a saturn and I am having some difficulties understanding the problem and what needs to be repaired.

Recently I was having issues with my driver side headlight, it was dimmed dramatically all of the sudden but the passenger side was fine and so were the parking lights and the rear brake lights as well as the interior lights. Even the high beams worked fine both driver side and passenger side.

Then a few days later both the driver side and passenger side headlight stopped working both low beam and high beam will not turn on and the driver side parking light also turned off. The only thing working is the passenger parking light and the brake lights in the rear. Now I took a look under the hood and checked the wires and there was nothing amiss and the driver side parking light/turn signal was burnt where the connection is. So I replaced the bulb and it works but the headlights refuse to work. I checked the bulbs and they are fine but the headlight socket for both driver and passenger side were burnt a bit. The other issue is when I turn on my low beams the high beam indicator on the dash board turns on even though high beams are off. When I turn the high beams on it still indicates that they are on even though there is no light coming from the headlights.

Would replacing both sockets turn the headlights back on or could this be a headlight switch problem? Or is there a wiring problem that someone knows about and I dont?

I bought this car last summer used but was in great shape and was inspected and a mechanic looked into everything before I bought it. The headlights worked great at the time and the only thing I replaced myself was the brakes, rotors, brake pads, calipers, wheel bearings, radiator, and fuel line as well as normal oil change, air filter change, and topped off fluids. When I bought it, it had 95,000 miles and today it reads 166,221 miles.

Can anyone tell me what could be the issue so I may repair it? I plan on replacing the headlight sockets soon as I get a hold of some butt connectors.

REWARD EXCELLENCE!

Add to Knightjams523's Reputation
Rate the quality of this post and help Knightjams523 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Knightjams523 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 02-14-2020, 12:17 PM   #2
imaddicted2u
Member
imaddicted2u is just really niceimaddicted2u is just really niceimaddicted2u is just really niceimaddicted2u is just really niceimaddicted2u is just really nice
 
imaddicted2u's Avatar
 
Join Date: Jun 2013
Location: Nova Scotia
Posts: 393

2008 AURA XE
Default Re: Headlight problems

You are likely on the right track if the plugs look burnt. Make sure the replacements are rated for high temperature.
I attached a circuit diagram that I found elsewhere. I hope it's the same as yours.
If you have a volt/ohm meter, with the connectors unplugged, check for a constant 12v on pin B of the headlight connectors. If these are missing, the fuses could be blown. Each side is fused separately in the engine compartment fuse box.
The other two pins can be checked on ohms. With the headlight switch on and on low there should be close to 0 resistance from pin A to the - battery terminal. With the headlight switch on and the high beams activated there should be near 0 ohms of resistance from pin C to the - battery terminal. If either of these show high resistance the ground is bad and may need to be cleaned up.
If you flip the pass to flash, it bypasses the headlight relay and if all the connections are good, the high beams should light. If they light you might have a bad headlight relay.
The headlight grounds pass through the body control module for feedback signal. A bad connection there could mess with the proper operation of the headlights as well. I'm not positive but the feedback signal may be what lights the high beam indicator. If the power is or ground is not right, that could be what is keeping the indicator lit up.
Attached Images
File Type: gif 2010-12-02_034240_05_ion_headlight_schematics.gif (23.1 KB, 1 views)

...
2008 Saturn Aura XE 3.5L 4 spd
2000 Saturn SL1 1.9L SOHC (Retired)

REWARD EXCELLENCE!

Add to imaddicted2u's Reputation
Rate the quality of this post and help imaddicted2u reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
imaddicted2u is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Headlight bulb problems xdarkxfirex Astra General 1 08-15-2016 08:16 PM
Headlight Problems Silverback Vue General 2 11-02-2015 10:20 AM
04 headlight problems mikemag123 Vue Tech 5 09-21-2012 11:03 PM
headlight problems? page454 S-Series General 3 08-31-2005 01:18 PM
headlight problems, 92 SC DJboozeAlot S-Series Tech 4 07-15-2005 11:04 AM


All times are GMT -4. The time now is 04:09 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.