SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 02-16-2018, 01:14 PM   #1
Jim@HiTek
Member
Jim@HiTek has a spectacular aura aboutJim@HiTek has a spectacular aura aboutJim@HiTek has a spectacular aura about
 
Join Date: Jun 2016
Location: Oregon
Posts: 217
 

2001 SL1
Default P0404 that fails to respond to changing the EGR...

'01 SL1, 67,000 miles

I did a lot of research for the SES light I was getting here on the forum so didn't think there'd be too much trouble fixing the cause of code P0404. That hasn't been the case.

First I removed the EGR and carb cleaner spray cleaned it, found that the pindle moved freely. Installed the new gasket I'd bought. Forgot to run the engine to blow out carbon. Contact spray on the connector. R&R the fuse. SES light came back in 20 miles.

Second time, used a tooth brush to thoroughly scrub the EGR, again made sure the pindle was free, sprayed the ports, scrubbed with a toothbrush, and this time ran the engine for four seconds. Contact spray on the connectors again. This time took 30 miles before the SES came back on.

Third time, ordered a new EGR, Standard T-series brand (made in Mexico). Noticed that the pindle moves easier then on the old EGR, like the spring was less stiff. Ran the engine before I installed it for 4 seconds, reset the fuse. This time it took 15 miles for the SES to come back on. Same old P0404 code.

What should I do next?

...
2001 Saturn SL1 SOHC
1.9L, Basic Transport

REWARD EXCELLENCE!

Add to Jim@HiTek's Reputation
Rate the quality of this post and help Jim@HiTek reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Jim@HiTek is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 02-16-2018, 02:03 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 43,242
 

2003 L-Series 3.0L Sedan
Default Re: P0404 that fails to respond to changing the EGR...

When the egr valve was left off, did the engine free rev immediately to programmed rev limit (4500)? This test is to check for a blocked intake port with exhaust deposits preventing exhaust gases from entering the intake manifold. The exhaust port should be blowing carbon deposits from high revs.

Anecdotal info that may or may not apply here. I replaced an O2 sensor to a Nissan Sentra with an NTK brand. The O2 error code returned and was puzzled. In the end, the car was brought to a shop and the sensor was replaced with a Denso brand and extinguished the error and passed state inspection. The difference in brands was just a few dollars........

Some aftermarket parts aren't compatible although they're listed as direct replacements for OEM parts. Used original parts from a junk yard sometimes helps while keeping costs down.
Attached Files
File Type: pdf DTC P0404.pdf (149.7 KB, 6 views)
File Type: pdf DTC P0404-1.pdf (100.8 KB, 3 views)

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 02-16-2018, 02:27 PM   #3
Jim@HiTek
Member
Jim@HiTek has a spectacular aura aboutJim@HiTek has a spectacular aura aboutJim@HiTek has a spectacular aura about
 
Join Date: Jun 2016
Location: Oregon
Posts: 217
 

2001 SL1
Default Re: P0404 that fails to respond to changing the EGR...

Yes, the engine rev'ed up to 4200+ immediately and I left it there for 4 seconds. There was very little carbon blown out...none that I detected. But overall this has tended to be a fairly clean engine. I ran it just after I used carb cleaner and a tooth brush to clean the ports out a bit.

It's not a matter of just a couple bucks for an EGR valve. Autozone has them at $129. Amazon and Rockauto have them at $78. eBay has them from $35 to $100. The Standard brand was $48, not the cheapest, not the most expensive, and free shipping. Saving between $30 to $81 for a very simple device suits my nature.

...
2001 Saturn SL1 SOHC
1.9L, Basic Transport

REWARD EXCELLENCE!

Add to Jim@HiTek's Reputation
Rate the quality of this post and help Jim@HiTek reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Jim@HiTek is offline   Reply With Quote
Old 02-24-2018, 04:00 PM   #4
Jim@HiTek
Member
Jim@HiTek has a spectacular aura aboutJim@HiTek has a spectacular aura aboutJim@HiTek has a spectacular aura about
 
Join Date: Jun 2016
Location: Oregon
Posts: 217
 

2001 SL1
Default Re: P0404 that fails to respond to changing the EGR...

After several checks driving over 100 miles, I was still getting the P0404 so I sent the EGR back. A mechanic told me that the ECM is not likely the source of the problem...he'd never had to replace a bad one. He figures it's most likely a wiring or connector issue.

So I'll be looking into that. Trying to chase down the wiring from the EGR as it travels to the ECM. The connector at the EGR looks fine...and I sprayed it with contact cleaner a couple times too.

Before I returned the new EGR, I had both new and old on the workbench and measured them looking for any large discrepancies. Thanks to fdryer for the drawings. No major differences found. The pindle changed the resistance smoothly in both cases. The Rt was within tolerances for both devices.

...
2001 Saturn SL1 SOHC
1.9L, Basic Transport

REWARD EXCELLENCE!

Add to Jim@HiTek's Reputation
Rate the quality of this post and help Jim@HiTek reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Jim@HiTek is offline   Reply With Quote
Old 02-24-2018, 06:30 PM   #5
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 43,242
 

2003 L-Series 3.0L Sedan
Default Re: P0404 that fails to respond to changing the EGR...

Here's some background info about egr valve operation.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 02-24-2018, 06:54 PM   #6
Jim@HiTek
Member
Jim@HiTek has a spectacular aura aboutJim@HiTek has a spectacular aura aboutJim@HiTek has a spectacular aura about
 
Join Date: Jun 2016
Location: Oregon
Posts: 217
 

2001 SL1
Default Re: P0404 that fails to respond to changing the EGR...

I don't have any of those symptoms as related on those documents. So that seems like a good thing.

Have plenty of power during acceleration, no hesitation, no overheating, no engine stalls. Even after it warms up. No noticeable issues when the A/C is turned on either.

Also starts fine in just a crank or two. Has great fuel mileage.

It's just that the P0404 SES light comes on after 30 miles or so after I've reset it. But I can drive for weeks with no other symptoms.

Thanks for your input.

...
2001 Saturn SL1 SOHC
1.9L, Basic Transport

REWARD EXCELLENCE!

Add to Jim@HiTek's Reputation
Rate the quality of this post and help Jim@HiTek reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Jim@HiTek is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
P0404 code after changing the egr valve, and radio resets itself everyday? Help? 1999saturnsl22 S-Series Tech 6 06-15-2012 11:20 PM
Help PLease respond fast Diezeltitan08 S-Series Tech 3 11-21-2011 11:57 AM
Car did not respond to gas pedal???? Dingo Warrior S-Series Tech 1 07-22-2008 07:54 PM
Please respond if interested? firestomper25 Classifieds 0 01-12-2008 05:44 PM
Everyone please respond RSXracer Mods and Performance 8 03-14-2002 12:41 PM


All times are GMT -4. The time now is 03:49 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.