SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Mods
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 08-12-2019, 08:49 PM   #1
jpsuli
Member
jpsuli is a jewel in the roughjpsuli is a jewel in the roughjpsuli is a jewel in the rough
 
jpsuli's Avatar
 
Join Date: Aug 2015
Location: Minneapolis
Posts: 201
 

1997 SL2
Default Running cluster outside of car - mileage stuck?

Hello,

I have a 99 cluster that I want to run outside of the car, I found this:
Quote:
Originally Posted by OldNuc View Post
5000pulses/mile from the PCM. Below from FSM.

SPEEDOMETER/ODOMETER
The speedometer receives vehicle speed information from the Powertrain Control Module (PCM ). The vehicle speed signal is passed through an RC filter to the input of the speedometer/odometer driver Integrated Circuit (IC ), located in the instrument panel cluster. The high-to-low edge of the square wave input triggers the IC to provide a well defined pulse of current to the coil of the speedometer gage. The IC also counts the input transitions and uses this information to drive the odometers. The vehicle completes one mile for every 5000 pulses received from the PCM.

There are two odometers in the instrument panel cluster. The odometer shows total mileage since the vehicle was built and cannot be reset. The trip odometer which shows total mileage since last reset, and can be reset to zero at any time. The two odometers are not synchronized. This means that even through one of the odometers may advance by a mile/kilometer the other one may or may not advance to the next mile/kilometer at the same time. The odometer is back lit by a single bulb to make it easier to read in all lighting conditions.

TACHOMETER
The tachometer is directly controlled by the powertrain control module (PCM) using a Pulse Width Modulated (PWM ) signal based on the signal received from the Crankshaft Position (CKP ) sensor. The PWM signal to the cluster is passed through an RC filter and sent to the tachometer driver integrated circuit (IC). The high-to-low edge of the PWM signal triggers the IC to provide a well defined pulse of current to the coil of the tachometer. The engine completes one revolution for every six pulses received from the PCM. The PCM monitors circuit 121 for an open, short to ground or short to voltage and will set DTC P1693 if certain parameters are met.
I grabbed a PWM switch and found the two wires that control ignition and the speedo, I was able to get it to work somewhat unreliably though the mileage does not move.

Any thought to get the mileage to work? I have spare PCMs to make it work, will try to play with it this weekend.
Attached Images
File Type: jpg speedo.jpg (122.5 KB, 11 views)

...
'97 Saturn SL2 @ 140k

r/Saturn_Cars moderator

REWARD EXCELLENCE!

Add to jpsuli's Reputation
Rate the quality of this post and help jpsuli reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
jpsuli is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 08-13-2019, 09:54 AM   #2
fetchitfido
Super Member
fetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant future
 
fetchitfido's Avatar
 
Join Date: May 2006
Posts: 14,337
 

2001 SC2
Default Re: Running cluster outside of car - mileage stuck?

Going by the diagram the Speedometer/Odometer just needs power, ground and signal to work. Ground & signal pins are on a different connector from the power pin.
The description of the signal required sounds pretty picky, if the square wave isn't 0-12v and a true square it won't work properly.
Attached Images
File Type: jpg 1999 IP Cluster Connector View-black.jpg (144.7 KB, 3 views)
File Type: jpg 1999 IP Cluster Connector View-natural.jpg (129.6 KB, 3 views)
File Type: jpg 1999 S-Series Gauge wiring diagram.jpg (176.8 KB, 5 views)

REWARD EXCELLENCE!

Add to fetchitfido's Reputation
Rate the quality of this post and help fetchitfido reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fetchitfido is offline   Reply With Quote
Old 08-14-2019, 12:37 AM   #3
jpsuli
Member
jpsuli is a jewel in the roughjpsuli is a jewel in the roughjpsuli is a jewel in the rough
 
jpsuli's Avatar
 
Join Date: Aug 2015
Location: Minneapolis
Posts: 201
 

1997 SL2
Default Re: Running cluster outside of car - mileage stuck?

Quote:
Originally Posted by fetchitfido View Post
Going by the diagram the Speedometer/Odometer just needs power, ground and signal to work. Ground & signal pins are on a different connector from the power pin.
The description of the signal required sounds pretty picky, if the square wave isn't 0-12v and a true square it won't work properly.
Wow, these diagrams are really helpful! The wiki didn't go into such specifics. I appreciate you finding them for me.

So maybe my PWM switch provides a far too dirty signal for the cluster to properly register the movement as actual mileage. I will play around with my raspberry pi to define the actual pulses sent to the cluster.

...
'97 Saturn SL2 @ 140k

r/Saturn_Cars moderator

REWARD EXCELLENCE!

Add to jpsuli's Reputation
Rate the quality of this post and help jpsuli reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
jpsuli is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Poor Gas Mileage/Running Rich? WVUDave S-Series Tech 11 05-09-2014 08:59 AM
Gauge Cluster Mileage Reprogram stoickiwi Astra Tech 0 08-03-2013 11:30 AM
Key stuck/car keeps running 2timesatowner Ion Tech 5 05-16-2012 09:36 AM
99 SL2 with electrical issue, running lights flash- instrument cluster haywire Bjorno S-Series General 6 11-25-2009 02:44 PM
temp running hot, mileage not working. bradnelson Vue Tech 4 03-05-2007 06:17 PM


All times are GMT -4. The time now is 08:31 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.