SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-15-2009, 08:50 PM   #1
strawberripocky
Member
strawberripocky is on a distinguished road
 
strawberripocky's Avatar
 
Join Date: Aug 2009
Location: South Jersey
Posts: 106

1999 SC1
Default Horn trouble.

I've searched the forum for similar problems and have found a few only slightly similar, but for an accurate answer, I figured I would post my problem here.

Okay, so... I have a '99 Saturn SC1. My horn just stopped working one day. I replaced the fuse, honked the horn a few times, and the fuse immediately blew. Can anyone tell me if it's just a problem with one of the wires, or if it's the entire horn that needs to be replaced? I'm a little new to repairing things on my own but I've had my car for 4 years now so I'm pretty familiar with how things work on it. The only problem is, I don't know where exactly the horn is located; my Haynes manual tells me very little. I've read in other forum posts that you can access it through the driver's side headlight, but I'm not sure if that holds true for different year cars. Also, is the relay for the horn connected to the horn itself? I'm looking to work on fixing it tomorrow, so if anyone could help me out, I'd GREATLY appreciate it

REWARD EXCELLENCE!

Add to strawberripocky's Reputation
Rate the quality of this post and help strawberripocky reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
strawberripocky is offline   Reply With Quote
SaturnFans.com Sponsored Links
 



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
horn trouble-no power to horn/not fuse 2xsl2 S-Series Tech 6 03-06-2010 10:32 PM
Horn trouble- Help mila123 Support Forum for Canadian Saturn Owners 1 10-23-2009 02:03 PM
expiermented to day on 97 sc1 horn replaced with honda horn,whadda ya think! maestro S-Series Tech 1 07-26-2007 11:52 PM
Horn Trouble tmatul S-Series Tech 5 03-30-2007 07:13 PM
VUE horn location - adding 2nd horn? Robert H. Vue Tech 3 09-11-2006 03:20 PM


All times are GMT -5. The time now is 10:01 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.