SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Categories > General Saturn Discussion

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 06-27-2008, 09:47 AM   #1
Mason648
New Member
Mason648 is on a distinguished road
 
Join Date: Apr 2007
Posts: 2
Default PO137/340 and 341

I have a 98 SL1 1.9 L with 138000 miles. My service engine light will come on and then go off at what seems at random. I took it to the Advanced Auto and they said the codes they were getting are PO137 340 and 341. I am not sure what these mean and how do I corect he problem. Any help would be appreciatd
Mason648 is offline   Reply With Quote
SaturnFans.com Sponsored Links
 

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SES light on Code PO137 - Help please 69buick S-Series General 2 08-11-2009 08:44 AM
Code 301,302, 340--Need some help jk3006 S-Series Tech 18 04-01-2008 07:11 AM
Po137 plmbst S-Series Tech 2 03-12-2006 12:39 AM
$42,340 BUBBLEMAN Relay General 22 07-18-2005 08:18 PM
PO 340 camshaft positioning sensor Gpuller S-Series General 5 01-30-2004 02:39 PM


All times are GMT -4. The time now is 04:41 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.