SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 05-29-2018, 01:32 PM   #1
Patriots
Junior Member
Patriots has a spectacular aura aboutPatriots has a spectacular aura aboutPatriots has a spectacular aura about
 
Join Date: May 2018
Posts: 29
Default Replaced tps on 01 SL2.. still idles high

I just replaced the tps on my 01 SL2 a week or so ago and it was fine until a few days ago. Now it will idle high after the car has been running for a while. When I shut off the car and restart it itíll run normal again.

Checked the connection of the sensor and everything looked fine. What could be causing this issue?
Patriots is offline   Reply With Quote
SaturnFans.com Sponsored Links
 

Bookmarks

Tags
high idle, problems., saturn, sl2


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
idles high pac S-Series General 5 10-14-2011 09:56 AM
'94 SC1 idles at very high RPMs ivkowalenko S-Series Tech 6 10-12-2011 02:48 PM
'02 SL1 Idles high. Why? markdunavant S-Series General 2 06-28-2011 01:52 AM
Car idles high dubsl2 S-Series General 21 10-26-2006 09:58 PM
99 sc2 idles high and jumps a bit twincities S-Series Tech 1 07-06-2006 01:10 PM


All times are GMT -4. The time now is 10:46 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.