SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 09-25-2011, 06:19 PM   #1
molasses13
New Member
molasses13 is on a distinguished road
 
molasses13's Avatar
 
Join Date: Sep 2011
Location: Sydney, Nova Scotia
Posts: 5

2001 SL2
Default 2001 Saturn SL2 -code P0300 and P0340

Hi there, my 2001 saturn sl2 is giving me the 2 codes P0300 and P0340, I was wondering if anyone can help give me some suggestions on what to try and fix. I know the codes are saying random/multiple misfires detected and cam postion sensor which it doesnt have one and uses a coil for it. Some back ground to the car. It has 190000KM on it, its a 5 speed, it sat in a damp garage for the past year and half.

what has been done to try and fix these codes.
1 added supreme and an octane booster to fuel (encase it went stale)
2 new plugs,also put plug one of the old ones and plug 2 to see if it was a defective plug
3 changed spark plugs
4 removed and cleaned coil bank
5 removed and cleaned EGR
6 cut exhaust off in front of catalytic converter(sounded clogged and was heating up the pipe red before and after the cat.
7 carb cleaner
8 changed air filter
9 oil changed

the problem with the car is when it starts it sounds bogged down, when it gets to about 2500rpm it sounds ok but feels like no power, any Rpm lower than that it wants to cut out and you can put the pedal to the floor and it takes about 5 secs or longer to get to 2000 rpm, it really hesitates.

Any suggestions will greatly help

REWARD EXCELLENCE!

Add to molasses13's Reputation
Rate the quality of this post and help molasses13 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
molasses13 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 09-26-2011, 12:26 AM   #2
SCpunk2001
Member
SCpunk2001 is on a distinguished road
 
Join Date: Aug 2011
Posts: 95

2001 SC2
Default Re: 2001 Saturn SL2 -code P0300 and P0340

Same code,same exact symptom. Most likely bad ICM, coil, or plug wires. An easy oldschool way to figure it out is, with the car running, remove one wire at a time from the plugs. If the car starts to stall, that wire/coil is generally working. If there is no change at all, that wire/coil is generally NOT working.

REWARD EXCELLENCE!

Add to SCpunk2001's Reputation
Rate the quality of this post and help SCpunk2001 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
SCpunk2001 is offline   Reply With Quote
Old 09-26-2011, 08:21 AM   #3
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 42,439
 

2003 L-Series 3.0L Sedan
Default Re: 2001 Saturn SL2 -code P0300 and P0340

1-Replace the original faulty plastic coolant sensor with a flat nosed brass one if it wasn't done.

2-Replace the thermostat if the temperature gauge hovers over the 1/4 mark.

Both items cause a rich running condition.

3-Cleaning the ignition coils is only half way. Clean the ignition control module of corrosion too.

4-Did you remove the catalytic converter or not? If not, a combination of high mileage and sitting in a garage for a long time may have taken its toll on the catcon. The worst case would be the internals crumbled and is now loosely rattling around (bang the bottom to check for loose cat guts) to block off exhaust flow. Removing the front O2 sensor for a brief LOUD drive can confirm either the same problem or renewed power. Renewed power just means the catcon needs to be replaced.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 09-26-2011, 03:57 PM   #4
molasses13
New Member
molasses13 is on a distinguished road
 
molasses13's Avatar
 
Join Date: Sep 2011
Location: Sydney, Nova Scotia
Posts: 5

2001 SL2
Default Re: 2001 Saturn SL2 -code P0300 and P0340

Thanks for the suggestions, will give them a try tomorrow night. I cut the whole exhaust off a little bit before the cat and nothing changed.

REWARD EXCELLENCE!

Add to molasses13's Reputation
Rate the quality of this post and help molasses13 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
molasses13 is offline   Reply With Quote
Old 07-21-2015, 10:59 PM   #5
bail0251
New Member
bail0251 is on a distinguished road
 
bail0251's Avatar
 
Join Date: Dec 2010
Location: Rochester, MN
Posts: 5

2001 SL
Default Re: 2001 Saturn SL2 -code P0300 and P0340

My '01 SL w 215K was running fine. Last week I started it up and immediately noticed rough idling. I thought it might just need to warm up, but it continued and there was little power when on the gas. I turned around and brought the car home before I got to the end of the block. SES was flashing before I could shut it off.

Among scarier problems, coil packs came to mind because I just moved from dry assed Utah, back to rainy and humid MN. I waited a few days until it was sunny and dry and started it up with no improvement.

Hooked up a reader and I pulled the P0300 and P0340 codes as well.

replaced plugs and wires with no improvement.

took a chance on replacing the coil packs and all symptoms and codes disappeared.

Thanks for the help, guys!

REWARD EXCELLENCE!

Add to bail0251's Reputation
Rate the quality of this post and help bail0251 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bail0251 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
p0340 code dbaier S-Series Tech 1 02-22-2010 04:13 AM
P0340 ses code H-Dogg S-Series Tech 1 05-22-2009 03:08 AM
Continuous SES code p0340 plainzwalker S-Series General 3 05-06-2005 05:03 PM
Still need help with P0340 code jegster S-Series Tech 7 07-01-2003 11:39 PM
SES P0340 code help jegster S-Series Tech 8 04-22-2003 09:45 PM


All times are GMT -4. The time now is 04:42 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.