SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Categories > General Saturn Discussion
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Closed Thread
 
Thread Tools Display Modes
Old 03-25-2003, 11:09 AM   #1
Alchik
New Member
Alchik is on a distinguished road
 
Join Date: Jul 2002
Location: Georgia/Canada
Posts: 6
Dizzy Suddenly running rough and hard starting

Hi,

My wife's 92 SL2 suddenly became hard to start. It sounds like it's not getting gas, spark or something. It turns over fine so the battery is good. It's sporadic right now. Sometimes it starts just fine. Also, after this hard start it coughs and sounds like it's going to die for a bit then it revs up like the choke is stuck. When you drive it after one of these starts it downshifts (automatic) hard when stopping with high revs. It has about 135,000miles on it.
At first I thought it may be the PCM but after reading a few threads I read where EGR valves on this model could be the culprit.
Any thoughts, ideas or suggestions would be greatly appreciated! I'd hate to pay an arm and a leg to get it fixed just to find out it was a part that cost less that $50 that I could replace myself.

Thanks,

Alchik

REWARD EXCELLENCE!

Add to Alchik's Reputation
Rate the quality of this post and help Alchik reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Alchik is offline  
SaturnFans.com Sponsored Links
Old 03-25-2003, 11:27 AM   #2
Qlara
Master Member
Qlara is on a distinguished road
 
Qlara's Avatar
 
Join Date: Oct 2000
Location: Earth
Posts: 5,905
 
Default

I'd suggest you get a new set of spark wires.
If plugs are not replaced yet, do it too.

REWARD EXCELLENCE!

Add to Qlara's Reputation
Rate the quality of this post and help Qlara reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Qlara is offline  
Old 03-25-2003, 11:48 AM   #3
brentg
Member
brentg is on a distinguished road
 
Join Date: May 2001
Posts: 258
 
Default

check the fuel pressure regulator. is it spitting gas out of the vacuum line?

REWARD EXCELLENCE!

Add to brentg's Reputation
Rate the quality of this post and help brentg reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
brentg is offline  
Old 04-02-2003, 03:27 PM   #4
Alchik
New Member
Alchik is on a distinguished road
 
Join Date: Jul 2002
Location: Georgia/Canada
Posts: 6
Default

Turns out it was the Coolant Temperature Sensor. Once it was replaced it started running smoothly again. Hmm, I never would have thought that....

Thanks for the suggestions (I did check those!)!

REWARD EXCELLENCE!

Add to Alchik's Reputation
Rate the quality of this post and help Alchik reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Alchik is offline  
Closed Thread



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1992 SL1 not starting/stopped suddenly amrjohal S-Series Tech 4 05-02-2008 09:55 AM
95 SW2 Suddenly running rough lemonhead S-Series Tech 2 09-10-2006 12:01 PM
Suddenly hard to shift into gear 85_SS S-Series Tech 2 06-01-2006 07:42 AM
95 SL1 suddenly running rough Av8r S-Series Tech 6 02-01-2005 03:38 PM
Hard - rough starting ION Ion General 3 06-01-2003 03:23 PM


All times are GMT -4. The time now is 10:59 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.