SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 04-11-2013, 02:11 PM   #1
sdowiat
Junior Member
sdowiat is on a distinguished road
 
Join Date: Jan 2010
Posts: 34
Default 94 S Cooling

Mine is a 94 5speed. Lots of miles ( about 250k ) but still runs good and gets 40 mpg. ( I can make it get 45 )

A couple of years I had to change the radiator. Not sure why, but since that time it doesn't cool as well as it should. Where it used to normally run with the temp gauge dead in the middle... now it wants to run higher. The electric fan does work, it's on continually whenever the AC is on and it comes on when the temp gauge is at about 3/4 and if the outside temp is 85 or higher it will get to the red... so I'll turn the heater on to pull it back down.

I've never had the red light come on, ( I watch the gauge ).. but it sure a pain running the heat in hot weather...

Questions: Do you think the new radiator capacity is too low? Can you replace the sensor with one that makes the fan come on at a significantly lower temp? Can you easily rig the fan to come on when you flip a switch, or rig it to run all the time?

REWARD EXCELLENCE!

Add to sdowiat's Reputation
Rate the quality of this post and help sdowiat reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
sdowiat is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 04-11-2013, 03:12 PM   #2
OldNuc
Super Member
OldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond reputeOldNuc has a reputation beyond repute
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 64,919
 

1998 SC2
Default Re: 94 S Cooling

First thing to do is replace the 2 wire temperature sensor, ECTS. While replacing it also carefully inspect the connector for any minute signs of moisture or corrosion.

http://www.youtube.com/watch?v=cucm7QGlsYs

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
92' SL1 cooling fan Phoenix_SL S-Series Tech 3 04-24-2012 02:53 AM
Cooling...EGR....SL1 saturn94v S-Series Tech 6 03-04-2011 11:07 AM
Cooling fan won't come on! GoldenSaturn94 S-Series General 9 09-15-2005 06:02 AM
Cooling Fan How-To? texlnghorn S-Series Tech 3 04-13-2005 08:56 AM
Cooling fan does not come on.. Rob130 S-Series General 7 03-22-2005 03:36 PM


All times are GMT -5. The time now is 01:06 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.