SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Closed Thread
 
Thread Tools Display Modes
Old 07-16-2002, 10:17 AM   #1
joshc
New Member
joshc is on a distinguished road
 
Join Date: May 2002
Location: Columbia,MO
Posts: 7
Dizzy Faulty Blinkers????

I bought a used 2000 LS1 and I love it.
I was driving the other day and tried to use the blinkers,
but it just clicked really fast and there was no blinking green arrow. Both the left and right did the same thing. Upon pulling over, I found that neither the left or right turn signals were blinking. Both the rear and front signals were out. I was totally unable to signal to anybody that i was turning. First thing I thought was the fuse. I found that the fuse was fine, when I pulled the fuse, it wouldnt even click fast. So I switched the fuse with another one just in case and still no turn signals. I tried to show my wife that the blinkers were not working and all of a sudden they were working fine!! But, ever since then its been off and on, sometimes they work other times they are completely dead and all i hear is a fast click. Anybody else ever had the same problem????

REWARD EXCELLENCE!

Add to joshc's Reputation
Rate the quality of this post and help joshc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
joshc is offline  
SaturnFans.com Sponsored Links
Old 07-16-2002, 10:35 AM   #2
spencerb
Master Member
spencerb will become famous soon enoughspencerb will become famous soon enough
 
spencerb's Avatar
 
Join Date: Mar 2000
Location: Memphis, TN
Posts: 5,007
 

2008 Astra XR
Default

Some cars use fast blinking as a signal that a bulb is burned out. You may have a loose or bad bulb.

REWARD EXCELLENCE!

Add to spencerb's Reputation
Rate the quality of this post and help spencerb reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
spencerb is offline  
Old 07-16-2002, 10:45 AM   #3
Galileo
Master Member
Galileo is on a distinguished road
 
Galileo's Avatar
 
Join Date: Feb 2002
Location: York, PA
Posts: 2,069
 

2007 AURA XE
Default

Since none of your turn signals are working when this occurs, you may need to replace the turn signal stalk which includes the T/S switch. Try using your Hazzards to see if all the bulbs are operational.

...
Beautiful People First~

REWARD EXCELLENCE!

Add to Galileo's Reputation
Rate the quality of this post and help Galileo reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Galileo is offline  
Old 07-16-2002, 11:44 AM   #4
Qlara
Master Member
Qlara is on a distinguished road
 
Qlara's Avatar
 
Join Date: Oct 2000
Location: Earth
Posts: 5,905
 
Idea

Possibly the Flasher unit (usually located near the same inner fuse relay box) is at fault.

Have you tried the Hazard lights to confirm no signal bulbs have burnt out?

REWARD EXCELLENCE!

Add to Qlara's Reputation
Rate the quality of this post and help Qlara reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Qlara is offline  
Old 07-16-2002, 11:50 AM   #5
Spanky
Member
Spanky is on a distinguished road
 
Spanky's Avatar
 
Join Date: Aug 2001
Location: Detroit
Posts: 400
Default

I agree, check the flasher.

REWARD EXCELLENCE!

Add to Spanky's Reputation
Rate the quality of this post and help Spanky reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Spanky is offline  
Old 07-16-2002, 08:30 PM   #6
wolfman
Super Member
wolfman is a glorious beacon of lightwolfman is a glorious beacon of lightwolfman is a glorious beacon of lightwolfman is a glorious beacon of lightwolfman is a glorious beacon of lightwolfman is a glorious beacon of light
 
wolfman's Avatar
 
Join Date: Jun 2002
Location: Texas
Posts: 12,066
 
Default

1 more educated vote for the flasher....

...
Old Saturns never die, people KILL them, so check your damn oil!
"Unthinking respect for authority is the greatest enemy of truth." Albert Einstein

REWARD EXCELLENCE!

Add to wolfman's Reputation
Rate the quality of this post and help wolfman reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
wolfman is offline  
Old 07-17-2002, 09:06 AM   #7
ricksLS1
Master Member
ricksLS1 has a spectacular aura aboutricksLS1 has a spectacular aura about
 
ricksLS1's Avatar
 
Join Date: Dec 2000
Location: NY
Posts: 5,576
 
Default

Do the Hazards work? I had the problem with the directionals (Arrows inside were on solid I believe and did not flash) and the hazards and the fix was a new Hazard warning switch. They tie in somehow I guess. Is the light off on the harard switch? That was another thing I noticed. This is the only thing the dealer could fix on the 1st shot!

Last edited by ricksLS1; 07-17-2002 at 09:13 AM..

REWARD EXCELLENCE!

Add to ricksLS1's Reputation
Rate the quality of this post and help ricksLS1 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ricksLS1 is offline  
Old 07-17-2002, 11:38 AM   #8
Qlara
Master Member
Qlara is on a distinguished road
 
Qlara's Avatar
 
Join Date: Oct 2000
Location: Earth
Posts: 5,905
 
Happy

Actually that's right, L-series' hazard switch is a 'Light' unit with different wiring....compare to S-series Toggle-type simple hazard switch.....

Guess it's another Quality-related issue.

REWARD EXCELLENCE!

Add to Qlara's Reputation
Rate the quality of this post and help Qlara reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Qlara is offline  
Old 07-17-2002, 12:12 PM   #9
ricksLS1
Master Member
ricksLS1 has a spectacular aura aboutricksLS1 has a spectacular aura about
 
ricksLS1's Avatar
 
Join Date: Dec 2000
Location: NY
Posts: 5,576
 
Default

Quote:
Originally posted by qlara
Actually that's right, L-series' hazard switch is a 'Light' unit with different wiring....compare to S-series Toggle-type simple hazard switch.....

Guess it's another Quality-related issue.
I think there is a TSB or even a re-call on this (I never got a recall notice. Here is what the repair invoice says:


Customer states directionals and hazards not working

Cause: Low\Insufficent Sealant

TECH COMM: Nesscasary to R and R Hazard Switch Asm to CRR

Repair: Switch replace hazzard warning

Part 90584073 Switch Assemby

REWARD EXCELLENCE!

Add to ricksLS1's Reputation
Rate the quality of this post and help ricksLS1 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ricksLS1 is offline  
Old 07-17-2002, 04:06 PM   #10
Qlara
Master Member
Qlara is on a distinguished road
 
Qlara's Avatar
 
Join Date: Oct 2000
Location: Earth
Posts: 5,905
 
Happy

And this TSB is for what year and trim in L?

REWARD EXCELLENCE!

Add to Qlara's Reputation
Rate the quality of this post and help Qlara reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Qlara is offline  
Old 07-18-2002, 09:11 AM   #11
ricksLS1
Master Member
ricksLS1 has a spectacular aura aboutricksLS1 has a spectacular aura about
 
ricksLS1's Avatar
 
Join Date: Dec 2000
Location: NY
Posts: 5,576
 
Default

Quote:
Originally posted by qlara
And this TSB is for what year and trim in L?
QLARA ... If you go to a link call All-data you can find information on recalls. If you want to learn about recalls and TSB's I suggest you look at it. Several people in this forum find it useful. Here is the info from alldata.

00-C-03 JUL 99 Recall - Replacement Of Hazard Warning Switch Assembly

It's on all 3 trim levels of the 2000 models LS,LS1 and LS2.

PS: As I said mine wasn't recalled and it went bad. Maybe for a different reason. Unless you pay you can't get more info than I supplied

http://www.alldata.com/recalls/

REWARD EXCELLENCE!

Add to ricksLS1's Reputation
Rate the quality of this post and help ricksLS1 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ricksLS1 is offline  
Old 07-18-2002, 07:59 PM   #12
WeeeZer14
Advanced Member
WeeeZer14 is on a distinguished road
 
WeeeZer14's Avatar
 
Join Date: Jan 2002
Location: New Jersey
Posts: 624
 

2003 VUE 2.2L
2002 L-Series 2.2L Sedan
Default

Hrm... I really need to ask my dealer 'bout this. I have had it happen twice to me in my 2002 L200. Once was in the dead of winter the first time I tried to use my signals one day -- rapid clicking like the relay was going crazy. Just turned the signal on and off a few times and it worked just fine. Figured the relay was frozen or something

Anyway, last week or so, I was again using my signals for the first time of the day and same thing -- rapid clicking to the point of being a buzz. Turned signal on and off a few times, no change. Then I hit the hazard button and it worked fine. Turned off hazards and the signals worked fine. This time temperatures have maybe been in the 70's at night and usually in the 90's during the day.

Otherwise signals always work and I use them to signal every turn and lane change unlike most people in NJ

REWARD EXCELLENCE!

Add to WeeeZer14's Reputation
Rate the quality of this post and help WeeeZer14 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
WeeeZer14 is offline  
Closed Thread



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Blinkers and Flashers out. Need help please geektastic dave S-Series General 5 01-07-2008 09:21 AM
Blinkers not working on a pontiac 6000 91 92[SL2] S-Series Tech 1 05-12-2007 01:41 AM
Clear side markers (NOT blinkers) - legal in NJ? BODKAx3BEPb S-Series General 12 06-05-2006 11:29 PM
LED Blinkers? Esca Ion General 3 12-07-2004 11:27 AM
turn signals - blinkers duffygirl Ion General 30 04-28-2004 07:03 AM


All times are GMT -4. The time now is 05:15 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.